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1.1

1.2
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RED Relay Tool Overview

Description

These tools are used for relay units regarding:

¢ Configuration for using in control system
e Parametrisation

e Creation of needed process objects

Features/Options

e On-line parametrisation

e Off-line parametrisation

e Upload/Download all parameters

e Upload/Download group of parameters

e Selection of setting group

e Reset of registers (user settable)

e Tool can be started from a process picture (LIB 510/MicroSCADA)
e Alarm indication (in the station picture)

e Authorization support

e Compare

e Parametrisation of times nominal values and primary values
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2.1

Environments

Starting from LIB 510 in MicroSCADA

The relay units are displayed as push-buttons in the station picture (see the following
picture).

Main Options Engineering Reports Stations Sinmlation Help

S |len| 99-06-21 12:42:22 Eastwick 110/20kV Monday (W25)
Ack. {Alarm) 99-06-18 12:03:08 Eastwick Outgoing HA2 I» TRIP + Station
Remote
110KV ' 20KV
Hi1 H2 H3 H4 HAL HA2 HA3 HA4 HAS HAG HA7
Ramote Ramote Remote Remote Raemote Ramote Ramote Remote Remote Ramote Ramote
Main
Reserve
() I Il s I e IRy o Il B I I |
Q3 Q3 Q3 Q3
Qo ¥ (eli] a0 a0 * a0 a0 an an an an (eli]
! 1‘ 1‘ ol 1, ar br &5
[0)] 1) 1) ) ) ° . ® ® .
Hol (o (o B 1] 1) 1) 0] 0] 1] D
az Gz 1 Q2 1
= _\las Nt 1| @a _\1@9 _\1@9 _\laa _\1@9
a9 = @g = @
E s s v L v v
A push button
! 0.0 kV
Manual
Pos. 12
T
Ak Ik Np
Sitation 4if "I.I.
Figure 1. The station picture including a relay unit push button

In case objects need updating, a dialog box as presented in Figure 2 appears when
pressing the relay units’ push-button. Objects can be updated either manually in the
Picture Editor or automatically by selecting Yes in the following dialog. In case
objects are updated manually in the Picture Editor, the whole configuration procedure
has to be updated. In case the automatic updating is selected, a dialog box confirming
that updating was successful appears to the screen (Figure 3).

ABB Automation 7
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TUTOR [1] / EAS_Q1_R1 - Tool Menu |

& The object needs updatingl

Do you want to update it now?

| = I | Ho I

Figure 2. The dialog indicating that an object needs updating

TUTOR [1] f EAS_Q1_R1 - Tool Menu l

@ Ohject haz been zucceszfully updated!

Figure 3.  Dialog box indicating that an object has been updated successfully

After the object has been updated successfully or a picture function has been clicked
in the station picture (in case updating was not necessary), the Tool Menu dialog box
(Figure 4) for the chosen object appears on the screen. This dialog box contains a list
of tools available for the relay unit.

1510_401_1[1] f Eas_OQ1_R1 - Tool Menu Ed

Object |dentification: Eastwick 01 =

Tools: [

Helay Setting Tool

Help

Figure 4.  The Tool Menu for a relay unit object

Select the desired tool and click Run if you want to change or view the Relay unit
setting parameters. The main view of the Tool is shown in the Figure 9 further on in
this manual.

ABB Automation
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2.2 Starting from CAP 501/505, SMS 510
i Project Structure Havigator - Master Design Yiew
Eile Edit ‘iews Sestem Toolz Help
m 'Fﬁ (-‘:..F\b -En.F\-l:
Froject Structure . Object Tools
=3 Root =
l-lE Station 2efting T oo
=3By Frelay Mimic E ditor
tg SPAC 53R Fielay Configuration Tool
C:ACAPROENPRIMSOST
PrStidani tif

Figure 5. Starting Relay Setting Tool from the Project Structure Navigator
Navigate to the desired relay object in the Project Structure navigation tree on the left

and select it. The tools that are available for the selected object appear into the Object
Tools list box on the right. Open the Relay Setting Tool by clicking it in the list.

ABB Automation 9
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3.1

3.2

3.2.1
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Relay Setting Tool

General

The HMI of a RED Relay unit is built up with the same menu structure as the local
HMI. The available RED Relay configurations are included in the object types (e.g.
REF54x) of the SW Package SM/RED. The representation of the parameters in the
Relay Setting Tool is based on HMI files (Menu, Image, Index and Help files). These
files are included in the used relay configuration. The Active Menu File, which is
needed to present the HMI in Relay Setting Tool, must be build when a new relay unit
object is selected for this tool for the first time or when the relay unit object
application has been reconfigured. The active menu file is built by using the HMI files
as input.

Start-up

Build Active Menu

The message in Figure 6 and the Build Active Menu File dialog box appear if the
active menu of the used relay configuration is not found. Click Build in the Build
Active Menu File dialog box to build the active menu for the relay configuration. This
dialog box will also open in the menu Options.

. Mezszage

Cannot find Active kenu file!
&fter you build the file, you can continue the

prograrm.

Figure 6.  Active menu of the used relay configuration has not been found
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] Build Active Menu File

— Source M| Files

Menn |Image I Index | Helpl

Fath:

| ChechLIE 44 fmodsSM_RE DYREFS4:h5w D 85071 0071 \MMINENSMEMLLMI

Help I
Relay Type: Software MNr: Wersion: State:
| REF543 | 1MAS5118500-001 Co0aag 1]
D ate: Author:
119.12.1997 | “RED 500"

— Built Active Menu File
Path:
| WSCAWPLAETO 401 _14WPROTECTIOMYPRINOBIOOZ2%M M INACT IVESE MW SACT IVE bbd|

File Created; | 00-00-00 00:00:00 Status: | File not found

— Files Used

Menu |Image I Index | HeIpI

Relay Type: Software Mr; ersion; State:

Drate: Authar:

Figure 7. The dialog box for building the Active Menu File

Import Relay Parameter Settings from External Programs

The relay parametrisation that is made by another program (e.g. Event Editor) can be
imported to the Relay Setting Tool. This import function appears automatically at
startup. Click Yes if you want to update the columns New Values by these values.
The dialog box will appear only once.

l:[‘_j Relay Setting Tool

'Event Editor' has configured [37-11-13 12:54: 28] the
following relay unit parameter ;

Eventmask 1 [F1200101] = 536870911

Are pou sure you want to import the walue to the Relay
Setting Tool?

es | Mo I

Figure 8. The dialog for importing relay settings

ABB Automation
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3.3 Main View
» TUTOR [1] f EAS_Q1_R1 - Relay Setting Tool _ O] x]
Eile Wievws Transfers Tools Oplions Help —————— ]
EENEIEIE JTED [#]
Status |Pn:u1pu:tiun lib. |Cnmr|:|l lib, | Cand.monit, lik, IMeasumments lib | Communic, lib, | Standard lib, Information —E
z 4
3
—ij— 5
[
* REF543 |Uploaded: 00-00-00 qﬁémi%ﬁf

Figure 9. The main view for the Relay Setting Tool
The main view includes the following functions:
1. Menu bar
The menu with commands for the Relay Setting Tool.
2. Toolbar

A bar with buttons that perform some of the most common tasks.

Button Functionality

Import parameters

&

Export parameters

Printing

0|

ABB Automation 13
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g Upload (receive) parameters
— Download (send) parameters

&

3. Relay unit menu tabbed pages

These pages represent the functions of the selected relay unit. The function to be
operated is selected by clicking the page tab.

The tool also shows the name of the selected object and relay unit in the header field.
4. Minimise button

The relay tool can be minimised to an icon in the station picture.

5. Tool area

The relay tool is opened into this part of the HMI. The Setting tool function offers a
complete tool for monitoring and configuring the relay unit.

6. Status bar

The status bar shows information about the current situation in the Relay Setting
Tool. The status bar has two fields. The first one shows information of the relay unit
type e.g. REF 541. The second field shows the upload status of the parameters. The
status might be:

e Uploaded 00-00-00 00:00:00, when the parameters of the selected page have been
read from the default file.

e Uploaded 00-00-00 00.00.00, when the parameters of the selected page have been
uploaded from the relay

‘ | StatuzB ar.tif

| \REF541 | Upload dane: 00-00-00 00:00:00

14

Figure 10. The status bar
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4 Using Relay Setting Tool

4.1 File Menu

The file menu contains the functions belonging to file handling.

Page Setup...
Print Setup...
Prirt... Ctil+F

Exit FileMenu tif

Figure 11.  The File menu

4.1.1 Import...

Selection Functionality

Import Opens a parameter database for importing parameters. The parameter file is
selected on the Import dialog (shown in Figure 12.).

ﬁlmpurt H[=] E3
History  Special  Wiew “olumes
MISCY
[53 HMl 1]
() REFG4%
<
Open:
*RDEB
Dpen Apply | | Cancel |
IripaDily fif

Figure 12.  The Import dialog for the import function

Access: User level 2.

ABB Automation 15
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4.1.2 Export...

Selection

Functionality

Export

Saves all parameters for exporting into the file being currently
selected. The file name can be selected from the dialog, which is
opened first.

Access: User level 2

The default directory for the user files is /apl/’apl name’/protection/prj/obj0000/misc.

: Save Ag M=l E3
Hiztory  Special  View Volumes
MISC | ]

3 Hl -
4

Save 4%

I | | | Caricel
Savefzihy i

Figure 13.  The Save as dialog for the export function

Access: User level 2.
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4.1.3 Page Setup...
Selection Functionality
Page Setup Opens a dialog in which page setup as to margins (Top, Left, Bottom,
Right) can be defined.

», Page Setup
— Margins

Top: |20 e Bottam: |20 E
Let: |50 = Right: |20 =

ok || Cancel I

Figure 14. Page Setup dialog

4.1.4 Print Setup...

Selection Functionality

Print Setup Opens a dialog in which print setup for the paper as well as for the
printer can be defined, if the option VS Local has been selected in the
MicroSCADA Monitor (Figure 16).

Print Setup HE

— Printer
Marne: HP Lazerlet 551 M, Properties I

Statuz: R eady
Type: HPF Lazerlet 55 b

Where:  red-las
Comment;
— Paper Orientation
Size: I,.-.‘.,q L‘ &% Portrait
Source: l.-'-‘-.utu:umatically Select ;I = Landscape

Metworl,.. i 0k l Cancel

Figure 15.  Print Setup dialog

NOTE! In case the option VS Remote has been selected in the MicroSCADA
Monitor dialog (Figure 16), the option Print Setup in the File menu is unavailable, and
the dialog presented in Figure 17 pops up. In this case, information concerning the
printer is given in the MicroSCADA Monitor dialog (the last field on the left-hand
side of the dialog in Figure 16).

ABB Automation 17
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MicroSCADA Monitor
— Pre Defined kaonitar

[ InUsze Sething I
_ Carcel |

Cancel

— Manitar Type Metwark Mode Mame
" 5 Local MicraGCADA; |FIMITRYSA-w283
" 55 Femole
~ .‘>< """""""""""" Dizplay: IFIMITHVSA-W2E!3:D

Application #: IDEfauIt 'I Application kMonitar #: IDEfauIt "I

Ficture Size: |54E| by 480 pivels j

WS Printer: ILF'T1:

Figure 16. VS Remote monitor selected in the MicroSCADA Monitor dialog

> Relay Setting Tool

The print setup dialog cannot be opened when
using the ¥3 Remate monitor.

Please, select the printer using the MicroSCaba
MONOr wincdow.

Figure 17. Dialog indicating that print setup cannot be opened when VS Remote
Monitor has been selected

18 ABB Automation
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4.1.5 Print...
Selection Functionality
Print Opens a dialog in which it is possible to select printing of the current

ABB Automation

page, all pages or of certain pages (the page numbers can be
entered in the field). It is also possible to select whether present
values, new values, or both present and new values are printed.
When selecting printing of both present and new values, printing
requires more pages than selecting printing of either present values
or new values.

* Print

— Tabbed Page Range

C t P
gﬂﬁrrgn = Cancel I
OPages| Help I

Type page numbers andfor page ranges
separated by commas. For example:
1.25-12

— Print

(® FPresent Walues
) Mesw Walues
() Present and MNew Yalues

Figure 18.  Print dialog

Print HE

r— Printer
Properties |

Mame:

Statuz Ready
Type: HF Lazerlet 55i ks
Wherer  rad-las

Commert; [ Frint ta file

r— Print range Copies

= 4 Mumber of copies: |1 3:

TR i ;

S ) g
Selection

Ok I Cancel

Figure 19. Print dialog 2

After the desired printing option has been selected and OK has been pressed in the
Print dialog (Figure 18), the second Print dialog (Figure 19) pops up. In this dialog
printing is either confirmed or cancelled.

Printouts can be made from a Visual SCIL tool, such as the RED Relay Tool, to a

local or network printer defined in the operating system. The availability of printers
and the configuration work needed depends on which context the MicroSCADA

19
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monitor is opened to. This varies in different MicroSCADA technology products as in
the following.

CAP 501, CAP 505 and SMS 510

In these products a tool is always opened to the context of the current operating
system user, i.e. the user that has logged in to the operating system. In this case all the
printers that are provided by the operating system to the user are available also for
printing from the tools.

LIB 510/MicroSCADA

In these products a monitor is by default opened to the context of the MicroSCADA
user i.e. the user with the user name “MicroSCADA?. In this case only local printers
can be used for printing from RED Relay Tool. Local printers are:

e Printers connected directly to computer's serial or parallel port
e Network printers defined as local port.

The procedure how to define a network printer as local port is described in section 3.4
in the SYS 500 8.4.3 System Management Operator’s Manual (IMRS751258-MUM).

If a monitor is opened from command prompt or from SCIL with an operating system
call, it can be opened to the context of the current operating system user. This requires
that the command line option start as logon user is used when opening the monitor.
Further details for the opening of monitors can be found in section 2.6.2 in the SYS
500 8.4.3 System Management Operator’s Manual (IMRS751258-MUM). When a
monitor is opened to the context of the current operating system user, printers can be
used as in CAP 501, CAP 505 and SMS 500.

When Local priters are used, the MicroSCADA user should have access to these

printers.

ABB Automation
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4.1.6 Exit...
Selection Functionality
Exit Exits the Relay Setting Tool and returns to the station picture from
where the tool is started.
Er] Relay Setting Tool
Lvee | [ w0 |
Figure 20. The Exit dialog
Access: No limitations
4.2 View Menu
The View menu contains a selection of views for the currently selected relay
configuration. The All view is always available and it shows all parameters of the
active menu. The other possible views are subviews of the All view and they are user-
specific. These additional alternatives may be added by using the Options/Menu
configuration (described further on in this manual).
Main settings/ Overcurrent protection
Main settings/ Directional earth-fault protection
Figure 21.  The View menu
4.3 Transfer Menu

ABB Automation

The Transfer menu contains commands used to communicate with the relay unit. The
offered selections below the line in the menu are user-specific. These additional
possibilities are to be added by using the Options/Menu configuration (described
further on in this manual).

Tranzfers
Upload...
Download...
Stare...

Fezet...

Figure 22.  The Transfers menu, the Reset... selection is shown as an example of an
user-specific configuration

21
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Upload
Selection Functionality
Upload Connects to the selected unit and uploads (receives):
1) parameters that are defined in the current page
2) all parameters
3) parameters on the entered pages.
— Tabbed Fage Range
0Ok,
(® Cument page -
Al Cancel I
Vi

Type page numbers and/or page ranges separated
by commas. For example: 1,25-12

Fiead parameters from the relay unit

Figure 23.  The dialog box for selecting the uploading method

Access: User level 0.

Download
Selection Functionality
Download Connects to the selected relay unit and downloads (sends):
1) parameters that are defined in the current page
2) all parameters
3) parameters on the entered pages.
H Download
— Tabbed Page Range
0K
(® Cument page -
O &l Cancel I
v

Type page numberz and/or page ranges separated
by commas. Far example: 1,2.5-12

Send parameters ta the relay unit

Figure 24.  The Dialog box for selecting the downloading method

Access: User level 2.

After uploading/downloading has been started, the dialog shown in Figure 25 appears
on the screen. The dialog gives the user information of the current operation

(uploading/downloading). It also shows how downloading proceeds. The Stop button
cancels the operation and removes the dialog.

ABB Automation
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Uploading:  FO31%471

21 & completed

Figure 25.  The communication dialog

If the communication error is such that the relay unit does not answer, a dialog that
invokes the user to select whether to Retry or Cancel the downloading process is
opened.

If an error occurs during communication (the relay answers with the NAK code), the
error dialog is shown with the possibility to either skip, retry or cancel the reading.

8 Communication Error %] |

DE narme: FOOTw 015
Error Code 932 The unit did not respond.

| Retmy I| Cancel I

Figure 26.  An example of a Communication Error dialog

S8 Communication Error |

DE narme: F231%003

Error Code B Slave does not contain all data
requested in the meszage.

| Skip I| Rty I| Cancel I

Figure 27.  The Communication Error dialog

After the uploading/downloading process is completed, the dialog is closed and the
tool area is updated.

23
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Store

NOTE! Applies only to certain relays.

Selection Functionality

Store

relays.

Stores settings to the non-volatile memory in the relay unit. Clicking
Close in the Storing dialog box does not cancel storing operation in the
relay unit, but then it cannot be guaranteed that storing has been
completed successfully (Figure 28). This function is not provided by all

= Store

)

Are pou zure pou want bo gtore the parameter
values ta the non-volatile memary?

W aiting for acknowledgement reply...

Time remaining: 531

LCloze |

Figure 29. The dialog box indicating progress in the storing process

Clicking the Close button in Figure 29 does not interrupt the storing operation, but
asks the user whether he wants to close the dialog or not (Figure 30). The dialog can
be closed by selecting Yes, but the user will not receive any information whether
storing was successful or not. By selecting No, the program will return to the Storing
dialog (Figure 29).

Are pou sure pou do nat want boowait for the
acknowledgement reply?

Clicking YES will not cancel the storing, but you will not
recelve any acknowledaement reply fram the relay unit.

Figure 30

Dialog asking whether you want to close the storing dialog

ABB Automation
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F[‘_j Mezszage

O Storing completed succeszsfullyl

Figure 31. Success!

Reset (Example)

Selection Functionality

Reset... Opens a dialog box for some general resetting operations. Select the
wanted action and click Send. NOTE! This is an example how
additional selections can be used.

i Aeset...

Action:

Reset reqisters

c
Fezet outputs
Reset indication

Reset reqisters _
FODTVI13 =1

Figure 32.  The dialog box for resetting relay unit

[ %]

Confirm

Are pou sure pau want to perfarm ‘Heset
indication”?

| ez I | Ho |

Figure 33.  The Confirm dialog box in which the selected action can be confirmed

Tools Menu

The Tools menu contains miscellaneous tools and commands.

Compare...

Edit Histary
Wiew Transdyc

Figure 34. Tools menu

25
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44.1 Compare
Selection Functionality
Compare The purpose of this function is to check that the values in the parameter

26

file and in the relay are the same. In the Compare dialog there are two
tabs, one for Present Values and the other for New Values. Present
Values tab shows the differences between the Present Values in the file
and the values in the relay. New Values tab shows the differences
between the New Values in the file and the values in the relay.

*» Compare
Present Values |New Yalues |
# Parameter | DB Mame | File Yalue | Relay Value |
¥
| Compare || Close |

Figure 35. Compare dialog in which the comparing process can be started by
pressing the Compare button

In the Present Values and in the New Values tabs there are several fields in which the
character # stands for a consecutive number, the second field (called Parameter)
indicates the description of the parameter, and the Database name is presented in the
third field. File Value is given in the fourth field, and the Relay Value is given in the
last field. The values will be shown only if the values in the parameter file differ form
the values in the relay. In case there has been an error during the reading process, an
error message will be shown in the Relay Value field. The comparing process can be
started by pressing the Compare button in the lower part of the dialog. To exit the
dialog without starting the comparing process, press Close.

* Compare E

Uploading:
FO33avom

40 % Complete

stop_|

Figure 36. Compare Uploading dialog

By clicking a field in the Present Values or New Values tab, the field is activated
(shown in blue as presented in the following figure) and a menu path is shown in the
field on the left-hand side in the lower part of the dialog. The time when the File
Value was updated last time is shown in the field on the right-hand side of the dialog.
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¥ Compare
Present Values |New Valuesl
# | Parameter DB Mame | File Value Relay Value |
1 Cycle count Flzoyviie | o 9 lhd
2 | Command timeout| FOOTY013 | 500 ms =
3 | Finaltestdate | FO
4 Urre Fooavooz
5 | Primary current | FOO3Y012
B | Primary current | FO03Y022 | 500 A
7 second. current | FOOSIYVO31 | 1 A
@ | Primary current | FOD3Y032 | 70 A
3 Current terminal | FOOIVO33 | 1 A
10 | Second. current | FOO3Y041 | 1 A Ei
Menu Path: MaIN MENUNConfigurationiMeas. devices\Current trafal File Yalue Uploaded 96-06-05 130112
| Compare || Close I

Figure 37. Compare Present Values dialog

* Compare
Present Yalues | Hevs \I’aluesl
s Farameter DE Mame | File Yalue | Relay Value |
1 Cycle count F1zovo1ez | o k] i
Z Command timeoy FOO1%013 | 500 100 s —
3 Final test date | FOO1%005 | 0 19371212
4 | Primary current | FO03YO0Z | 500 os
fi Primary current | FOO3Y022 | &00 )
7 Second. current FOO3Y031 | 2 3 A
i Primary current | FOO3¥032 | 70 )
k] Current terminal| FO03%033 | 1 3 A
10 | Second. current] FOOSY041 | 2 ah 3
Menu Path: MaIN MENUWConfigurationiteas. devices\Current trafo2 |_
Compare || Close |

Figure 38. Compare New Values dialog

To exit the dialog, click Close.
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Edit History
Selection Functionality
Edit history Made changes are collected and presented in the Edit history dialog.
These changes remain in the dialog only until the end of the session
(i.e. they are not saved).

Er] Edit History

Parameter DB Mame Prezent W alus MHew Value Uploaded
Operation mode | FO325041 Drefinite time Mot in uge 00-00-00 00: 0000 |+
Start cunment FO325042 070 ®lk = 30 A | 013 %ln = B4 A 00-00-00 00 20: 00

Clear I | LClose

Figure 39. Edit History dialog

To erase all information from the dialog, click Clear. The dialog can be closed by
clicking Close.

View Transducers

Selection

Functionality

View Transducers

Nominal values can be viewed in the View Transducers dialog.
These nominal values are used when calculating primary values for
certain parameters (Figure 53, note 6). Values are defined in the
Object Configuration Tool, please refer to SM/RED Configuration
Manual (LMRS751392-MEN).

» Transducers

— hlominal values

Iy | 300
lova: |50
Uy |1
Uow: |1

Figure 40. Transducers dialog

To exit the dialog, click Close.
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Options Menu

The Options menu contains miscellaneous tools and commands.

Resize Dialog Box...
Rebuld Active Menu...
Mernu Configurats

Figure 41.  The Options menu

Resize Dialog Box

Selection Functionality

Resize Dialog Box Opens a dialog in which the size of the dialog box can be changed
(see Figure 42).

Access: User level 1.

=" Resize Dialog Box

Dialog Box b= GO0

v = G00

— Mew Size:

[~ Use default size
| 800 % | 600

[ Use thiz size at next startup

Figure 42.  The dialog box for resizing the Relay Setting Tool

Rebuild Active Menu

Selection Functionality

Rebuild Active Menu Opens a dialog box, where the building of the Active Menu File
is started. This file is needed to present the HMI in the Relay
Setting Tool. The dialog box is automatically opened at the
startup of the relay setting tool if the relay unit application has
been reconfigured.

Under Source HMI files there is a tab page for every HMI file. These tab pages
contain information about file location, relay type, software number, version and
state, date of creation and author. These files are used when building the new active
menu.
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Under Build Active Menu File there is information about the current active menu file:
file location, date of creation and status. Details of used HMI files, on the basis of
which the current active menu file has been created, can be found under Files Used.

Access: User level 1.

4 Rebuild Active Menu File

— Source Ml Files

Henullmae Index | Hel

=1
Path:

| CASCALIBAAFMODYSM_REDAREFS4XASWAS 1100014 MMIALANGDMMENU. M

Relay Type: Software Mr: Wersion: State:
| REF541 | 1MAS0S0100-4x 10 00
Drate: Author:

| 19970217 | MITRSEMU

— Built Active Menu File

Path:
CASCALIBAAFMODYS M _REDYREFS4:0S5W A5 110001 AN MINLANG DWACT IVE MMI

File Created: | 570324 16:11:20  Status: | OK

— Files Uzed
Menu |Image | Index |He||:- |
Fielay Type: Software Mr Werzion: State:
| REF541 | MRS 090100k 10 00
Drater Authar:
| 1997-02:17 | MITRSEML

Figure 43.  The dialog box for building the Active Menu File

Menu Configuration

Selection Functionality

Menu Configuration With this function the user has the possibility to customise the
View and Transfers menu options. All menu configuration settings
apply only to the object that has been selected in a station picture
(in LIB/MicroSCADA environment) or in the navigation tree (in
CAP 501/505 environment).

Access: User level 2.

An example of how to add a function to the View menu will be given in the
following. The method is the same for both View and Transfers. Several new
selections can be added to the menus. It is also possible to delete inactual selections
from the menus.
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453.1 Menu Configuration/View Menu

B Menu Configuration

Yiew Menu | Tranzfers kMenu

Cloze
— Menu Commands _

tain Setings/0vercurrent protectior Remove...

tain Settings/E arth-fault protection o

— Configurations
Mew Canfig 1 Create
M ain/MOC3Low
M ain/MEFTLow Remove...

Properties. ..

[=
(=8

Figure 44.  Adding a new configuration to the list of Configurations

Start by creating a new configuration with the function Create. After Create is
pressed, the “raw material” New Configl is added to the Configurations list. Select
this item and click Properties.

Er] Properties

Mame:
— Menu Tree — Parameters Cancel

[ Status + [ Sw vergign
[ Pratectian lib. [ SW TEVISION
(3 Cantral b, [® Serial number
[ Measurements b
[ Commuric. b,
[ Tests

= D |nformation

D Identification
0
[]Ps14]

[ JEI01[8]

[ JBI02[7]

[ ] MIMIC[17)
R e T e +

: B

| tMaIN MEMUM nfomiationsCRUT [3]

Figure 45.  Giving the properties for Serial number
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Table 1 The function Properties has the following fields and functions:

Selection Functionality

Name Give a useful name for the configured function, otherwise it will remain
as e.g. New Configl. In the example mentioned above the name Serial
number has been given by the user.

Menu Tree Navigate in the menu tree and select the wanted function.

Parameters The selectable parameters are shown in this field. Select the ones
needed.

OK Verify the choices made.

Cancel Regret and return without changes.

After New Configl has been configured, it will have the name Serial number. The
following step is to prepare the Menu Commands. Start by pressing Add, and the New

Command1 appears on the list.

Er{ Menu Configuration

View Menu | Transfers Menu

— benu Commandsz

Properties...

Mew Commandi

All
tain Settings/0vercurent pratectior Bemove...
Main 5ettingz/E arth-fault protection

— Configurations

Senal number LCreate

Main/MNOC3Low
ain/MEFT Low Remove...
Froperties. ..
+]

[

Cloze

Figure 46. A new menu item New Command 1 is added to the Menu Commands, but
it still has to be prepared with the help of the Properties functions

Select New Command]1 and press Properties.
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] Menu Properties

Wigw name; Ok

| Show zenal number

Bind to Configurations:

|4u

b ainMOCILov
ainMEFTLow

Figure 47.  Giving the name for the menu function and binding it to the appropriate
configuration

Table 2 Menu Properties contains the following fields and functions:

Selection Functionality

View name Replace the New Commandl with the name you intend to
present in the View menu.

Bind to Configurations You will now have to bind a configuration with the menu
selection.

OK Verify your changes/setup

Cancel Regret and leave without changes

The new menu selection is at your disposal after ending the Options/Menu
configuration function.

Main settings/ Overcurrent protection
Main settings/ Directional earth-fault protection

Figure 48.  The new menu selection is at your disposal

Menu Configuration/Transfers Menu
The user has the possibility of preparing a Transfers menu of his/her own. The

method is exactly the same as described in the previous section regarding the View
menu. Please refer to that part for detailed information.
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Er] Menu Configuration

Wiew Menu  Transfers Henul

— Menu Commands

Mew Config 1

Fezet/General

Diavanload. ..
Bemove...
""""""""""""""""""""" Properties...
Reset
— Configurations

Remove...

Froperties...

[

LCreate

LCloze

Figure 49. The Transfers menu is customized in the same way as the View menu. In
this connection the option Properties has slightly different functions as in

the View menu, see Figure 46

Select Properties for the created New Config 1, see Figure 50:

Er] Properties

M arne:

| Outputs/Events

— Source

F124v105 - Evert mask 3 i
F1248107 - Event mask 4
F1275003 - Event delay
F127v012 - Cycle count
F127¢101 - Event mask 1
F127103 - Event mask 2
F127105 - Event mask 3

F127107 - Event mask 4
F1E2v099 - Alarm ack,
F1E2¥101 - Event mask 1
F1E2A103 - Event mask 2
F1E2105 - Event mask 3
F1E2¢107 - Event mask. 4
F1E3w099 - Alarm ack, >

— Target

Cancel

Output 10
Output &
Ewvent mask 3

| Event mask 4

|F127v107

Figure 50. Giving the properties for the new configuration
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Table 3 The fields and functions are used in the following way:

Selection Functionality

Name Give a useful name for your configured function, otherwise it will remain
as e.g. New Config 1. In the example above the name Outputs/Events
is given by the user.

Source Select the wanted parameters or items to be added to the Target list by
the Add button
Target The Target list contains a list of all added items from the Source list. By

selecting the items one by one, the text can be edited. The field for the
parameter code, e.g. F127V107 cannot be edited, but the value in the
field to the left can be changed. Apply has to be used for verifying each
change of an item on the Target list.

Add Adds the selected item from the Source list to the Target list
Remove Removes the selected item from the Target list

OK Verify your selections and modifications made

Cancel Regret and return without changes, also those done by Apply

Remarks regarding Figure 50:

As it can be seen in the Source list in Figure 50, a huge amount of parameters/items is
selectable and can be added to the Target list. Normally, the idea is not to make
parametrisation of the relay parameters via the Transfers menu even if it is possible,
but to enable e.g. resetting of registers, indications etc. in the relay. Relay
parametrisation and monitoring is described further on in chapter 4.7. Furthermore,
the user should check that the value of each parameter/item in the Target list has the
right value (in the field on the right side of the parameter code). In other words, the
user should ensure that the parameter/item has the value the user wants to send to the
relay. The default value is not always the wanted one. The values can, of course, be
changed afterwards, whenever necessary. It is also recommended to take into
consideration that giving “wrong” value may result in that the expected result remains
unfulfilled when executing the menu selection in the Transfers menu.

4.6 Help

The Help menu contains an on-line help for the tool functions.

About Setting Tag)

Figure 51.  The Help menu

4.6.1 About Setting Tool
Selection Functionality
About Setting Tool Gives information regarding the setting tool.

Access: No limitations.
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aﬁhnut Relay Setting Tool

T ool Informatian

Relay Setting Tool
1D:
Copyright;

REMMI [1.2.8]

ARE Subsztation Automation Oy

System |nformation

Licenzed to:

Froduct revizion:

Base spstem:
IC:

ABE Substation Automation Oy

ABE FISUB aaza

CaP_505 200 Development

8.4.3 2000-0-3
21000000

Lot 4

Figure 52.  About Relay Setting Tool dialog box

Monitoring and Changing Parameters

The RED Relay Setting Tool gives the relay engineer a powerful tool for monitoring

and configuring the relay un

RED Menus

its.

When a menu from the Relay Setting Tool is selected, a menu hierarchy of the
functions (Figure 53, note 1) available for the relay unit is displayed in the tool area.
Each function holds several tabbed pages of configurable parameters.

Tabbed Pages

The Relay Setting Tool Main View contains tabbed pages. The hierarchy and the
number of these tabbed pages depends on the selected relay. A tabbed page can be
selected by clicking the wanted page with the mouse, e.g. page 41 (see note 2 in
Figure 53). Note 3 in Figure 53 indicates the last page (214).
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UTOR [1] / ¥AA_SU_R1 - Relay Setting Tool
le  Wiew Transfers Toole Options Help

‘ﬁﬂﬂﬂ@ﬂ%i% [MAIN MENU [#]
Statug . Protection lib. ’Eontlol lib. 1 Cond.maonit. lib. ; Measurements lib i Communic. lib. i Standard lib. 1 Infarmatian i IE
AREFUn | pEFaHigh | DEF2Low NOC3High  |nocans | MoC3Low I
Ol ssting | [41] Setting groupl [[42)Settng qow2 |3l Contolseting | (dliputdsis | (51 0uputdas | (L20[2])
tenu Fath: MalM MENU‘Protectinn lib. SMOC3HightS etting group1 41,214 :
Drezcription DB Mame Present ¥alue Mew W alue Range "
Operation mods FO325041 | Defirite time | Definite time i [#]
Start cirrent FO325042 : oo n1a -‘\ win (010 .. 4000
|30 [ 54 A (30... 12000)
: : i
Dperatt time FO325043 (005 [ 0.05 5 (0,05 ... 300.00)

\REF543 | Uploaded: 00-00-00 0C:00:00

Figure 53.  Relay Setting Tool Main View

4.7.3 Parametrisation

The Setting Tool pictures hold a field indicating the Present Values and a field
indicating the New Values. After changing the New Values, the changes have to be
downloaded to the relay unit. Downloading is done by the function Download
parameters (which can be found in the Transfers menu). The Present Values are also
updated when the values are downloaded.

If there are multiple choices, the suitable alternative can be selected from the drop-
down combo box (see note 4 in Figure 53). If the relay unit is protected by a
password, the password is asked before the changes are downloaded. The dialog in
which a new value can be entered (Figure 54) can be brought out by pressing the left
mouse button on the field (note 5 in Figure 53) and by pressing any key.

e Note 4 in Figure 53: The value changes color when selected. A suitable alternative
can be selected in the drop-down combo box.

e Note 5 in Figure 53: The dialog presenting possible alternatives for the new value.
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e Note 6 in Figure 53: Primary value. Whether this is in use or not is defined in the

Object Configuration Tool.

Er] New Yalue

Start current  [FO3B5072)

Type a new value;
11.4 Zln [1.0..700.0]

0k l | Cancel

Figure 54.  The input field of the Setting Tool
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PQ-Monitoring Tool in LIB510/MicroSCADA

General

The Power Quality Monitoring Tool is used to visualise the data generated by PQ
IEDs (Power Quality Intelligent Electronic Devices) and uploaded by MicroSCADA.

Startup

The tool is started by first clicking the relay units' push-button in the station picture
and then by selecting the PQ-Monitoring Tool from the opened dialog box and
clicking Run.

+510_403 1[1] /ESTHO2_R1 - Tool Menu

Object Identification:  E ashwick Outgoing 110k

Toolz: Cancel
Relay Setting Tool ’:

PO-Monitaring Tool

|:|I:U
=
=]

PCbaT ool 4

Figure 55. Tool Menu for a relay unit object

If the selected relay unit does not have any PQ-Monitoring Function, the Monitoring
Tool will not open and the following dialog box will appear.

@ Error Dialog
e Mo Power Quality functions available on
ESTHOZ_R1
OF.
ErvarDil tif

Figure 56.  An indication dialog box for PQ function not available
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@51 0_403 1[1]1/ES5THOZ_R1 - PQ-Monitoring Tool

File  Wiew Optionz Help

3

Main View

@ | |2

Orline 3 zec. Walues | Onlire 10 min. Walues @Harmonic Yiolation ¥ EWalues | Maximum Walues | Selected Harmanic

POYO3H

Yaltage wavefarm distartion measurement @

PCihlin g i

40

Figure 57.  Main view of the PQO-Monitoring Tool

This is a main view of the tool when Voltage waveform distortion measurement is
selected (the other implemented function, Current waveform distortion measurement,
looks exactly same). The main view consists of the following functions:

1. Menu bar

A set of menus for basic functions of the tool.
2. Toolbar

A bar of buttons for commonly used operations.
3. Tabbed page

A tabbed page where each tab opens a new visualisation area depending on the used
monitoring function.
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4. Visualisation area
An area where the monitored data is displayed.

5. Status bar

A bar where some various monitoring information is displayed.
5.3.1 Menu Bar

The Menu bar includes the following menus.
5.3.11

File Menu

The File menu contains the file handling functions.

Print... Ctrl+P

E zit F‘QFiIeMe.ﬁﬂ

Figure 58.  File Menu

Selection Functionality

Print Setup Opens a dialog in which the used printer setup can be modified if

the used MicroSCADA Monitor type is VS Local.

ABB Automation

Print 5etup
Frinter
Mame: HP Lazeret 5/5M PostScript Properties
Statuz: Ready
Type: HF Lazerl et 5/5M PostScript
Where:  Whfirnibrte] -2007 \tre-lag
Cornment;
Paper Orientation
Size: | s =] .I & Paortrait
Source: | Automatically Select | " Landzcape
Metvaark. .. | ] | Cancel
PrirtSet i

Figure 59. Print Setup dialog box

If the used MicroSCADA Monitor type is VS Remote, the following error dialog box

appears.
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>< Error Dialog

e The print setup dialog is not available on ¥
Remote monitor. Please, select the printer in
MicroSCADA Monitor window when starting a V35
Remaote monitor.

Ok

Etralily2 4f

Figure 60. Print Setup error dialog box

When the VS Remote monitor is used the printer selection must be done when starting
the MicroSCADA monitor.

MicroSCADA Monitor

Pre Defined Manitar

[ InUse Carcel

konitar Type Mebwork Mode Mame

" WS Local MicroS CaDd: |FIMIT-FITF|-WEIEI1EI
v %S Femote

Iy Drizplay: |FIMIT-FITFE-WIJEI'I .0

Application #: [Default = | Application Moniter #: [Default =

Picture Size: |Ee1III by 480 pivels ﬂ

WS Printer:

W5Printe A

Figure 61. VS Printer selection in MicroSCADA VS Remote Monitor startup
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Selection Functionality

Print Opens a printing dialog of the current page where the setup can
also be changed (VS Local Monitor type). If the used Monitor type
is VS Remote, the Print dialog is different.

Printer

 arne: HF Lazerlet 550 PostScript Properties

Statuz: Ready
Type: HF Lazerl et 5/5M PostScript
Where:  Whfirnibrte] -2007 \tre-lag

Cornmert: [ Prirt ta file
Print range Copies
Ol | Murnber of copies: 1 3:

o~

1 2 <] I
- R|p
| k. | Cancel

PrindCy 4f

Figure 62.  Print dialog box on a VS Local Monitor

»¢ Print
\%l) Frint selected page
Ok Cancel

PrirdFan fif

Figure 63. The Print dialog on a VS Remote Monitor
NOTE! Printing needs info from the active menu of the used relay. If the active menu

file of the relay is not found, an error dialog pops up and the menu should be build by
the Relay Setting Tool.

43



RED Relay Tool 1MRS751383-MUM

5 PQ-Monitoring Tool in Operator's Manual
LIB510/MicroSCADA

M Error Dialog

Q Error in reading Active Menu file. Please, use the
Felap Setting Tool o build an Active Menu file.

OF.

ErroDly3 G

Figure 64. Error dialog when Active Menu file was not found

Selection Functionality

Exit Exits the PQ-Monitor Tool.

! ‘_\ Do pou really want o exit?

ez Ho

EcitP Cirl T fiF

Figure 65. Exit dialog box

5.3.1.2 View Menu

The available PQ-Monitoring functions are listed and selectable in the View menu of
the tool.

Figure 66. View Menu

Selection Functionality

PQVO3H Opens a view of "Voltage waveform distortion measurement".
The monitorable PQ indices can be seen and selected on the tabs
of the opened page.

PQCU3H Opens a view of "Current waveform distortion measurement”. The
monitorable PQ indices can be seen and selected on the tabs of
the opened page.
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Options Menu

This menu includes some configurable options of the PQ-Monitoring Tool.

Optioks

¥ Enable automated data upload on POYO3H Harmanic violation evert

+ Enable automated data upload on POYVO3H Obs. period ended event
Enable automated data upload on PACUZEH Harmonic violation event
Enable automated data upload on POCUSH Obs. period ended gygik &

Figure 67. Options Menu

The automated data uploading is started on "Harmonic violation" and "Obs. Period
ended" events. On this menu the auto-upload feature can be enabled or disabled
(toggled on and off) by selecting the modifiable item. On the menu above, the first 2
items are enabled and the last two disabled.

NOTE! Enabling and disabling automated data upload is only allowed on

authorisation level Engineering (2) (or higher). If the level is inadequate, the
following error dialog is opened.

M Information Dialog

\i,) E nabling or dizabling automated data upload
needs Engineenng [2] nghts

O,

InfoDle gF

Figure 68. Insufficient user rights to change the auto-upload option

Help Menu

The Help menu includes the on-line help of the tool functions.

‘ About PO-Monitoring Tool... |

Figure 69. Help Menu

Selection Functionality

Help Opens a dialog containing the on-line help of the tool functions.
About PQ- Opens a dialog containing some general information of the PQ-
Monitoring Tool Monitoring Tool.
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5.3.2 Toolbar
The Toolbar includes the commonly used buttons presented in the following:
Button Functionality
—; Exit
¢
E Print Setup
é Print
g Upload
The first three buttons do the same file handling functions as the choices in the File
menu and the fourth button is used to upload on-line data from the relay unit.
Some further info is also viewed on the toolbar. The presented info depends on what
is being monitored. If the on-line values are viewed, the information of "Measured
input" is shown. In the case of harmonic violation the "Violation Period" is shown and
can be selected from the toolbar. If the values from a certain period are monitored, the
"Observation Period" is shown and selectable on the toolbar.
Viclafion Period  [1395121010,19.00.694 - 19361290 101916477 ]
Figure 70. Information of the selected Harmonic Violation Period
5.3.3 Tabbed Page
A tabbed page is opened when a selection of the monitoring function (Voltage or
Current waveform distortion measurement) is done from the View menu. By clicking
the wanted tab, the actual page for visualisation opens.
Online 3 sec. Yalues | Ornline 10 ik, Y alues | Harmanic Yialation | & % Walues | b axirnum 4 alues | Selected Happomic, _ﬁf|
Figure 71.  The list of of monitored data on Voltage or Current Harmonics
If there is no saved data for a Harmonic Violation Period or an Observation Period the
following information dialog is opened.
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M Information Dialog
\ll) Mo heeded data available!
Ok
InfaDlg2 4

Figure 72.  An information dialog of saved data not available

534 Visualisation Area

This is the area where the actual results are being visualised. The uploaded or saved
data is shown on a bar chart of harmonics or on a cumulative curve of the selected
harmonic.

The bar chart of a Harmonic Violation Period consists of bars and a curve.
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@51 0_403 1[1]1/ES5THOZ_R1 - PQ-Monitoring Tool

File  Wiew Optionz Help

Yiolation Period 13331210 10:13:00.634 - 13331210 10:13:16.477 | E

Online 3 sec. Yalues | Dnline 10 min. Yalues Harmonic Yiolation | % Valugs | Maximum Yalues | Selected Harmaonic
Zln

80— A

G0 - =

40

20

00 ! I — . —

THD 2nd 3id 4th Bth Btk Ttk Sth Sth 10th Ttk 12th 13th

PEIOEH Yaltage wavefarm distartion measurement M awirnum wvalues ab 1933-12-1010.19:08.156

HarmiPe

Figure 73. A bar chart of a Selected Harmonic Violation Period

In this picture, the height of each bar describes the magnitude of a harmonic value.
The values under the adjustable limits (yellow lines) are shown with green bars and
the values over the limits with red bars. The continuous black curve describes the
limits of the EN 50160 Standard for each harmonic.

A picture of a Selected Harmonic during a selected Observation Period is shown
below.
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Figure 74. A cumulative curve of selected harmonic during an Observation Period
(Requirements fulfilled)

This curve is drawn according to five percentiles (1%, 5%, 50%, 95% and 99%)
calculated by the relay unit. The adjusted limit value for a selected harmonic is shown
with a red horizontal line. If the 95% percentile value for the selected harmonic is
under the adjusted limit, the cumulative curve is blue and the requirements are

fulfilled.

If the 95% percentile value for the selected harmonic exceeds the adjusted limit, the
cumulative curve changes to red and the requirements are not fulfilled.
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Figure 75. A cumulative curve of selected harmonic during an Observation Period
(Requirements not fulfilled)
5.3.5 Status Bar
Some various information is displayed on this bar depending on the monitoring
function.
POYWO3H Yoltage wavetorm distortion measurement b aimum walues at 1999-12-10 10.19.08.156
StatuBar if

Figure 76. A status bar info on a selected Harmonic Violation period

The status bar has always the information of the data generating Function Block and
the explanation. The rest depends on what is being monitored. If on-line values are
monitored, the status bar includes the info of the ending of current observation period.
When a harmonic violation period is displayed, the status bar has the time stamp of
the recorded maximum values. In the case of X % values, the adjusted X (percentile)
is shown. A number of the harmonic (or THD) is viewed when the curve of selected
harmonic is presented.

50 ABB Automation



1MRS751383-MUM

RED Relay Tool

Operator’'s Manual 5 PQ-Monitoring Tool in
LIB510/MicroSCADA

5.4

5.4.1

ABB Automation

Monitoring Functionality

After the PQ-Monitoring Tool has been started, the wanted monitoring function
should be selected from the View menu. By selecting the first or second tab from the
opened page, the on-line values from the relay can be uploaded. The on-line mode is
also indicated by the upload button that has just become enabled. The rest of the tabs
are used for saved data visualisation. When any of these tabbed pages is selected, the
upload button becomes disabled.

On-line Monitoring

The on-line monitoring is started by pressing the upload button on the toolbar. When
the uploading begins, the following indicator of the process proceeding pops up.

M Progress Indicator ]

| ploading:
FA131029

86 % Complete

I

Figure 77.  An indication dialog of the uploading process proceeding

Praglrdi

If the relay unit does not answer or there is some other communication problem, an
error dialog appears.

M Error Dialog

e Communication erarl

Ok

ErroDlg2 i

Figure 78.  An error dialog of communication problem

NOTE! The manual data uploading requires authorisation level Control (1) or higher.
Otherwise, the following information dialog is opened.
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M Information Dialog
\i_) bl anual uploading needs Contral [1] or higher
rights
OF.
IrfiCeley 3 i

Figure 79. Insufficient user rights to manual data uploading

5.4.2 Monitoring of Saved Data
The monitoring of previously saved data is done by selecting the wanted time period
from the dropdown list on the toolbar.
Yiolation Period [1993-12-10 10:19.00.694 - 13931210 10:13:16.477 B
19931210 10:18:12.996 - 19391210 10:18:20. 266 [+
Orline 10 min Yaluss | 1995121010:18:26,017 - 19991210 10:18:23.419 ro—
: 19991210 10:19:34.657 - 19391210 10:18:41 627
1999-12-10 10:18: 48,957 - 1999-12-10 10:18:55.867
1993-12-1010:19:00.634 - 1933-12-1010:19
1999-12-1010:19:24.869 - 1939-12-10 10:19:43.365
19991210 10:21:25.773 - 1999-12-1010:21:30.179
19991210 10:21:25 773 - 1933-12-1010:21:39 823 ||
1999-12-10 10:23:31 043 - 1933-12-1010:23: 38 £54 N
1999-12-10 11123:51 973 - 199312410 10:23: 57 531 +
SelPerio ff
Figure 80. Selection of a harmonic violation period from a dropdown list
When a period is selected, the progress indicator opens and the saved data is read
from the disk. After that, the results are ready to be visualised.
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