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About this User Manual

General

Any security measures described in this document, for example, for user access,
@ password security, network security, firewalls, virus protection, etc., represent
possible steps that a user of an 800xA System may want to consider based on a
risk assessment for a particular application and installation. This risk assessment,
as well as the proper implementation, configuration, installation, operation,
administration, and maintenance of all relevant security related equipment,
software, and procedures, are the responsibility of the user of the 800xA System.

This User Manual includes information as it pertains to maintaining 800xA Base
System and Functional Area software.

User Manual Conventions

Microsoft Windows conventions are normally used for the standard presentation of

material when entering text, key sequences, prompts, messages, menu items, screen
elements, etc.

Feature Pack

The Feature Pack content (including text, tables, and figures) included in this
User Manual is distinguished from the existing content using the following
two separators:

Feature Pack Functionality

<Feature Pack Content>

3BSE046784-510 E 13



Warning, Caution, Information, and Tip Icons About this User Manual

Feature Pack functionality included in an existing table is indicated using a

table footnote (*):
Feature Pack Functionality

*

Unless noted, all other information in this User Manual applies to 800xA Systems
with or without a Feature Pack installed.

Warning, Caution, Information, and Tip Icons

This User Manual includes Warning, Caution, and Information where appropriate
to point out safety related or other important information. It also includes Tip to
point out useful hints to the reader. The corresponding symbols should be
interpreted as follows:

Electrical warning icon indicates the presence of a hazard which could result in
electrical shock.

injury.

Caution icon indicates important information or warning related to the concept
discussed in the text. It might indicate the presence of a hazard which could
result in corruption of software or damage to equipment/property.

Information icon alerts the reader to pertinent facts and conditions.

Tip icon indicates advice on, for example, how to design your project or how to
use a certain function

: Warning icon indicates the presence of a hazard which could result in personal

Although Warning hazards are related to personal injury, and Caution hazards are
associated with equipment or property damage, it should be understood that
operation of damaged equipment could, under certain operational conditions, result
in degraded process performance leading to personal injury or death. Therefore,
fully comply with all Warning and Caution notices.

14 3BSE046784-510 E



About this User Manual Terminology

Terminology

A complete and comprehensive list of terms is included in System 800xA System
Guide Functional Description (3BSE038018%*). The listing includes terms and
definitions that apply to the 800xA System where the usage is different from
commonly accepted industry standard definitions and definitions given in standard
dictionaries such as Webster’s Dictionary of Computer Terms.

Released User Manuals and Release Notes

A complete list of all User Manuals and Release Notes applicable to System 800xA
is provided in System 800xA Released User Manuals and Release Notes
(3BUA000263%*).

System 800xA Released User Manuals and Release Notes (3BUA000263*) is
updated each time a document is updated or a new document is released.

It is in pdf format and is provided in the following ways:

e Included on the documentation media provided with the system and published
to ABB SolutionsBank when released as part of a major or minor release,
Service Pack, Feature Pack, or System Revision.

*  Published to ABB SolutionsBank when a User Manual or Release Note is
updated in between any of the release cycles listed in the first bullet.

ﬂ A product bulletin is published each time System 800xA Released User Manuals
and Release Notes (3BUA000263*) is updated and published to ABB
SolutionsBank.

3BSE046784-510 E 15



Released User Manuals and Release Notes About this User Manual
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Overview

Section 1 Introduction

This instruction includes information as it pertains to maintaining 800xA Base
System and Functional Area software. Information included in this instruction is as
follows:

System Check - To get full benefit of the system, it needs to be inspected on a
regular basis.

Operation System Update - It is increasingly important to keep the automation
systems current with available security updates. ABB validates security
updates from Microsoft with respect to relevance to and compatibility with
System 800xA. By properly upgrading an automation system installation with
security updates, it is possible to avoid or mitigate damage from attacks by
certain types of malicious software.

Node Restart and System Shutdown/Restart- Contains information on the order
to start and stop a node or system.

Import/Export - The Import/Export tool allows you to move applications to and
from any 800xA System. The data is saved as objects and aspects in archive
files (.afw). The Import/Export tool allows you to store and restore objects,
aspects, and entities. It is possible to view the contents of an archive file.

Backup and Restore - The backup and restore procedures consists of two
different parts; backup of standard Windows system and backup of the System
application data.

Single Node Replacement - This covers the procedures that must be performed
in order to recover from a node failure in a complete 800xA 5.1 System

3BSE046784-510 E
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Overview Section 1 Introduction

(including all functional area information). The three possible recovery paths
are as follows:

— Reinstall Like New.
— Reinstall and Restore.
—  Recover Node.

* Information Management - This section provides guidelines and reference
information related to configuring and maintaining Information Management
software.

Tools such as import/export and backup/restore, do not include referenced

generic elements. The user should manually include generic elements for the afw
file or ensure that the generic elements are already available in the target system.

18 3BSE046784-510 E



Introduction

Section 2 System Check

To get full benefit of the system, it needs to be inspected on a regular basis.

System Check List

Some useful recommendations are listed below:

On an 800xA System node:

Look at the system alarm, system event, and operator message lists for
information from the 800xA System.

Open the System Status Viewer for the Service Structure or the Node
Administrator Structure to see if any 800xA System service is not in service or
standby state.

On all 800xA System nodes:

Open the Service Connection view to see the status of the service provider
connections for the node.

Open the Task Manager and add following process columns to the default:
Peak Memory Usage, USER Objects, Virtual Memory Size, Handle Count,
Thread Count and GDI Objects.

Make a screen dump of the Task Manager Processes tab when the system is
started and use this dump as reference to compare later on to see if there are
any significant deviations.

While in the task manager switch to the performance tab. Look in the Commit
Charge square in the lower left corner. There are three values:

—  Total - Sum of all memory currently allocated by your processes.

3BSE046784-510 E
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System Check List

Section 2 System Check

— Peak - Highest total value achieved during the session.
—  Limit - Total amount of memory, physical and virtual, available.

It is recommended that the Total/Commit Charge always is kept below the
Total Physical Memory; i.e., more physical memory is added when necessary.

When the Total/Commit Charge is above the Total Physical memory, the page
file is constantly accessed to swap programs in and out of memory, eroding
disk i/o on the disk with the page file. The greater amount of memory used
above the Total Physical Memory, the worse the system performance.

If Peak/Commit Charge, at any time, reaches the Limit/Commit Charge value
you have an insufficient memory problem that might cause the processes to
crash or just stop working. The page file can be increased, to help with peak
memory usage. However, to avoid performance problems there should be
enough physical memory available where Total/Commit Charge is always less
than Total Physical Memory.

Go to Start > Settings > Control Panel > Administrative Tools > Event
Viewer and check for Errors Messages in the Application Log and the System
Log.

Go to Start > All Program > Accessories > System Tools > Disk
Defragmenter and defragment the disk.

The file system must be in a consistent state at all times. Defragment disks on a
regular basis using the defragmentation software provided with the operating
system.

Windows 7 defragmentation is enabled by default. Windows Server 2008
defragmentation is not enabled by default and can be enabled, if desired.

It is recommended to defragment the Aspect Directory before defragmenting the
hard drive where the Aspect Directory is stored. Refer to the Product Bulletin

800xA Operations, SV 3.x, 4.x, 5.x, Fragmented Aspect Directory Database
(3BSE059394) for the procedure on defragmenting the Aspect Directory.

—  Size disks so they will be 25 percent empty for defragmentation purposes.

—  Check the system for fragmented files on all nodes where trend and
history logs reside, and defragment the applicable disks as required.
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— History configuration impacts not only the History Server disks, but also
Connectivity Server disks where trend logs are configured. Therefore,
check the disks on Connectivity Servers where trend or history logs reside,
and defragment them as required.

—  Extensive use of the Bulk Configuration tool may cause disks to become
fragmented. Check the system for fragmented files after any such
procedure, and defragment disks as required.

—  Configuration procedures that involve creating, deleting, and then
recreating of a large quantity of objects may cause the associated disks to
become fragmented. Check the system for fragmented files after any such
procedure, and defragment disks as required.

—  Deleting and then creating the Aspect System may cause associated disks
to become fragmented. Check the system for fragmented files after any
such procedure, and defragment disks as required.

*  Go to Start > Settings > Control Panel > Administrative Tools > Computer
Management > Device Manager and check that no hardware errors are
indicated.

*  Inthe 800xA System search for the Process Portal crash dump files
(exceptions*.txt) in the following folders:

C:\ProgramData\ABB\Process Portal A\Dump\Crash
C:\ProgramData\ABB\Process Portal A\Dump\Hang

e Available disk size. Right-click on the local disk(s) via Windows Explorer and
select Properties to check the size of the disk(s).

e Memory and CPU usage for various processes will vary. Establish a baseline
and monitor them to determine how much memory growth and CPU load is
normal or can be expected on each node in your system.

If there is inconsistency or strange behavior in the system, close and reopen a
Workplace, restart a service or, in the worst case, restart a whole node.

It is also very important to do these inspections after a major disturbance in the
system such as lost main part of the communication or many servers have been
down (power, restart, etc.). After a disturbance, check the Workplaces if there are
red crosses over alarm bands or alarm sequence bars (suspect that the alarm and
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event list not updates properly), or white crosses on red background in process
displays or that trend displays not updating. In these cases, return to operation by
closing and reopening the Workplace.
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Introduction

It is increasingly important to keep the automation systems up-to-date with available
security updates. However, before an update is installed, it needs to be verified that
it does not interfere with the operation of the automation system.

Windows and 800xA System Updates

ABB validates security updates from Microsoft with respect to relevance to and
compatibility with System 800xA. For relevant updates that Microsoft classifies as
critical, the goal is to communicate to customers within 24 hours the plan for
validating each update, and within 7 days the result of the validation. For this
communication, the SolutionsBank/Field Alert, 3BSE041902, Microsoft Security
Updates Validation Status (continuously updated) instruction is available for
download via ABB SolutionsBank. It also provides possibilities for customers to
subscribe for e-mail notification on updates.

By properly upgrading an automation system installation with security updates, it is
possible to avoid or mitigate damage from attacks by certain types of malicious
software. However, the fact that a virus or worm at all finds it way into a system
indicates, that there is an underlying security problem in the installation or in how it
is managed. It is important to understand how a system becomes infected, and to
take measures to prevent it. The white paper IS Security Considerations for
Automation Systems (3BSE032547) provides advice on security measures that
should be considered by users of automation systems. The white paper is also
available for download via ABB SolutionsBank.
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Section 4 Node Restart and System
Shutdown/Restart

Introduction

This section contains information for restarting an individual node or stopping and
starting an 800xA System.

Node Restart

Perform the node restart in the order presented in this section.

Client
There are no tasks involved, simply restart the node by performing the following:
1. Select Start > Shut Down.

2. Select Restart from the drop-down list box and click OK.

ﬂ The time for a client to restart depends on the hardware but normally takes 1 to 3
minutes.

Redundant Aspect Server

1. Ensure that the redundant Aspect Servers are synchronized by opening the
System Status Viewer and checking that the synchronization is ready (all
services will be marked in green).

Do not restart the Aspect Server before synchronization is ready as this may
@ result in a loss of data or a system crash.

2. Select Start > Shut Down.
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3. Select Restart from the drop-down list box and click OK.

When the Aspect server is restarted it will start to synchronize with the already
running nodes. The synchronization normally takes about 5 to 15 minutes
depending on the system size.

Redundant Connectivity Server
Follow the same procedure as stated for the Redundant Aspect Server.

ﬂ Synchronization for a Connectivity Server normally takes about 3 to 7 minutes
depending on the system size.

Combined Aspect Server and Connectivity Server

Follow the same procedure as stated for the Redundant Aspect Server.

ﬂ Synchronization for a Combined Aspect/Connectivity Server normally takes
about 5 to 15 minutes depending on the system size.

ﬂ In case of node gets isolated (disconnected) from the client server network,
follow the steps below:

1. Shutdown the server.
2. Do a configuration change in the aspect directory.
3. Reconnect the server to the network.

4. Startup the server.

System Shutdown

Perform the following procedure when a shutdown of an 800xA System is required:

1. Stop all external clients to the 800xA System (OPC DA, HDA and AE clients
that access the 800xA System) before a system shutdown.

2. From the Configuration Wizard, select System Administration and click
Next.

3. Select the system to stop and click Next.
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4. Select Systems and click Next.
5. From the Systems dialog box, select Stop and click Next.

6. From the Apply Settings dialog box, click Finish.

ﬂ The 800xA System will shutdown within a couple of minutes. The time it takes to
shutdown my be more or less depending on the size of the 800xA System.

System Restart

To restart an already configured 800xA System that was previously shutdown,
perform the following procedure:

1. From the Configuration Wizard, select System Administration and click
Next.

Select the system to restart and click Next.
Select Systems and click Next.
From the Systems dialog box, select Start and click Next.

From the Apply Settings dialog box, click Finish.

AN O i

Start all external clients to the 800xA System that were previously shutdown
(OPC DA, HDA and AE clients that access the 800xA System).
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Section 5 Import/Export

Introduction

The Import/Export tool allows you to move applications (i.e. import and export
data) to and from any Industrial™ 800xA System. The data is saved as objects and
aspects in archive files (.afw). The Import/Export tool allows you to store and
restore objects, aspects and entities. It is also possible to view the contents of an
archive file.

Engineering Repository

The Engineering Repository simplifies the Import Export between systems and the
application backup by embedding the export import as context menus in
Workplaces.

Main differences between Import Export tool and Engineering Repository are:
*  Engineering respository focuses on entities as control applications, libraries.
*  Afw files gets created in the background. No file handling is necessary.

*  Engineering Repository is called up from the workplace context menu and not
from the toolbar.

*  Engineering Repository allows to define custom entities to manage objects
which are not in any entity.

*  Engineering Repository allows to define aspect category filters to prevent
aspects as e.g. Operator notes to be overwritten in production systems.

For more information about Engineering Repository, refer to System 800xA
Configuration (3BDS011222%).
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Application Change Management

Feature Pack Functionality

The Application Change Management (ACM) simplifies the Import Export between
systems and application backup by embedding the export import as context menus
in Workplaces.

Main differences between Import Export tool and ACM are:

Provision to archive multiple versions of an object/entity in afw file format.
Support for connecting more than one engineering system.

Baseline for system in ACM host and roll back to required older baseline.
Supports multiple versions of the configuration artifacts.

Supports Activity log.

For more information on ACM, refer to System 800xA Application Change
Management (2PAA108438%*).

Import/Export Tool Overview

®

®

The Import/Export tool should be used to transport small applications in the form of
object types and/or object instances between configurations. For backup and restore
actions, use the Backup/Restore tool described in Section 6, Backup and Restore.

Do not export or import very large amounts of aspect objects at the same time.
Operational disturbances might then occur because the Import/Export tool loads
the system significantly.

An upper limit of about 50 000 objects at a time is recommended.

Do not export standard objects that are created as a result of creating the Aspect
System, or as a result of adding the various system extensions.

In some configurations upload from an OPC server is used to create objects and
aspects. This applies for example when using Generic OPC to connect to a 3rd
party OPC server. If the uploaded objects have been extended with aspects such
as graphic displays, it is important to make the import and upload in the right
order. As a general rule the import should be done first and then the upload.
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may exist. Refer to the Consistency Check section of System 800xA Tools
(2PAA101888%*) for more information.

Export can be done by drag and drop from the Plant Explorer to the Import/Export
tool, via AfwExport.exe, or by using the Find Tool in the Plant Explorer. Import can
be done by selecting Import in the Import/Export Tool or via Afwlmport.exe.

@ Run a consistency check on all imported items after an import as inconsistencies

ﬂ If an object is a member of more than one structure, perform an export of that
object for each structure.

ﬂ Close your Plant Explorer when making a large import. If that is not possible,
close the application that you are importing to. For example, if you are importing
a control application, make sure the Control Structure in Plant Explorer is closed.

ﬂ To Import / Export VB graphic aspects, the user should belong to Windows Local
Administrators group.
The User Interface

The user interface is designed to resemble the Plant Explorer as much as possible.
The Import/Export tool has two views; Structured View and Entity View
(Overview).

o Overview

Figure 1 shows the Import/Export tool in the Overview. It consists of three main
areas; the entity area, the object browser and the aspect list.
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Figure 1. The Import/Export User Interface - Overview

The Overview presents the entity and entity extensions in the archive. This view
gives a simplified overview of the actual objects and aspects in the archive which is
of importance when working with engineering items such as libraries and control
applications. From this view it is easy to for example selectively import specific
control module types or function block types. In the case where the archive does not

contain any entities this view is disabled.

Archive files created before 800xA 5.0 will not have the meta-data information
about entities and therefore the Import/Export tool can not perform any entity-
specific actions for those files. This means that an AC 800M control library
exported before 800xA 5.0 will contain all objects and aspects that make up a
control library and the control types.

Because it was exported before entities existed the Import/Export tool will handle
them as objects and aspects when for example importing.
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Archive files created in 800xA 5.0 or later will contain all the necessary meta-data
information about entities and entity extensions to perform the necessary actions
when making changes to the archive file, for example deleting an entity extension,
or when importing an entity into the system.

o Structured View

Figure 2 shows the Import/Export tool in the Structured View.
It consists of two main areas; the Object Browser and the Aspect List.

The structure view presents all objects and aspects arranged in structures. The icons
of objects and aspects are only present if the application is connected to a running
system. Note that if the icons are in the archive they will not be extracted and the
generic object or aspect icons will be used.

Object Browser Aspect List

/

Figure 2. The Import/Export User Interface - Structured View
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The figure above shows the Import/Export tool with a file opened and an object
selected. The aspects of the selected object are shown in the aspect list. The window
at the bottom shows dependencies that are required in order to import the objects
and aspects into a system.

Reserve Information

When importing objects and aspects into a running system, the reservation state of
those objects and aspects (if present in the system) can be an important piece of
information.

Especially if there are objects and aspects that are reserved by another user because
that prevents any other user from overwriting those objects and aspects. The reserve
information can be displayed in the Import/Export tool if it is connected to a running
system, see Figure 3.
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Figure 3. Reserve Information

Production Specific Aspects

In a system with environments enabled, there are cases when aspects can only be
imported into the production environment. Any attempt to import such aspects into
any other environment will not work and the import will either fail or those specific
aspects must be skipped during the import.

If the Import/Export tool is connected to a system where environments are enabled,
it is possible to highlight those aspects to make it clear what objects and aspects that
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How to Use the Import/Export Tool

must be imported into the production system and what objects and aspects can be
imported to other environments such as the engineering environment. See Figure 4.
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Figure 4. Production Specific Aspects

How to Use the Import/Export Tool

Exporting objects and aspects are done by either using drag and drop from the Plant
Explorer or using the Add Items dialog, see Figure 5.
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% Add items

- Il AsA

| |
You are now adding the following itern(s): A48
Options

W Include dependencies W Include children

¥ Irnclude extenzions

2l

oK Cancel ‘

Figure 5. Add Items

In this dialog you can see a summary of what was dropped and also in what context.
You can choose to import a larger context than by using drag and drop. As an
example, if the you drop an object that is part of a Control Module Type created
through 800xA for AC 800M, the dialog will present the object dropped and the
context it lives in; the Control Module Type and the Library. It is then possible to
select to either add the Control Module Type or even the entire Library.

It is also possible for you to include or exclude dependencies, children or
extensions. Children is only available when an object or an entity has been dropped.
Extensions are only available when an entity has been dropped.

ﬂ Information about what references each aspect reports at the time of exports is
saved even if dependencies are excluded. This information is used later to

calculate missing dependencies and the import order.
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Select OK to start the Export. The Adding items dialog will appear.

Adding items...

v Pre process

P Process items

o )

[ Close when finished

@ 0 Emrors I M 0Wamings | (i) O Infarmation

I Time Description Error coc

Figure 6. Adding Items Dialog Box

In this dialog you can cancel the export by selecting the Cancel button.

The Main Menu, Toolbar and Context Menus

File Edit Wiew Tools Actions Help

Ty 7 & ']
d 2 W . & L [ e } @ & O e
Mew Open Sawe  Production Refresh  Import &l Differences  Messages | Dependencies | Find AddIkern  Print  Options = Help

Figure 7. The Main Menu and Toolbar

An action or option can be available from more than one place in the User Interface,
like the toolbar or the context menu. The action or option is described in the Menu

description.

The File Menu

The File menu includes the following options:

New. Click New to create an empty archive. If a file is already open and changes
have been made, the user will get a question about saving the file before closing it.
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Open. Click Open to open an archive file. If a file is already open and changes have
been made, the user will get a question about saving the file before closing it, then
the new file will be opened.

Close. Select Close to close the file. You will get a prompt to save the file if there
are unsaved changes.

Locate. Allows you to locate a specific object or aspect in any afw-file on disc.
From the result list it is possible to select the located archive file and open it to
perform further actions.

%4 Search for Afw-File

Allor patt of the file name; Name | InFolder Size

[x.dw

DObject or Aspect name:

[Prant” =l
* Objects " Aspects

Lok in:

=

Figure 8. Search for Afw-file Dialog Box
Save. Click Save to save the file to disk and to perform the actual export.

Save As. Click Save as to save the file with a new name and to perform the actual
export.

ﬂ When an afw-file is saved, the Import/Export tool makes sure that the entire
contents of the new file can be successfully written to the file-system. This is
done before it actually saves the new contents to a temporary file and overwrites
the old file. When the disc does not have enough space for the entire new file, a
Save As dialog will be presented, so that a new location with enough space can be
selected.

Properties. Select Properties from the menu to bring up the Properties dialog.
In this dialog it is possible to set the properties that will be saved with the file.

With every archive file, the following properties are saved:
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*  Source System Name

*  Source System id

¢ Source Environment name

e Source Environment id

e Creator

*  Short description of file (optional)
¢ Tool name and version

e  File Version

Properties for 'C:\ieTest_1_1.afw'

Mame:
Path:

Syskem:
System Id:

Environment:
Created by:
Modified:
Tool Mame:

Tool Version:
File: Wersion:

Meta Data:

Description:

Environment Id:

Setislized Data:

ieTest_1_1.afw
i

SEYST-W-D002972 System - Production
{CABCDECE-13FA-4B4E-A751-CA19FFBOCS21}

Production
{FE520D30-7BE4-4430-AZ 1E-62C1FZA1518A}

sevizha
47(2006 06: 26:46

AfwImnportExport
5.115.210.46
3.1.0.0

3 kb (67.45)%
1 kb {32.55)%

[ OF H Cancel ]

Figure 9. The Properties Dialog Box

files before they are converted.

The information in the Properties dialog box is also available via the context
menu of an archive file. This is a good way to get information about old archive

Exit. Select Exit to exit the tool. You will get a prompt to save the file if there are
unsaved changes.
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The Edit Menu

The Edit menu includes the following options:

Add Item. This option opens the Add Item dialog box in which you can add objects,
aspects, entities and entity extensions to the afw-file.

Remove. This option removes the specified aspect, node, entity or entity extension

from the archive file.

Select All. This option selects all objects (if you are in the object browser) and all
aspects (if you are in the aspect list).

Find . Select Find in the Edit Menu to bring up the Find Tool dialog. In this dialog
it is possible to search for objects and aspects within the archive file.

B Find Objects and Aspects

Aspeck Type
Sike

™ Structure +|
[ Modification Date 3 4|

[~ CreationDate  2003-04-74 +|

ANNRENNNNENEEN
Search

Hame:

Type

3
|

Area
Area
Area

Figure 10. The Find Dialog Box

The example above shows a search for all objects starting with the “a” letter of the
Area object type. The result is displayed in the list to the right.
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The View Menu

The View menu includes the following options:

Differences. When the Difference dialog is launched from the View Menu or the
Difference button in the toolbar, you can select to view differences between two
archive files, two items in the same file, or the open file, the entire archive and
another archive or a running system. See Figure 11.

Pk, Show Differences

Select Target
Select laget to compare with

Sploct Taek © Currert Archive

Spsteir [EatpelCon - Froduction

Erveonment  [Production

EITX
© Other Archive @ System
=
=
Ensh | Concel | Hep |

Figure 11. Show Differences Dialog Box - Entire Archive
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When launched from the context menu (see Figure 12), it is possible to show
differences between the selected aspect/object and another aspect/object that resides
in the current archive, another archive, or the system.
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Figure 12. Show Differences Dialog Box via the Context Menu

When you have selected Differences from the menu the Difference setup dialog box
will appear, see Figure 13. Depending on what you selected to show the differences
for, the setup dialog will contain the possibility to select what to compare with. For
example, if you selected a single aspect, the difference setup dialog will select the
corresponding aspect in the currently connected system. If you selected a single
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object, the dialog will select the corresponding object in the currently connected
system.

%1 Show Differences EEX
Select Target
Select Largel 1o compaie with
Eaelmoss  Cunert Archive C Oiherdchive & System
Systent Jtapecalp Prodhuction j
Ervrorment  [Froduction ~|
‘ e (1 Admin Struchae A Name Created
#-030 Aspect Systen Structue C Admn Stuctue 2/208/2008
£ & Conkrd Stucture Admn Shuctuie 2/28/2008
| B %) Corrol Stushee  2/28/2005 .
i 0o LonhrdFuund DA Domain Defriton  2/28/2005.
0 Functond S (] Domain Type Refe... 2/28/2006 .
(31 Graphics Sructue {Bal Functonal Structure. - 2/26/2006,
5 Libeay St . % Location Stuciure  2/28/2005
- 1 St T WiName 22002006
-0 Localion Siicture -
(4 Maintenance Siructure L System Stucture  2/208/2005

- 11 Nods Adminislation Shucture
(5 Object Thpe Structure

Eurish Cancel Help |

Figure 13. Show Differences for a Specific Item

The Settings tab in the Show Differences dialog contains the settings that should be
used when the difference report is created. The default values are usually enough for
most reports, but in some cases for example when there are a lot of objects and
aspects to compare, changing the settings to only show the information needed, will
increase the performance.

ﬂ If the System radio button is selected, uncheck the Show items that are in the
“target” location check box. Otherwise the capacity of the system might be
decreased.

Check the Exclude Aspect Structure check box to skip all structure aspects
when comparing objects.
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R Show Differences

Settings
Select how the compaizon should be made

EEX

—Seitings

¥ Include Chidten

¥ Include Extersions
I Inchide Monexportable Aspects
I Include Struchue Aspects

Details

¥ Show items that are in the ‘souice’ location
¥ Shows items that e in the target' location
¥ Show iems that are difierent

I~ Show tems that are equsl

Figure 14. Show Differences - Settings

When the correct settings are made for the report, select Finish. The difference
report will appear. The dialog can display the result in two different ways, the
normal structural view as shown in Figure 15 or as a list as shown in Figure 16.

Br, Differences between CiApp proj.afw and CarpeCorp - Production

G'H'a%.‘ﬁ@wlu O =] m |8 e
Fiter  Save | View Mods Eid | Added | Deleted | Corflict | Updated | Modfied Equal | Destination | Print  Help

=13

| Desciption

(| = Conliol Stucture Hame
% —@ Cantrol Network % Application
=@ PP [ % Conirol Buikder Name
& ?gﬁww dlspact Categosy Definibion
= &8 Co (3§ Hare
L“ Cariral &laimn Event

[ (41 Node Admiristration Structure

* Qj Object Type Structure (* Corirol Pioperiiss

[ Narme Uploadet

[? Coritrol &pplication Tyoe Reference

(5] e |

Figure 15. Difference Report - Structural View
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U, Differences between G:\pp praj.afw and CarpeCarp - Production
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Figure 16. Difference Report - List View

The toolbar contains a button for each type of difference. Each type of difference
can be toggled by pressing/depressing the corresponding button.

Added - The item only exits in the source and importing it will add it to
the destination.

Deleted - The item only exists in the destination and importing the archive
will delete that item. This typically applies for objects and aspects that are
part of entities or entity extensions.

Conflict - The item has been modified in the source and in the destination
independently. Importing the archive will by default overwrite the change
made in the destination.

Updated - The item has been modified in the destination but not in the
source, i.e. the data in the destination is newer. Importing the archive will
by default overwrite that new change in the destination and that change
will be lost.

Modified - The item is newer in the source and importing it will by default
overwrite the destination.

Equal - The items are considered equal and importing the archive will not
affect that object or aspect.

Destination - The aspect only exists in the destination and importing the
archive file will not affect that object or aspect directly.
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It is possible to double-click on an aspect to see the aspect details for the source and
target aspect. When double-clicking on an aspect, the Aspect Details dialog box in
Figure 17 will appear.

&® Details for, €1 Alarm List =1{E3
&
Advanced
Name Froperty Value {Source) Id {Source;
C1 Alarm List iMarne C1 Alarm Lisk {64 72010E-FODS-4FED-BR94-F21 287D AG949}
Description
Created 2005-06-20 13:46:30
Creation User 400000000-0000-0000-0000-000000000000%
Modified 2005-06-20 15:01:22
Modification User 400000000-0000-0000-0000-000000000000%

Aspect Category  Alarm and Event List  {16A60499-6A43-1103-5E52-0006C7DFS97E}
Keys

Size {in bytes)

Part of

Part of Extension

Figure 17. Aspect Details

The difference report can be saved to file. It can be opened in the Import/Export tool
even though the archive file may not be loaded and the target may not exist or be
different.

Messages. Select Messages in the View Menu or click the Messages button in the
toolbar to show/hide the message window at the bottom of the Import/Export tool.
The window displays all messages that have been generated within a session. See

Figure 18.
€31 Enors NV Wamings  J)45 Infomation | ¢ Frint b Save ¥ Open
I_l Time | Diazcription | Emor code |

/2006 35455 P Import Started

/2006 36505 PM Mizsrg Parent for ‘Application_1°: '0Object Type Structure'..
/2006 355:05 PM Escepbon from HRESULT: OxBABB0BES.

/2006 355:05 PM It Faded [0:0:10)

[Z] Messages

Figure 18. The Messages Window
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From the context menu it is possible to clear, print or save messages. For some type
of messages it is possible to navigate from the message context menu to the actual
aspect or object. To do this select Goto Aspect/Object in the context menu.
Messages can be filtered by status, for example so that only warnings and errors are
displayed. If a message contains detailed information, you can to select Details
from the context menu to read the complete message.

It is also possible to load previously saved messages in order to find out what went
wrong with a particular import or export.

Dependencies. Select Dependencies from the View Menu or click the
Dependencies button to display the dependencies view. This view displays all
dependent aspects, objects, entities, entity extensions and system extensions.

Import / Export - TT11459_SV50.afw

File Edt Miew Tools Actions Help
J 2 - € B B . P& (& B
Mew  Open Production Fefresh  Import Al Differences  Messages | Dependencies  Find | Addltem | Print  Options
= %g Admin Structure | Mame ‘ Created by | Fieserve comment | Reserved by | Pait of
+ %g Contral Stucture
%E + %g Functional Stucture
+ %g Library Structure “
T;g Contents
Mame Type Source T arget Comment
’?_‘;ACEDDM Connect System Extension  B.00.0 5.0.00
AL?‘) DM & PH Application System Extension  5.0.0.0 Mot loaded System Extension is not loaded in SEVS..
AE; Engineering Base System Extension  5.0.0.0 Not loaded System Extension is not loaded in SEVS..
A’Zy Fieldbus Builder PROFIBEUS HART System Extension  5.0.0.0 Not loaded System Extension is not loaded in SEVS..
&’?_‘; Function Desigrer Syatem Extengion 5000 Mot lnaded Syztem Extension iz not loaded in SEVS..
A’?_,a Function Degigner for AC800M Connect Suystern Extenzion 5.0.0.0 Nat loaded Syztem Extension iz not loaded in SEVS..
A’Z; H&RT Device Inteqration Library - Basics Systern Extenzion 5000 Nat loaded Syztem Extension iz not loaded in SEVS
’Z; Process Portal & System Extension  5.00.0 5.0.00
A’?_‘; Signal Extension for ACB00M Connect System Extension  5.0.0.0 Mot loaded System Extension is not loaded in SEVS..
AL?‘) Topology Designer System Extension  5.0.0.0 Mot loaded System Extension is not loaded in SEVS..
l.'_.]. Dependencies
&L NMEANSETEWAT

Figure 19. Dependencies Page

When the Import/Export tool is connected to a running system, the dependencies are
also compared with that system and the dependencies page will display warnings for
all inconsistencies.
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For example, if an archive file requires a specific system extension and that system
extension is not loaded in the system, it will be presented as a warning since it will
affect the possible to import the objects and aspects into that system.

ﬂ If you have an entity which contains an aspect that is related to an aspect within
another entity, the related entity is shown in the dependency view.

Placements. The placements dialog shows the insertion point needed for the
objects and aspects in the archive file. Any missing placement will be indicated as
an error or warning in the dialog and can be corrected before import by selecting

new insertion points in the system. Right-click on the missing placement and select
a new insertion point from the system.

ﬂ Some objects must be inserted at specific locations in the system. For example a
Control Application must be inserted under a 800xA for AC 800M project.

= 1] Control Metwork
\.!) Contral Metwark.
= \.!) Controller_1
\.‘) Controller_1

%E ":; Flacements

Import / Export - pp proj.afw E]@
File Edit Yiew Tools Actions Help
a 2 . 5 B e / @ & @
Mew Open Froduction Fefresh  Import &l Differences  Meszages Dependencies  Find Addltem  Print  Options
Flacements x
M ame Path .
= ﬂApplication_‘l
b @Application_‘l [Object Type Structure]0bject Types/Control SystemdAC B00M /T Connect/Application-defined Types

[Control Structure]Root

[Made Administration Structure]Mode AdministrationAl Modes

Type: Object. Date Modified 6/12/2006 08:22:13.

& NMEANsehestr

Figure 20. Placements View

Details

You can view extended information about aspect or objects by selecting details from

the context menu.
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Aspect Details. If you want extended information for one or several aspects, select
it/them, right click and select Details from the context menu.

The Aspect Details dialog displays information about the aspect.
See Figure 21.

® Details for C1 Alarm List M=1E3

&
Advanced

Mame Property Walue {Source) Id {Source])

1 flarm List fiame 1 Aliarm List JE4 01 DECFODE 4FE0-B904-F 2 1 370Rs 40T
Description
Created 2005-06-20 13:46:30
Creation User 400000000-0000-0000-0000-000000000000}
Modified 2005-06-20 15:01:22
Modification User 400000000-0000-0000-0000-000000000000}
Aspect Category  Alarm and Event List  {16A60499-6443-1103-8E52-0008C7DFA97EL
Keys
Size {in bytes)
Part of
Part of Extension

Figure 21. The Aspect Details Dialog Box

Object Details. To view extended information for an object; select the object and
select Details from its context menu.

The Object Details dialog displays information about the object. See Figure 22.

® Differences between Application_1 and

Marmne Froperty Walue [Source] Id [Source]

@Application_‘l Mame Apphcation_1 {FE480596-F594-4393-44. ..
Description
Created 2006-01-2511:5213
Creation User NMEA\seteval {7DDABE34-4948-4BAF-90...
Modified 2006-01-25 11:5213
Modification Lser NMEA\seteval {7DDABS34-4948-4BAF-90...
Object Type nfa nfa
Path Root/Control Network /PP/...
Part of Apphcation_1 {FE4B0596-F594-4993-44...
Part of Extension nfa néa

Figure 22. The Object Details Dialog Box

The Restore Path and Translated Restore Path areas are for fault finding.
The Restore Path is information about the object’s location during the export. It is
represented by a list of structure nodes.
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The Restore Path area contains the GUIDs of the structure nodes (<object-id> :
<aspect-id>). The Translated Restore Path area also includes the restore-path,
but translated in the selected system.

ﬂ The information in the Object Details dialog is possible to copy.
For example the ID/GUID number.

The Tools Menu

From the Tools menu the following options are found:

Select Target. Brings up the Select Target dialog. The dialog displays the system
which the application is connected to by default. You can also select Environment.

kfi Select Target

System: PTTS10 Super Duper System - Production -

Environment: | production 4

o [ o |

Figure 23. The Select Target Dialog Box

Options. This Option button brings up the Options dialog. In this dialog you can
set application wide options of different kinds. It is possible to reset the options to
the default options by selecting the Reset button. The Options dialog is divided into
four parts all described below.

*  Presentation Options - contain information that affect different aspects within
the import export interface.
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Options

Presentation Options

Present ation O ptions

Select how data iz prezented to the user.

—Aspect st
I Name [ Description
W Category Name [ Creation User
™ AspectID I Modification User
™ CategoyID [ Ressrve Comment
I Creation Time [~ Reserved By
™ Modification Time [ Inherited
—Wizible tabs
F Contents ¥ Dependencies
I™ Placements [ Meszages

frish | Cancel | Hebp

Figure 24. Presentation Options

* Add Options - controls the default behavior of the Import/Export tool when
items are added to the import/export archive, either through drag and drop or

via the Add button.

Options
Add Options

Select how itemsz shall be added o the Import/Export tool.

—Add Detad

M Include Dependencies

W Inchude Children
W Inchude Extensions

— DOvemwnite Existing Data
 Yes & Prompt if Different

 No " Prompt &lways

Figure 25. Add Options
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If the Include Dependencies check box is selected, the tool will add the
selected items in dependency order.

If the Include Children check box is selected the application will add the
selected object’s children.

If the Include Extensions check box is selected the application will add the
selected Extensions.

*  Import Options - controls the default behavior of the Import/Export tool when
items are imported to a system.

Options | X

Import Options
Select how import shall operate.

— Import Detal
W Include Dependencies W Include Extensions
W Include Children [ Keep Reservation

— Dwensmte Exasting Data
" Yes & Prompt if Different
Mo " Prompt Always

—LUzer Settings Structure Modes
I~ Force User Info [ Rearange Nodes

™ Force Time Info

Figure 26. Import Options

The Import Detail area has four check boxes:

—  If the Include Dependencies check box is selected, the tool will import
the selected items in dependency order.

—  If the Include Children check box is selected the application will import
the selected object’s children.

—  If the Include Extensions check box is selected the application will
import the selected Extensions.

—  Keep Reservation will automatically reserve the imported items after the
import is complete.
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In the Overwrite Existing Data area, the following four radio buttons are
available.

—  Yes - Always overwrite old data with new data, never bother the user with
questions about over writing existing data.

— No - Never overwrite old data with new data and do not bother the user
with questions about over writing existing data.

—  Prompt if Different - Prompt the user if new data is different than
existing data.

—  Prompt Always - Always prompt the user before overwriting any existing
data.

When importing objects and aspects, information about the creation and
modification user is the same as in the afw-file. For example, if you create a
new object and make an export, the object will get your creation user
information. When this file is imported, the object will retain the user
information stored in the afw-file, and therefore you will still be the imported
object’s creation user.

In some cases, the user-information in the afw-file is not valid, e.g. the creation
user is a system extension, and you don't want this information to be imported
into the system. When the Force User Info option is enabled, the
Import/Export tool will change the creation and modification user to the user
doing the import. When the Force Time Info option is enabled, the
Import/Export tool will change the creation and modification time of the
objects and aspects to the time when the import is done.

The structure of objects and aspects in an afw-file is used only when objects are
imported for the first time. If an imported object and structure node already
exists in the system, the position of the object will be retained. This happens
even if the user says Yes to overwrite the existing object. By checking the
Rearrange Nodes option, the Import/Export tool will rearrange existing
objects so that the layout of the structure becomes identical to the structure
layout in the afw-file.

General Options - controls additional functions of the Import/Export tool
itself. When the Close When Finished check box is selected the progress
dialog will automatically close when the an operation succeeds. The Drag
from Import/Export controls if the user can drag objects or aspects from the
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Import/Export tool into either another Import/Export tool or the Plant Explorer.
Please note that this operation is not the same as importing the object or aspect.
It creates a copy of the object or aspect.

Options |z|

General Options
Select how the tool shall behave.

—Progress Dialog
W Close When Finished

r—Drag from Import/Export

General Options

Frech Cancel Help

Figure 27. General Options

The Actions Menu

The Actions menu includes the following actions:

Import / Import All . Select Import/Import all from the Actions menu or click the
Import button to bring up the Import dialog. By clicking the Import button in the
toolbar the entire archive will be imported.

This functionality is also available from the context menu of both aspects and
objects. When the Import dialog is opened from the context menu, it will by default
import the selected aspect, object, entity or entity extension but it is possible to
change to import the entire archive.
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e  Import Items

Import objects and aspects |Z|

Import Items
Import the listed items to the selected spstem.

Irnport [tems Import to System:

¥ Selection
Control Metwork

" Al DbjectsfAspects
The entire content of the archive

frish | Concel Help

Figure 28. Import Items Dialog Box

In the Import to System drop-down menu you select to which system the
import will be made, and to which Environment in the Environment drop-
down menu.

In the Import area it is possible to select which system the import will be made
to, whether or not to include children or dependencies.

It is possible to filter out aspects by simply deleting them from the archive
before importing. The aspects can either be deleted manually one by one from
the aspect list, or by using the Find Tool and delete the aspects from there.

When importing entities, the import performs differently then when just
importing objects and aspects. When objects are imported, the aspects in the
system are merged with the aspects in the archive file which means that the
result is the combination of the aspect in the archive and the aspects in the
system.

When an entity is imported, any additional objects and/or aspects in the system
are deleted. If the archive file contains and entity and it has one or more
subentities, the import will replace/overwrite what is included in the archive
file. Subentities only present in the system but not in the archive file will be
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merged into the structure. If the archive file contains an entity with one or
several entity extensions, import will make sure that only those entity
extensions present in the archive file are present in the system after the import.
Any additional entity extension will be deleted.

ﬂ When importing a library with a library version, other existing libraries will not
be deleted. When importing a control project, other existing libraries will not be
deleted.

*  Import Options - Has the same function as in the Options dialogs in the Tools
Menu. But when you select your options in this dialog, the new options will
override the default options for this particular import you are about to do. See
Options.

Messages. Have a submenu from where you can clear, save or print the selected
message.

The Help Menu

The Help menu includes:
Contents. Select this option to launch the on-line help for the Import/Export tool.
About. This option displays the current tool version and file format.

Detailed Difference Report

Detailed Difference Report is a feature that easily produces documentation, reduces
customer burden for testing and verification of changes during QA procedures
promoting better change management practices. It works in environment enabled
architectures or single systems.
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Detailed Difference Report

Detailed Difference Report uses Afw file to compare archive file to the current

system configuration.
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Figure 29. Detailed Difference report

Below are two different data view in Detailed Difference Report:

1. Tree View:
An overview of the difference in function diagram with a tree like structure is
displayed.

—
Only in Source | Changed | Only in Compare !
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2. Text View:
Selecting individual components on the tree view, detailed difference is
displayed.
For example: Aspect properties such as DFO, aspect objects.

ﬂ For sequence logic, text view displays the overall differences of the sequences.

Detailed Difference Report provides more detailed information on configuration
changes in:

*  Control Logic (Control Builder M and Function Designer).
e Process Graphics 2.

It supports save and print features as shown in Figure 29. It has a filter feature to
check the changes made to the function diagrams.

It enhances readability by color indication.

Benefits of Detailed Difference Report
a. Enhanced change management for graphics and control logic.
b. Complements Audit trail ends and shows the changes.

The below table depicts the aspects and their support details to tree and text
differences:

Table 1. Tree and Text Differences Supported by Aspects

Aspects Tree Differences Text Differences
Process Graphics 2 X X
Function - General X X
Function - Sequence X
Programming Language
Control Builder X
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Additional Information

Upgrading Files

The application supports old file formats through a conversion scheme that is used
when performing the actual load.

Dependencies

The Import/Export function is dependency aware. This behavior can be switched on
or off by the user (see Dependencies).

Dependency aware export means that dependencies are brought in automatically
and exported to the same file as the dependant aspect. If an aspect depends on
another aspect or object that is part of a system extension; a note is made in the file,
but the aspect/object is not exported.

To view dependencies for an aspect, select the aspect and click the Dependencies
button in the toolbar. The dependency list will display all dependencies to objects,
aspects, entities, entity extensions and system extensions.

The imported file might be dependent on a specific version of the System, a System
Extension or a Library. In this case, it is necessary to resolve the dependencies by
installing them - before continuing the import.

A notification of missing dependencies will be displayed at the time of import.

Working with Dependencies

When a user works with import/export to move engineering-solutions or part of
engineering-solutions between systems, there are a number of issues that affect how
the data should be transported:

*  Size of the data to transport. How many objects and aspects, but also how many
bytes they take up on disc and how complex that data is to import. The
recommendation is to put each library in a separate afw-file, and each control
project in a separate afw-file. If libraries are small they can be put in the same
file, but at the end, each customer must trim the procedure of how much data
can be put in an afw-file since it also depends on the performance of the
available hardware.
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Distribution of dependent data. Are dependent libraries distributed as system
extensions separately, or must the user include them.

Relevance of dependent data. Should all data be included, or should dependent
data be selectively included by the user. As an example, the libraries could
already be at the target system for some other reason and therefore only the
control project needs to be exported.

When it comes to dependent data, there are basically two different workflows that
needs to be used depending on the state of other work being done in the source
system. How engineering tasks are performed will affect how the user should use
import/export.

Sequential Workflow.
Engineering tasks are performed by one or several users in sequence.

Parallel Workflow.
Engineering tasks are performed by one or several users in parallel, and the
different engineering tasks needs to be delivered at separate points in time.

Sequential Engineering Workflow. Engineering tasks are handled one by one in
the engineering system. When an engineering task has been completed it is
delivered to the production system, and the next engineering task is started.

Work to be dane
(n

Engineering Task 4" Engineering Task

Engineering Task

Engineering Task

Engineering Task

Figure 30. Stage for the Sequential Engineering Workflow
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In this example (see Figure 30), a new library has been developed and an existing
control project has had one application modified and a new application was also
developed. The A-Team now needs to deliver the library and the modified project to
the production system.

1. The engineering team gets an engineering task to perform in the engineering
system.

2. The team creates a new library in the engineering system. A new application is
added to an existing project and another application is modified.

3. The modifications are exported. In this case, the project utilized only a few
libraries so all necessary data could be transported in one afw-file. The export
is then made by dragging the project to the Import/Export Tool, and checking
the Include dependencies check box.

A dd items |E”g

&[]t Contral Project
1% Project
K| b
“You are now adding the following item(s}: Project<
Options
Include dependencies Include children [l Include extensions

Figure 31. Add Items Dialog Box
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Before pressing save, the team checks that no irrelevant objects or aspects were

included in the export. See Figure 32.

Import # Export

Fle Edt View Tooks Actions Help
g 2 W . e . ] s £
Mew Open Save Production st Difercnoes Messages | Dependencies | Find | A
Contents [%]
|@ -0 Conlrol Project
o | | 20 Projects
;i ; Adpplication Name
-8 Bapplcation
- MainControlier
R Library
=-{f0 Da0ne
- 0AOne 100 ail 3

s Conterts
Dependsncies |x|
Wame Type Souce Target Comment

[#,ACo00MC.. SystemEsension 5000 5000

[, Engineeiing... SystemEstension  5.0.0.0 5000

[ FunctionD_.  System Estersion 5000 5000

[ Function D... SystemEstension  5.0.0.0 5000

[ Process P System Estension 5000 5000

[ Signal Edte...  SystemEstension  5.0.0.0 5000
2 ] 3
[
{4+ Dependencies |

& NMEANseteval

Figure 32. Import/Export Tool

4. The afw-file is moved to the production system and imported.

Parallel Engineering Workflow. Several teams of engineers are working in parallel
on different tasks in the engineering system. When an engineering task is finished it
is delivered to the production system while the other engineering tasks are still

being performed.
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Work to be dane

Engineering Task 45‘ Engineering Task

Engineering Task

Engineering Task

(M

Engineering Task

B Team

Figure 33. Stage for the Parallel Engineering Workflow

In this example (see Figure 33), two teams are working with different engineering
tasks in the same control project. A-Team is making minor modifications to A-
Application in the project while B-Team is making modifications to B-Application.
B-Team has also added two new libraries to the project that only B-Application is
using.

1. B-Team gets a large engineering task that involves modifications to application
B-Application.

2. B-Team starts to modify B-Application and also starts the development of two
new libraries OB-One and OB-Two. The two libraries are included in the
project and are connected to the B-Application only.

3. A-Team gets a small engineering task that involves minor modifications to the
application A-Application.

4. A-Team makes the modifications to A-Application.
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A-Team exports the application by dragging it to the import/export tool. In this

case, they know that B-Team is working on the other application in the same
project and they also know that none of their work is finished so it is important
that no B-specific modifications are included in the export. A-Team leaves the
default settings in the add-form and adds the application to the tool.

ﬁ Add items

=[] Control Project
& [178 Projeci:
[E[=] 24 0plication

| o]
You are now adding the following item{s]: A4ppiication
Options
[ Include dependencies Include children [#] Include extensions
Figure 34. Add Items

In the dependency-list they see that the application has dependencies to OA-
One library and to the project. They know that OA-One library is not being
modified by B-Team and includes that dependency.

& Import / Export =19
Fie Edt Wew Tooks Actiors Help

¥ W = 5 Bl S £ ¢ & O e
Mew Open Save Fuoducion  Reflesh Impotdll Diferences Messages | Dependenciss | Eind | Addltem  Prt Options  Help
Contents
@) = ComnalPoiec Conlents of Appiication’
s S Pt = (3 Contiol Apgication Name Desoiption M

1% Adpplication
3 ey =1 [ Adgplicalion
e -y Cortrol Stuhure
i Object Type Stuctse
< >

T8 Contents
Dependencies x
[ Mame T Sowes Target et

B, ACEO0M Cannect System Extensen 5.0.0.0 5000

&, Funciion Designer System Extension 50,00 5000

Funclion Designer for AC300M Connect _ System Edtensicn__ 5.0.0.0 5000

H0a0ne 1.00 0ADne 1.00

B, Process Ponal A System Evtension 5.0.00 5000

75 Projectt Proischd

Figure 35. Import/Export Tool
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Audit Trail

The project is however being modified by B-Team and therefore it is not
included in the afw-file because it already exists in the production system.

A-Team clicks save to create the afw-file.

File Edt Wiew Tools Actions Help

y » B } =
Mew Open Save Produclion

Conlents

=55 ProjectX

= L Libray
& (F) 0a0ne

=]

Messages

)| = 7 Contial Project Contents af ‘AApplcation'

= [ Cortrol Appication
=-(F sapplication
#- T Control Structure
- Object Type Stucture

&
Dependences

e Contents
Dependancies
| hane
3, ACAO0M Connect
£ Fumction Designer
B, Furction Designer for ACB00M Connect
&, Process Poital A

T8 Projectt
£, Signal Exterion for ACS00M Conrect

{4 Dependencies

Type
Systen Extension
Systen Extension
System Extension
System Entonsion
Proizcid

System Extension

5000
50,00
5.0.00
5000

5000

Target
5000
5000
5.0.00
5000

5000

~ ¢ & B
Erd  Addllem Pt Options

Name

Comment

Description

£ NMENseleval

& import / Bxport EBX

o
Help

Figure 36. Import/Export Tool

6. The afw-file is delivered to the production system and imported.

Audit Trail

The Import/Export components support Audit Trail. It means that all operations
performed by these components are published in the Audit Trail log. Information
about when the operation occurred and which user performed it will also be visible

here.

Common Import/Export Scenarios

Importing/Exporting Fieldbus-Related Structures

For importing/exporting fieldbus-related topologies like an HSE Subnet or an
Control Project entity, the workflows given in this subsection shall be followed.

Preconditions:
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Identical versions of 800xA software installed in source and target system.
b. Same system extensions installed in source and target system.

c. Device Type objects installed in the source system are also installed in the
target system.

The following steps have to be carried out in the source system:

1.
2.

3.

Open the 800xA Plant Explorers Object Type Structure.
Check the following folders for already installed device types:

- FF Libraries Object Type Group (for FOUNDATION Fieldbus).
- Field Devices Object Type Group (for HART).
- PROFIBUS Devices Object Type Group (for PROFIBUS).

Record the name and version of the listed device types.

Expand the sub-tree of the mentioned Fieldbus folder and create a screenshot.
Print the screenshot for use with the subsequent steps in the section. Also it will
be helpful to take Device Library Wizard log file. This file will give information
about all the Device types which has been installed on the source system.

The following steps have to be carried out on all system nodes in the target system:

1.

6.

Start the Device Library Wizard: Start > All Programs > ABB Industrial IT
800xA > Device Mgmt > Device Library Wizard.

Select Extract Device Types > Extract Device Types via Manual Selection.

Click Browse and navigate to: 800xA Device Library DVDs of the required
Fieldbus protocol.

In the Browse dialog, select all Field Device Types as listed or printed in Step 4
for the specific fieldbus protocol and start extracting.

The file name of the corresponding Device Type object and the name displayed in
the Device Library Wizard can be looked up in the document DLW Mapping
Table, 2PAA101821* provided on 800xA Device Library DVDs.

Repeat the extraction steps for each used fieldbus protocol.

The Installation DVDs may not contain all required Device Types. Missing
Device Types must be downloaded via ABB SolutionsBank

(http://solutionsbank.abb.com)

Navigate back to the main window of the Device Library Wizard.
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10.

11.

12.

Select Device Type Administration.
Select Install Device Types.
Select the fieldbus protocol, for which Device Types shall be installed.

Select all Device Types previously identified to be required in the target system
and follow the install procedure.

Optionally navigate back to Install Device Types and repeat steps 14 to 15 for
the other fieldbus protocols.

Exit the Device Library Wizard.

FOUNDATION Fieldbus

Workflow for exporting an HSE Subnet from a source system and importing it into a
different target system.

The following steps have to be carried out in the source system:

1.

Use the Import/Export Tool to export the HSE Subnet from the Control
Structure. Do not select ‘Include Dependencies’ from the import options.
Individually include items from the dependencies window to be included in the
export file. This applies especially to items not created by the system.

Option: Use the Import/Export Tool to export the FFLibraries Object Type
Group from the Object Type Structure. Do not select ‘Include Dependencies’
from the import options. Individually include items from the dependencies
window to be included in the export file. This applies especially to items not
created by the system.

Perform this step only, if:

a. the FF Libraries have been expanded by importing FF devices in Fieldbus
Builder FF (in contrast or in addition to adding device type object with the
Device Library Wizard) or

b. device types have been modified by editing the FF Libraries in Fieldbus
Builder FF or by editing the FFLibrary in the Object Type Structure of
Plant Explorer.
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The following steps have to be carried out in the target system:

Perform Step 1 through Step 3 only, if the FFLibraries Object Type Group has been
exported in the previous Step 2. Otherwise continue with step 4.

1. Option: Use Import/Export Tool to import the FFLibraries Object Type Group
from the export file to the target system.

2. Option: Run Upload FF Library to move duplicate object types to the duplicate
structure.

3. Option: Move additional aspects from the object types in the duplicate folder to
the corresponding object types in the FF device type folder.

4. Use Import/Export Tool to import the HSE Subnet from the export file to the
target system.

5. Run Update Library on all HSE Subnets.
6. Run Upload HSE Subnet on all HSE Subnets.

PROFIBUS

PROFIBUS Device Types are included and available in the system as Hardware
Libraries (HWLibs). A PROFIBUS Hardware Library for a specific device type,
which is delivered by ABB and installed via Device Library Wizard, contains a
Basic Library and so called Extension Libraries. Extension Libraries can be
modified, but will result in a new major version of the library type.

If the installed Hardware Libraries have not been changed manually by the user, the
following workflow must be performed:

1. Use Import/Export Tool in the source system to export the Control Project with
PROFIBUS Device Type instances from Control Structure.

ABB recommends exporting the Control Project entity for PROFIBUS without
dependencies (refer to Dependencies for more details). Including dependencies
will export additional system structures and references, which results in huge file
sizes.

2. Store the export file on a media, which can be used on the target system.

The following steps have to be carried out in the target system:
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1. Use Import/Export Tool to import the Control Project from the stored export
file to the target system.

If the installed Hardware Libraries have been changed manually by the user (e.g.
new created extension library), the following workflow must be performed:

1. Use Import/Export Tool in the source system to export the Control Project
entity using PROFIBUS Device Type instances from Control Structure.
Include Dependencies.

2. Store the export file on a media, which can be used on the target system.

3. Navigate in the Plant Explorer to the modified extension library and click the
Export Library button on the Library Definition aspect to export the modified
extension library. Store the file on the media. Repeat this step for all modified
PROFIBUS extension libraries, if applicable.

The following steps have to be carried out in the target system:

1. Use Import/Export Tool to import the export files from the media to the target
system.

a. First import all manual exported extension libraries

b. Import after the extension libraries the Control Project.

HART

The following steps provide a workflow for exporting HART device types from a
source system and importing it into a different target system:

1.  Use Import/Export Tool in the source system to export the Control Project
entity using HART Device Type instances from Control Structure.
Important:

a. Include dependencies if the HART Device Types Objects (or any of the
entity children) have been modified by the user.

b. Do not include dependencies if the HART Device Types Objects (or any
of the entity children) have not been modified by the user.

2. Store the export file on a media, which can be used on the target system.

The following steps have to be carried out in the target system:
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1. Use Import/Export Tool to import the Control Project from the stored export
file to the target system.

PLC Controller Type Objects with Dependencies

When exporting PLC Controller Type Objects with dependencies, the result may be
a faulty export of ObjectTypes. Two Objects with same name can show up on same
level in up to three different places. This usually occurs when exporting Soft point
objects with Calculation Aspects. This has an impact on exporting and importing
Soft point objects without PLC connect.

If you have created your own composite object types, take the following actions
before proceeding with import/export:

1. Export the objects without dependencies.

2. Export the object type from the Object Type Structure without dependencies.

Information Management

Log sets and archive groups do not get exported as dependencies to log templates
automatically by the system. When the user exports a log configuration and includes
dependencies, only the control structure object and the library structure for the log
template are exported. To move the log template to another system, this needs to be
done manually by the user. If log sets are not used and if the archive groups are not
referenced on the log template or log configuration aspects, the below steps are not
required. Perform the following steps to export and import log configurations with
log sets and archive groups if the archive groups are referenced:

1.  Export logset(s) and archive group(s) into their own export file.

2. Export the log configuration which will pull the log template along as a
dependency.

3. Import the logset(s) and archive group(s).
4. Import the log template.
5. On the log template for the IM log (IM Definition tab):
a. Select the logset if one was set on the previous node.

b. Select the archive group if one was set on the previous node.
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6. On the log template for the IM log, set the Service Group to the desired service
group.
7. Import the log configurations.

8. If the archive group(s) was set up via the Node Administration Structure, re-
initialize group and re-specify logs.

Precautions when Importing/Exporting Aspects

The Import/Export tool can be used to restore graphic aspects, and for such aspects
there are restrictions for both Import and Export.

Import Aspects

You probably want to restore the graphic elements and hence preserve existing
unique identities, i.e you want the graphic display to look the same as it did.

If the graphic element is created with a new unique identity, previous references to
the aspect will not work.

When a graphic aspect is exported, the object the aspect belongs to needs to be
exported as well to keep all identities intact.

The object can in turn belong to a hierarchy of objects, and in this case the whole
structure needs to be available when the graphic aspect is imported. This means that
the entire object structure needs to be exported, though not necessarily in the same
afw-file.

When exporting a graphic element to another system, it is important that the

systems have the same logical color definitions.

Resolving Errors and Conflicts

While importing, there might be situations where you have to make a decision for
the import to be able to continue. One common situation is that the parent of the
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object that's being imported, does not exist in the system. In such a case the
following dialog will be presented.

Missing Restore Path

LY Fiestore path to object "[Functional Structure]/4/B" was not found,
-
~
Do you want to place it manually?

[ &pply ta all

[ es H Mo H Lancel ]

Figure 37. The Import/Export Placement Dialog Box

In the example above we have tried to import an object named B, but its parent
(named A) is not present in the system.

Another example is if you have imported an aspect that already exists; you need to
resolve this by choosing whether to replace that aspect or skip it and continue with
the rest of the import. It is possible to let the application make the same decision
every time a similar incident occurs.

Replace Existing Object

LY Do you want ta replace "[Functional Structure]/4/8"
\__0/ created 5/19/2006 14:29:42 and modified 5/19/2006 14:30:17
with object "[Functional Structure]/4/8"
created 5/19/2006 14:29:42 and modified 5/19/2006 14:25:427

Prezzing "Skip Subtree’ will skip the object and all children.

[ &pply ta all

[ es ] [ Mo ] [ Lancel ] [ Skip subtree]

Figure 38. Replace Object Dialog Box

Every decision you make is logged and visible in the message window (see
Messages).

When trying to import an aspect whose aspect category is missing in the target
system, the user is presented with a Skip & Continue/Cancel dialog, where it is
possible to either skip the aspect and continue with the import, or cancel the import.
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When a general error occurs importing an aspect or object, the user is presented
with a Skip & Continue/Cancel dialog, where it is possible to either skip the faulty
aspect/object and continue with the import, or cancel the import.
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Section 6 Backup and Restore

Introduction

This section describes the procedures that must be performed in order to save and
restore a complete 800xA 5.1 System (including all functional area information).
Figure 39 is a flowchart that outlines the steps required to save and restore 800xA.
The procedures must be performed in case the upgrade procedure will not be
successful and you will be required to return to the previous system state. It is
recommended that the save procedures also are performed on a regular basis.

ﬂ 800xA for DCI is not included with the initial release of 800xA 5.1 and thus
800xA for DCI backup and restore instructions are not documented in this user
manual. Alternate backup and restore instructions will be provided with the
800xA for DCI 5.1 release documentation.

The procedures required are:

*  Save function-specific information using various tools and utilities.
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Use the 800xA backup and restore utility to save the Aspect directory and other
800xA system information.

BACKUP RESTORE
START START
SAVE
nssET save 1 RESTORE 3%?255
OFTIMZATION B00KA FOR DCI SYSTEM B00XA MELD DY
SAVE PC, SAVE RESTORE
NETWORK AND S00¢A FORMOD DEVICE RESTORE
SOFTWARE 300 MANAGEMENT AND SO00XA FOR DCI
MO NITORING FIELDBUS
SAVE RESTORE RESTORE
SAVE SMS AND E- INFORMATION ASSET BOOKA FOR MOD
MAIL MESSAGING MANAGEMENT OPTIMEATION 300
SavE SAVE PROCESS N'ﬁ:ggi :ﬁn RESTORE
PLC CONNECT ENGINEERING TOOL SOFTWARE INFORMATION
MANAGEMENT
INTEGRATION MONITORING
SA\VE B00KA FOR RESTORE SMS AND RESTORE PROCESS
ADWANT MASTER Sﬁ:iﬂgﬁsﬂ? E-MAIL ENGINEERING TOOL
ANDSAFEGUARD MESSAGING INTEGRATION
SAVE SAVE
RESTORE RESTORE STRUCT URE(]
BOOKA FORAC BOOKA FOR IEC
s00mt 1850 PLC CONNECT DATA LOG (SDL)
SAVE BO0XA SAVE RESTORE 300XA FOR RESTORE
FOR ADVANT MASTER 200XA FOR IEC
BASIC HISTORY DATA|
HARM ONY AND SAFEGUARD £1850
SAVE 300XA BACKUP RESTORE RESTORE
FOR MELODY SYSTEM B00XA m’;ﬁ;ﬁ“ At BASIC HISTORY DATA
B00KA FOR
HARMONY

Figure 39. Backup and Restore Workflow

1. Not included with the initial 800xA 5.1 release.
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Precautionary Issues

It is possible for software and data to become corrupted. In that case there are third
party backup/restore and hard drive clone/image utilities that could be used.

A limited number of hardware failures can also be compensated when using these
utilities. It is important to understand the limitations associated with these utilities.

In some cases (e.g. corrupted data, corrupted software, or hard disk failures), these
utilities can be useful, while in other cases (such as replacing a workstation), these
utilities may be of limited use.

It is recommended that cloning/imaging software are used to save (and restore if
necessary) an image of the workstation hard drives, after installation of third party
software and/or after installation of software.

The 800xA Import/Export utility can be used to save 800xA information in smaller
parts at a time. The 800xA backup utility is the functional equivalent of exporting
all 800xA system information at one time. The critical difference between these
utilities is that individually exported parts of 800xA information can be imported
back into the original system or into a completely different system, while backed up
800xA information only can be used to restore a whole system. Read more about
800xA Backup and Restore in How to make a Full Backup on page 124.

It is very important to understand that the following procedures are written to save
the entire 800xA system and restore the 800xA system exactly as it was saved.
Thoroughly understand the following critical restoration limitations before saving
the system:

*  The 800xA system can only be restored and recovered to an equivalent
800xA system.

. All 800xA software must be of the same level (version, service pack, roll up,
etc.) as when the backup was made.

*  The same system extension, as when the backup was made, must be installed.

e The Domain server must contain the same configuration as when the backup
was made.

Refer to Requirements on page 100 for a complete list of the restoration
requirements and limitations.
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Save Function-Specific Information

Some information specific to certain functional areas, is not saved during an 800xA
system backup. The information that must be saved manually is detailed in the
following subsections.

Asset Optimization

Use the following procedure to back up Asset Optimization information (perform
only the steps applicable to the system):
1. Asset Monitoring:
ﬂ Asset Monitoring directories will be found on every Asset Optimization Server
node and any other node defined as an Asset Monitoring Server.

a. If Runtime Asset Monitors are being used in the system, save the Runtime
Asset Monitor data directory (DeviceRunTimeMSLogicStore) to a safe
media. This directory is located in the following directory:

For 64-bit:

...\Program Files (x86)\ABB Industrial IT\Optimize
IT\Asset Optimization\AssetMonitorEnvironment\Bin

For 32-bit:

...\Program Files\ABB Industrial IT\Optimize IT\Asset
Optimization\AssetMonitorEnvironment\Bin

b. If XY Profile Deviation Asset Monitors are being used in the system, save
the XY Profile Deviation Asset Monitor data directory
(XY _Reference_Profiles) to a safe media. This directory is located in the
following directory:

For 64-bit:

...\Program Files (x86)\ABB Industrial IT\Optimize
IT\Asset Optimization\AssetMonitorEnvironment\Bin

For 32-bit:

...\Program Files\ABB Industrial IT\Optimize IT\Asset
Optimization\AssetMonitorEnvironment\Bin
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c. If Counter Check Asset Monitors are being used in the system, save the
Counter Check Asset Monitors data directory named {66E71F7B-90D6-

4E62-9881-38388B24CBDF} to safe media. This directory exists for each
AO Server in the system. These directories are located in:

<install drive>:\OperateITData\AoEng\<AO Server
ID>\AmCat\<Counter Check ID>

Where each <AO Server ID> directory represents one AO Server instance
running on the selected node. The <AO Server ID> directory name is
formatted as two consecutive GUIDs, for example, {FOC150F5-2929-
4A12-BC28-E0OED6DB1585} {B925E77F-2A82-41C6-A981-
FAB4386D5701}.

For correct system operation it is important that only the directories identified by
@ the Counter Check Asset Monitor category GUID be saved, as other data in the
tree structure above these directories will not be consistent with a restore.

2. Maximo Integration:

If using Maximo Integration, the Maximo Integration information (Maximo
equipment ID and maximo credential aspects) MUST be saved from all Asset
Optimization Server nodes. Reference the Service Structure for the name of the
Asset Optimization Server.

a. The IBM Software’s Maximo system is separate from the 800xA system
and the system in use should be backed up. Follow Maximo standard
practices for Maximo system backup.

b. The MxDef files provide the mapping between the 800xA System
environment and the Maximo system. If the MxDef files were customized
as per the instructions in the System 800xA Asset Optimization 5.1
Configuration (3BUA0001 18%*), backup the customized MxDef files to
safe media.
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Backup the customized MxDef files from the following location:
For 64-bit:

...\Program Files (x86)\ABB Industrial IT\

Optimize IT\Asset Optimization\AOECSConnector
\MaximoDef\CustomDef

For 32-bit:

...\Program Files\ABB Industrial IT\Optimize IT\Asset
Optimization\AOECSConnector\MaximoDef\CustomDef

Backup the AOMaximoModel.xml file to a safe location. The ECS model
for Maximo also needs to be modified if MXDef files are customized.
Hence in this case a backup of AOMaximoModel.xml is necessary. The
model file is available in the following location:

For 64-bit:

...\Program Files (x86) \ABB Industrial IT\Optimize
IT\Asset Optimization\AOECSConnector\ECSDefinitions

For 32-bit:

...\Program Files\ABB Industrial IT\Optimize IT\Asset
Optimization\AOECSConnector\ECSDefinitions

The pending fault reports residing in the system are available in the following
directory structure. Backup the entire OptaoACDs folder.

<<install drive>>:\OperateI TData\OptaoACDs

SAP/PM Integration:
If using SAP/PM Integration, the SAP/PM Integration information (SAP
equipment ID and SAP credential aspects) must be saved from all Asset
Optimization Server nodes. Reference the Service Structure for the name of the
Asset Optimization Server.

a.

Although the SAP/PM system is separate from the 800xA System, it is a
good idea to back up the system in use. Follow SAP/PM standard
practices for the third party SAP/PM system backup.

The SAPPMDef files provide the mapping between the 800xA System
environment and the SAP/PM system. If the files were customized as per
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the instructions in the Industrial’” 800xA, Asset Optimization,
Configuration Manual (3BUA0001 18%), backup the customized SAPDef
files to a safe media.

The customized SAPPMDef files for SAP version 4.7 are located in:
For 64-bit:

...\Program Files (x86)\ABB Industrial IT\Optimize
IT\Asset
Optimization\AOECSConnector\SAPPMDef\CustomDef

For 32-bit:

...\Program Files\ABB Industrial IT\Optimize IT\Asset
Optimization\AOECSConnector\SAPPMDef\CustomDef

c.  The ECS model for SAP also needs to be modified if SAPPMDef files are
customized. Hence in this case a backup of AOSAPModel.xml is
necessary. Backup the AOSAPModel.xml file to a safe location. The
model file is available in the following location:

For 64-bit:

...\Program Files (x86)\ABB Industrial IT\
Optimize IT\Asset Optimization\AOECSConnector
\ECSDefinitions

For 32-bit:

...\Program Files\ABB Industrial IT\Optimize IT\Asset
Optimization\AOECSConnector\ECSDefinitions

The pending fault reports residing in the system are available in the following
directory structure. Backup the entire OptaoACDs folder.

<<install drive>>:\OperateI TData\OptaoACDs

The DMS Calibration Integration approach is changed 800xA 5.1. Reconfigure
the DMS Calibration Integration based on an engineered solution. Contact ABB
technical support for more information.
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PC, Network and Software Monitoring

Use the following procedure to save PC, Network and Software Monitoring
information:

ﬂ This procedure is only necessary if there are user defined Script, Resource, and
Assembly files in the 800xA System.

1. If there are user defined Script, Resource, and Assembly file, they need to be
backed up. Assuming the default directory was selected during PC, Network
and Software Monitoring installation, the user files are located in:

For 64-bit:

...\Program Files (x86)\ABB Industrial IT\Optimize IT\
PC, Network and Software Monitoring\bin\Configuration\
Scripts\User

...\Program Files (x86) \ABB Industrial IT\Optimize IT\
PC, Network and Software Monitoring\bin\Configuration\
Assemblies\User

...\Program Files (x86) \ABB Industrial IT\Optimize IT\
PC, Network and Software Monitoring\bin\Configuration\
Resources\User directory

For 32-bit:

...\Program Files\ABB Industrial IT\Optimize IT\
PC, Network and Software Monitoring\bin\Configuration\
Scripts\User

...\Program Files\ABB Industrial IT\Optimize IT\
PC, Network and Software Monitoring\bin\Configuration\
Assemblies\User

...\Program Files\ABB Industrial IT\Optimize IT\
PC, Network and Software Monitoring\bin\Configuration\
Resources\User directory

Copy the files in these directories to a safe location.

SMS and E-mail Messaging

Save all GSM Device hardware information. Record information for the GSM
device on the SMS and E-mail Messaging GSM Hardware Setup Worksheet shown
in Table 2.
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SMS and E-mail Messaging

Table 2. SMS and E-mail Messaging GSM Hardware Setup Worksheet

Item

Setting/Value

Spooler Settings

Activate Outbox Spooler

Checked (check and leave checked)

Activate Inbox Spooler

Checked (check and leave checked)

Interval for Checking for Incoming

Messages Value: ____ Seconds Minutes (circle 1)
Port Settings

COM Port Value:COM

Baud Rate Value:

Data Bits Value:

Parity Value: _

Stop Bits Value:

PIN and Properties

Query PIN

Checked or Unchecked (circle one)

PIN (only if Query PIN is checked)

Value:

Save PIN (only if Query PIN is checked)

Checked or Unchecked (circle one)

Own Number (telephone number of SIM

card (including Country Code) in GSM | Value:
hardware)
Initialization String for GSM Hardware Value:
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Table 2. SMS and E-mail Messaging GSM Hardware Setup Worksheet (Continued)

Item

Setting/Value

General Service Properties

Name (GSM service provider) Value:
Port Value: COM __
SMSC Value:
Default Country Code Value:
Default Prefix Value:
Number of Attempts Value:

Splitting Service Properties

Splitting

Checked or Unchecked (circle one)

Optimize Splitting

Checked or Unchecked (circle one)

Enumerate Splitting

Checked or Unchecked (circle one)

Narrowband Sockets

(
(
(
(

Checked or Unchecked (circle one)

Messaging Service Properties

Add Before Message

Blank (verify and do not change)

Use for Delivery Notification Only

Unchecked (verify and do not change)

Default Option

0 (verify and do not change)

Message General Properties

Replace CR LF for Incoming Messages

Checked or Unchecked (circle one)

PLC Connect

To backup PLC Connect information:

1. If the PLC Connect IEC60870 feature is installed and configured, the IEC
configuration must be saved. Refer to System 800xA 5.1 PLC Connect
Configuration (3BSE035041%*) for more information.
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5.

If the PLC Connect Communication Server Pre Treatment function is being
used in the application (refer to System 800xA 5.1 PLC Connect Configuration
(3BSE035041%*) for more information), make a backup of the PreTreat2.dll and
PreTreat3.dll files. Pretreat2.dll and PreTreat3.dll are located in the \ABB
Industrial IT\Operate IT\PLC Connect\Bin folder on the PLC Connect
Connectivity Server.

The path is the default location of these files. If they have been placed somewhere
else, make a backup from that location.

Make a backup of the VB application projects for PreTreat2.dll and
PreTreat3.dll.

If the Event Server Pre Treatment function is being used in the application
(refer to System 800xA 5.1 PLC Connect Configuration (3BSE035041%*) for
more information), make a backup of PreEvent.dll. PreEvent.dll is located in
the \ABB Industrial IT\Operate IT\PLC Connect\Bin folder on the PLC
Connect Connectivity Server.

The path is the default location of the file. If it has been placed somewhere else,
make a backup from that location.

Make a backup of the VB application projects for PreEvent.dll.

800xA for Advant Master and Safeguard

1.

Make an RTA Board backup.

Before restoring these files, ensure that the node being restored is running the
same character conversion language used by the node from which the files were
backed up.

Save the following files in the \ProgramData\ABB\AC400Connect\AdvantBase
\Data\RTA\Init\ folder and record which files belong to which workstation:

2.

\DATHR1.CD
\DATHR2.CD
\DATHR3.CD

The MB300 node, network address, REVERSED_SYNCH_MODE, and
PU410 redundant cable supervision settings for the RTA board in the RTA
Board Control aspect must be documented for re-configuration.
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3. If the configuration for Alarm and Event, or Data access is done in the
Connectivity Servers, save the AdvDsMasterAdapter.csv and
AdvMbAeOPCServer.csv files located in the <installation path>\bin.
800xA for AC 800M

Use the following procedure to save the 800xA for AC 800M information:

1.

Control Builder stores its settings (systemsetup.sys) on disk. Copy this file,
located in the Control Builder working folder, to a safe media.

Save OPC configurations by selecting File > Save Configuration in the OPC
Server Panel.

The OPC Server stores configuration files (*.cfg) and settings
(systemsetup.sys) on disk. Copy these files to a safe media.

The systemsetup.sys file is located in the OPC Server working folder.
The configuration files are stored in the Files folder in the same location.

Backup all Control Builder projects using the ordinary 800xA System
backup/restore utility. This utility also includes cold retain files stored by the OPC
Server.

800xA for Harmony Backup

If the Harmony Configuration Server is not in synch with the Aspect Server the
synchronizer should be run prior to performing any backup operation.

The sessions on screen status entries are appended to a backup or restore log file.
The user must manually erase any unwanted entries or Rename/Delete the log file
to start a fresh log. The log file is created in the temporary directory for the
currently logged in Windows account. The screen form contains a log file icon
that opens the log file in a Notepad application window for viewing, printing, or
editing of the log file.

Must be run on each Server containing an 800xA for Harmony Configuration
Server while logged in to the 800xA Installing account or another local
administrator account.
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Do not use a SQL Server generated backup done through a SQL Maintenance
Plan or manually through the SQL Enterprise Manager for the restore operation.
The 800xA for Harmony backup/restore utility does not support this format.
Ensure that your Maintenance Procedures include an 800xA for Harmony backup
utility generated backup each and every time you do a backup of your Aspect
System. These two backups must be synchronized at the time of a restore
operation.

Backup

Use the following steps to back up an existing configuration:

1.

Log into the 800xA for Harmony Configuration Server with the 800xA
Installing account or another local administrator account.

Select Start > Programs > ABB Industrial IT 800xA > 800xA for OCS
Systems > Harmony > Configuration > Backup Configuration, select the
Connect button to manually initiate the connection to the configuration
database.

The filename is auto generated using the Configuration Server name, date and
time (ConfigServer_20020521_1034.bak for example). The backup file
name can be changed from the default as needed.

Refer to the MSSQL file folders for the .bak files generated upon successful
backup.

4. The Backup button manually initiates the SQL database backup operation.
Only one single backup is stored per file. If the backup file already exists it is
overwritten.

5. If completed successfully, the Exit button is activated and the user can then exit
to quit.

6. Repeat the above procedure for other 800xA for Harmony Configuration
Server application servers.

800xA for AC 870P/Melody
The following is a general information about the Melody Configuration Backup and
Restore:
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v

*  The sessions on screen status entries are appended to a backup or restore log
file. The user must manually erase any unwanted entries or Rename/Delete the
log file to start a fresh log. The log file is initially created in the Windows
Server 2008 accounts temporary directory location. The screen form contains a
log file icon that opens the log file in a Notepad application window for
viewing, printing, or editing of the log file.

*  Must be run on the Melody ConfigServer while logged in the 800x Alnstaller
account or an 800xA administrator account.

Recommendations: Typically, run the Backup option after creating a database for
the first time. Run the Backup option before doing an upgrade or making
significant changes the system configuration. Run the Restore option when the
system becomes corrupt or after and upgrade takes place

Access

This feature is accessed through Start > (All) Programs > ABB Industrial IT
800xA > 800xA for AC 870P Melody > Configuration on the ConfigServer node.

Function

The 800xA for AC 870P/Melody Backup or Restore feature allows the user to
manually initiate a backup or restore that supports either the full backup or full
restore of the SQL 800xA for AC 870P/Melody configuration contained in its SQL
database. The backup or restore operation sequences through all steps are required
to complete the operation requested.

The user backup process consists of the user selecting an aspect system name and
file location to contain a standard SQL backup set and initiating the backup for the
Melody ConfigServer. This includes the Melody Connectivity Server backup
because of the snapshot done in the same procedure. The user restore process
consists of the user selecting an existing SQL backup set filename and initiating the
restore operation.

For support during the ConfigServer backup the Microsoft SQL-Server online
help is also available.
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Backup Industrial IT Melody Composer

The Composer backup and restore procedure is described in the AC870P / Melody
Composer Installation (2PAA100254%).

Backup ConfigServer

ﬂ The backup has to be stored on a local disk or on a tape connected to the local
workstation. A backup via network drive is not possible.

@ During the backup, configuration changes must not be performed.

Use the following procedure to save 800xA for AC 870P/Melody information:

1. Log in to the 800xA Installer account or an 800xA administrator account
account on the ConfigServer node.

2. Use the 800xA for AC 870P/Melody Config backup / restore utility to create a
backup of the Melody Config Server database.

a. Select All Programs > ABB Industrial IT 800xA > 800xA for AC 870P
Melody > Configuration > Backup Configuration

b. Click Connect in the 800xA for AC 870P/Melody Configuration
Backup/Restore window.

ﬂ This initiates the connection to the configuration database using the current
Windows Server 2008 account security. This account must have Administrative
access to the system and ConfigServer database.

The file name is auto generated using the ConfigServer name, date and time.

Example: ConfigServer 20020521 1034.bak

c. Click Backup.

Clicking on the Status Log icon shows the log file. This text file can be saved.

ﬂ The Backup button manually initiates the SQL database backup operation. Only
one single backup is stored per file. If the backup file already exists it is
overwritten.
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d. Click Exit when the backup is complete.

Batch

This section is only required when using Batch with 800xA for AC 870P/Melody.
Successful backup of the Batch configuration requires that Object IDs of the various
Batch objects be preserved.

Perform the following backup procedure:

1. Export the Functional Structure and Procedure Structure using the
Import/Export tool.

2. Use the Melody Backup Configuration utility to save the ConfigServer
configuration.

3. Backup the Melody Composer project.

800xA for MOD 300

AdvaBuild® is the engineering tool used to backup 800xA for MOD 300 control
system information. The AdvaBuild Administration User Guide (3BUR001977%)
instruction provides information needed to manage the AdvaBuild projects.

There is no additional data needed for 800xA for MOD 300 other than performing
the system backup. For long term maintenance, refer to the 800xA for MOD 300 5.1
Configuration (3BUR002417%*) instruction, Appendix F, for more information on
customized data settings.

Information Management

The following procedures can be used to backup all information related to
Information Management software. Information Management software includes:

e Inform IT History (includes Archive)
e Inform IT Display Services

*  Inform IT Application Scheduler

*  Inform IT Data Direct

e Inform IT Desktop Trends

e Inform IT Open Data Access
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. Inform IT Calculations

Not all components require additional steps to backup local files. An Information
Management server will have all the software installed while other nodes will have
only some of the software used. For each component that is configured and used on
a node, all the files should be backed up occasionally. The following procedure
provides the steps to perform the backups.

Node Types
The IM software run on 3 basic node types.
*  Information Management 800xA Server

* Information Management 800xA Client, with optional Desktop Tools
components.

*  Desktop Tools installation

For a given node type, the backup steps depends on the type of software installed
and the software used on the node. If software is installed and not utilized, there will
be nothing to backup. The following steps identify how to backup an Information
Management 800xA Server node. The steps to backup the other node types will
reference the server backup procedure.

Backup of Information Management Server
The following step will backup the Information Management Server:

1. Use PAS to stop all Information Management processes and the Inform IT
History service provider for this node.

The procedure can be performed by using the pasgui command in the Run dialog
box (Start > Run).

a. Use the Windows Taskbar to select:

Start > Programs > Administrative Tools > PAS > Process
Administration

b.  Click Stop All in the PAS dialog box. This will stop the Inform IT History
Service Provider.

To make a backup:
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1. Select Start > All Programs > ABB Industrial IT 800xA > Information
Management > History > Backup and Restore.

2. Verify the Create Backup Files of Current Configuration option is enabled in
the IM Historian Backup/Restore Utility window.

3. Click Next. A window for setting up the backup operation is displayed.

4. Specify the location where the backup files is to be created in the New
Directory Path for the Backup field.
This path must already exist and the directory must be empty. If necessary,
click Browse to create a new directory. See Figure 40.

E IM Historian Backup/Restore Utility x|

It Histanian D atabase Backup

This step will create a backup of the entire M Histarian database and place it in the directory
specified below. The backup includes all data in oracle (including configuration and log data such
as message logs and POL), numeric log flat files and IM aspect system definition file.

MOTE: Backup path must exist, and it must reference an empty directory. |f these conditions are not
met, this utility will not allow to create a backup.

Mew directory path far the backup:

IC:\Backup\T3 Browse... I

I you wish ta wn hsBAR with additional options, you may specify them below. hsBAR iz a console
application involked by this utility to generate non-aspect part of the histarian backup.

Option below allows ta skip hsBAR and anly create IM aspect system definition file. This filz iz
populated with all the information needed by the restore side ta recreate all aspects configured in the
spstem at the time of backup.

[~ Dnly generate aspect definition file

Click '"Mext" button to start backing up configuration..

< Back | Mext » | Cancel

Figure 40. Setting Up the Backup Operation

5. Verify the Only Generate Aspect Definition File option is disabled.
6. Click Next. The HsBAR Output Window is displayed.
7. Enable the Automatically Close Upon Completion option.
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8. After the HsSBAR Output Window closes, monitor the progress in the Progress
Status area of the IM Historian Backup/Restore Utility window and click
Finish when the backup is complete.

ﬂ If a message stating that there are inconsistencies between the log configurations
in the Aspect System and the log configurations in Oracle is displayed:

1) Run hsDBMaint -clean function. (Refer the Information Management
Configuration instruction for more information.)

2) Re-run the backup utility.

Saving Other Information Management Related Files

There are several other files related to Information Management that need saved as
part of total system backup.

ﬂ More detailed instructions for this procedure can be found in the section on
backing up individual Information Manager applications in the appropriate
Information Management instruction.

*  History Archive Data: For each archive device, go to the location specified by
the Device Filename and copy the folders under that directory to a safe
location. Do this even if automatic backup is configured. If automatic backups
are for local disks, also transfer them to a safe media at this time. Archive state
information must be saved. The Archive folder from the following path must be
saved to a safe location:

C:\ProgramData\ABB\IM\

*  Reports: Save any report template files created in Microsoft Excel,
DataDirect, and/or Crystal Reports. Also save report output files created as a
result of running these reports via the Scheduling Services.

*  Desktop Trends: Back up trend display, ticker display, and tag explorer files.

¢ Display Services: Back up the directories for custom users, as well as display
and user element definitions.

»  DataDirect: Back up custom text files for object, object type, and attribute
menus used on the DataDirect windows.

All files should be copied to a remote storage medium after the saving is completed.

3BSE046784-510 E 93



Process Engineering Tool Integration Section 6 Backup and Restore

Use PAS to start all Information Management processes and the Inform IT History
service provider for this node.

The procedure can be performed by using the pasgui command in the Run dialog
box (Start > Run).

a. Use the Windows Taskbar to select:

Start > Programs > Administrative Tools > PAS > Process
Administration

b.  Click Start All in the PAS dialog box. This will start the Inform IT
History Service Provider.

Non-Information Management Server nodes.

Any nodes that are installed and are configured to use Desktop Trends, Data Direct,
Application Scheduler (reporting) should backup any application specific files after
backup process is completed on the node. The backup files include:

*  Reports: Save any report template files created in Microsoft Excel,
DataDirect, and/or Crystal Reports. Also save report output files created as a
result of running these reports via the Scheduling Services.

*  Desktop Trends: Back up trend display, ticker display, and tag explorer files.

»  DataDirect: Back up custom text files for object, object type, and attribute
menus used on the DataDirect windows.

Process Engineering Tool Integration

Use the following procedure to back up Process Engineering Tool Integration
information:

Assuming the default directory was selected during Process Engineering Tool
Integration installation, the project data is located in the following directory:
...\Program Files\ABB Industrial IT\Engineer IT\Engineering Studio\Process
Engineering Tool Integration\Xml

Save the entire Xml data directory to a safe media like a network share or removable
disk. The directory contains the default mapping files (*.dmf) modified on the
project, accelerator files (*.acc) and configuration files (*.pcf and *.fcf).
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Structured Data Log (SDL)

A database backup creates a copy of the full database.

This copy can be used to recreate the database with the Restore statement as it
was at the time the Backup statement was completed.

For a full description of the Backup and Restore statements, refer to SQL Server
Books Online > SQL Server Architecture > Administration Architecture >
Backup/Restore Architecture and to Transact-SQL Reference.

When the SDL database grows in size beyond a certain limit, it may be
advantageous or even necessary, to remove old data to keep the size of the database
down and the performance up.

Refer to the System 800xA Post Installation (3BUA000156%) instruction for more
information.

The SDL database may be backed up by using the SQL Query Analyzer tool
installed with the SQL Server 2000.

The following Transact-SQL statements should be executed:

o Select the “master” database.
USE master

*  Create a logical backup device for the full SDL backup.
EXEC sp addumpdevice 'disk', 'SDL BU',
DISK ='<path of backup folder>\SDL BU.dat'

e Back up the full SDL database.
BACKUP DATABASE SDL TO SDL_BU

The file SDL_BU.dat should be kept in a secure place.

The logical backup device SDL_BU needs to be created only once. It is used
during both Backup and Restore.
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800xA for IEC 61850

Make backups for the IEC 61850 CET OPC Server projects. Refer to Section 6 of
System 800xA IEC 61850 Configuration (YARD171387%) to export CET OPC
Server projects.

ﬂ Handling of IET/CCT projects and PCM 600 projects is not described here as
they are external tools contributing to the IEC 61850 workflow. They do not

reside on 800xA System nodes.

Basic History Service Data
To backup the Basic History Service Data, use the following steps:

1. Go to the Maintenance Structure and select the Backup Definition Root object.

2. Create a new Basic History Backup object. See example in Figure 41 below.

Aspects of 'Backup Definitions’ |
Backup Definition Root Type Refer...
BackupObiectCantrol

T:i‘j Maintznance Struckure j
a Backup Definitions, Backup Definition Root

gl Backups, BackinDack

e T — ;
a Synchronizatio

a Synchronizatio | C@mman IProduct Type Structure |
R RSy il Backup Definition

a System Config

[~ Object description

r—Additional Arguments

Ohject Tron
i

Mame

| Stovs all [V List presentation

Figure 41. Basic History Backup Object
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Basic History Service Data

3. Select the created object and its Backup Definition aspect. It has three tabs:
Scope, Storage and Summary and Start Backup tab. See Figure 42.
Aspects of 'Basic Histary Backup' | Modified | Dese... | Inherited | Category name
Backup Definition F005-11-74 11:3...  This... False Backup Definition
Full Backup Definition Type Refere... 2005-11-24 11:3.., False Full Backup Defi...
%3 Maintenance Structure 2005-11-24 11:3...  [Main... False Mainkenance St...
B3 Name 2005-11-24 11:3,..  The... False Mame
@Ob]ect Icon 2005-11-24 11:3...  Icon ... False Object Icon
O H‘ - ‘Baswc Histary Backup:Backup Dafiniticj ?) /(9 -
Scope ]Storage } Surmary and Start backup I
Backup Type:
‘Externa\ Services j
Histary Backup Configuration
s all Data
" Data From Date: =l
" Data From Last: ‘ J

Figure 42. The Scope tab

4.

5.
6.

Select External Services in the Backup Type drop-down menu.

See Figure 42.

Apply | Help |

Check the Basic History check box in the Configuration area.

Click Apply.

The Storage tab (see below) includes information about the backup.
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Object description

Cammon | Product Type Struckure

Full Eackup Definition

Additional Arguments

Object Icon

r-4

Marne
| Basic Histaory Backup

¥ Iv List presentation

Advanced... | Set GUID. .. | Create | Cancel Help

Figure 43. The Storage tab

7.  Go to the Summary and Start Backup tab. Click the Start Backup button.
See Figure 44 below.

JJ O H_ - |System Message Backup:Backup Defi;l _’,;'j )? -

Scope | Storage  Summary and Start backup |

Start Backup |

Cancel | Apply | Help |

Figure 44. The Summary and Start Backup tab
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The backup will now be started. A dialog will appear, confirm the backup with OK.
You can see the backup progress in another dialog. See Figure 45.

:ﬁJHistory Backup; 2006-05-08; 15-32 : Backup Info _ ||:||i|
JJ b4 [History Backup; 2008-05-0; 15-32:E = | % 07 i 16 1= |

Status |Scope I Storage I Restore I

—Backup Type: External Services
B azic Histary Ready ls
‘Wigw Log Abort Backup

Cance] Apply | Help I

Figure 45. Backup in progress

800xA System Backup

The backup/restore utility supports manual and scheduled backups of 800xA system
information. For scheduled backups, the ABB Inform IT Scheduler must be
installed.

Requirements

All system extensions that are part of the system must be installed and added on the
node where the backup will be taken (usually the Primary Aspect Server node).
Changes must not be made (especially to the Aspect directory) during the online
backup process.

When backing up a system with environments both the Production environment and
the Engineering environment will be included in the backup. Only the current
version of each aspect will be included in the backup, which means that all version
history will be removed.
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Procedure

The following steps outline the 800xA system backup procedure. Refer to How to
make a Full Backup on page 124 for more detailed information.

1. Create a Full Backup Definition object in the Maintenance Structure, and
configure the Scope and the Storage tabs.

ﬂ Note that it is only possible to perform a backup from the Production
environment.

2. Check disk space and path in the Storage tab of the Backup Definition aspect.
A large configuration could require a minimum of five gigabytes of free space.

3. Start the backup process.

4. In case of any warning or error messages (refer to How to make a Full Backup
on page 124), take the appropriate measure and create a new backup.

ﬂ Do not manually import or edit any information in backup files.

800xA System Restore

The backup/restore utility supports the restoring of 800xA system information,
including multiple environments.

Requirements
The following restrictions apply when a backup is used to restore a system:

e All 800xA software must be installed and be of the same level (version, service
pack, rollup, etc.) as when the backup was taken.

e The Domain server must contain the same configuration as when the backup
was taken.

Procedure

The following steps outline the 800xA system restore procedure. Refer to How to
make a Restore on page 128 for more detailed information.

1. Minimize the system to a single node Aspect Server using the following
procedure:

a. Disconnect and shut down all clients.
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b.  Perform the following operations on each server node except the node on
which the backup is taken (One of the Aspect Servers). Perform the
operations on the Application Servers followed by Connectivity Servers.
Then perform the operations on the Aspect Servers. Complete the
operations on each node before proceeding with the next.

— If the node is an IM server, start the pasgui from the Run prompt and stop
all the IM services. Then start the services.msc from the Run prompt and
change the ABB Process Administration service to Manual and stop the
service.

— In Configuration Wizard, stop the server using the Stop Server operation.
Wait for the server to stop.

—  After the node is stopped, use the Aspect server to remove the node from
the system. In the configuration wizard, remove the server from using the
remove server operation. (System Administration/Nodes/Remove Server).
Wait for the operation to complete before proceeding.

—  Restart the node that was removed from the system.
c. Perform the following operations on the existing Aspect Server:

— In Configuration Wizard, stop the server using the Stop Server operation.
Wait for the server to stop.

—  In Configuration Wizard, delete the system using the Delete System
operation. (System Administration/System/Delete System). Wait for the
operation to complete before proceeding.

—  Restart the node.
Start the restore procedure on the same node the backup was taken.

Check for messages in the log file. Refer to How to make a Full Backup on
page 124 to resolve any received warning or error messages.

One node at a time, start up all nodes again and connect them to the 800xA
system in the following order:

—  Aspect Server nodes.
—  Connectivity Server nodes.
— Application Server nodes.

—  Client nodes.
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Use the following guidelines while connecting nodes:

Set the current system as the default system when connecting nodes to the
system.

In some cases, problems may be encountered when connecting nodes to
the system. Verify that the system software user settings are correct using
the Configuration Wizard. Restarting the node again may also solve the
problem.

Wait until all services in the newly connected node are up and running
before connecting the next node. Select the Node Administration
Structure\connected_node_name\System Status Viewer aspect to monitor
the status of services. If some services will not start up, restarting the node
may help.

Restart each node after it has been connected to the system.

If the node is an IM server, start the services.msc from the Run prompt.
Change the ABB Process Administration service to Automatic and then
start the service.

5. Verify the affinity settings to ensure best system performance. If required,
correct the settings. Refer to the System 800xA Post Installation
(3BUA000156%) for more information about how to configure affinity.

Recover Function-Specific Information

Information specific to certain functional areas that was saved during an 800xA
system backup can be recovered using the information in the following subsections.

Device Management & Fieldbus

server node is functional.

@ Configure the OPC server on the primary Aspect server after the primary Aspect

In the case that the system node has been formatted, third party software for Device
Type must be re-installed.

ﬂ The Device Library Wizard procedure described here can be skipped, if the
system node has not been formatted.

The following steps for Fieldbus Device Types need to be carried out on every
system node in the following sequence, except thin client nodes:
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*  Aspect Servers (including redundant Aspect Servers).

e Connectivity Servers (including redundant Connectivity Servers).
*  Application Servers.

e Clients.

1. Start the Device Library Wizard:

Start > ABB Industrial IT 800xA > Device Mgmt > Device Library
Wizard

or

select the Device Library Wizard icon on the desktop.

ﬂ If the Device Library Wizard - Client has not been connected to the Device
Library Wizard - Server, navigate first to:

Device Library Wizard Administration > Connect Client
and follow the wizard installation.
2. Navigate to:
Device Type Administration > System Restore Wizard

and choose the third option in the Wizard (Figure 46).
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& ABB Device Library Wizard [B00xA with AC 800M]

System Restore Wizard(1)

Usethe radio buttonto select the system upgrade or restore path

System Restore Wizard provides a guided restore for 800xA Fieldbus Device Libraries to be executed
after an 800xA System Restore via System Configuration Wizard is done

@ Continue only if one of the following selectable options applies to your system environment
Choose a suitable option

" An B00xA System upgrade from SV4.x to System Version 5.1(or higher) has been done
™ An B00xA System upgrade from 5V5.0 {or higher) to System Version 5.1{or higher) has been done

™ An B00xA System update from System Version 5.1 to System Version 5.1{or higher) has been done

View Log .. < Back Exit Help

Figure 46. System Restore Wizard Option

3. Click Next.

4. Choose whether or not the system node has been formatted and click Next.

If the system node has not been formatted, no more steps are required and the
Device Library Wizard will automatically navigate to its main window. Exit the
Device Library Wizard and continue with the other system nodes (if applicable).

5. Depending on which Fieldbus protocol is used in the previous system version
environment, one of the delivered Device Library system DVDs shall be
inserted in the DVD drive (Device Library HART — DVD).

6. Click the Browse button and navigate to the drive where the DVD has been
inserted.

7. Click Next.
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The Device Library Wizard is scanning the 800xA System for already used
Fieldbus device types and compares it with the contents of the inserted DVD.
Device Types available in the 800xA system and the DVD are shown in the
Extract tab of the Device Library Wizard (Figure 47).

a ABB Device Library Wizard [B00xA with AC 800M]

Extract Device Types
Confirm with "Next” button to complete the extraction operation of all device types.

Extract| Missing
Devices

B ABB PME 120 v1.1-DP
HEBiffi FO2 PremiTork V1.0-DP
A EL-0-Matic Q-COPS v1.0-DP
HEEMG Drehmo I_Matic V1. 1-DP
HRotork 10512 V1.0-DP

< Back Mext = Exit Help

View Log ..

Figure 47. Extract Device Type Files
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9. Click Next to start the extraction process.

Device Types available in the 800xA System but not on the inserted DVD are
displayed in the Missing tab. In this case, the Next button in the Device Library
Wizard is disabled. Navigate to the Browse window by using the Back button and
insert a new Device Library DVD.

Repeat this procedure until all device types are extracted to the system node and
the Missing tab does not list any device types.

If the Device Library DVDs do not contain all Device Types used in the previous
system version, the missing Device Types must be download via ABB
SolutionsBank (http://solutionsbank.abb.com).

It is possible to continue the Wizard only if all device types have been
successfully extracted.

10. After successful extraction, the device types need to be reinstalled on the

system node. Click Next (Figure 48).

g ABB DEVICE LBRARY WIZARD [800xA with AC 800M] EI_Ié

Re-Installation of Device Types

Confirm with "Next”button to complete the installation operation of all devicetypes.

Install | Restore |

Devices

T ABB PME120x V1.0-HART

B ABB PME 120 v1.1-DP

B aUMA AUMATIC ACO1.1V1.0DP
H¥Rotork 10512 v5.0-DP

View Log .. < Back Mext = Exit Help

Figure 48. Install Device Types

11. Follow the wizard to complete the installation. The wizard will automatically

navigate to the main window after the process has been finished.
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Section 6 Backup and Restore Asset Optimization

12. Exit the wizard and perform these steps on the other system nodes if
applicable.

Asset Optimization
Use the following procedure to restore Asset Optimization information:
1. Asset Monitoring:
ﬂ Asset Monitoring directories MUST be restored on every Asset Optimization

Server node defined in the system.

a. If Runtime Asset Monitors are being used in the system, restore the
Runtime Asset Monitor data directory (DeviceRunTimeMSLogicStore).
This directory must be restored to the following directory:

For 64-bit:

...\Program Files (x86)\ABB Industrial IT\Optimize
IT\Asset Optimization\AssetMonitorEnvironment\Bin

For 32-bit:

...\Program Files\ABB Industrial IT\Optimize IT\Asset
Optimization\AssetMonitorEnvironment\Bin

The saved data contains the Runtime Asset Monitor data present at the time of the

ﬂ save. Use the Runtime Asset Monitor faceplate to reset the asset monitors by
adding the lost time to their accumulated run time or with some known values
based on other records. Ignore any alarms occurring during the backup.

b. If XY Profile Deviation Asset Monitors are being used in the system,
restore the XY Profile Deviation Asset Monitor data directory
(XY _Reference_Profiles). This directory must be restored to the following
directory:

For 64-bit:

...\Program Files (x86)\ABB Industrial IT\Optimize
IT\Asset Optimization\AssetMonitorEnvironment\Bin

For 32-bit:

...\Program Files\ABB Industrial IT\Optimize IT\Asset
Optimization\AssetMonitorEnvironment\Bin

c. If Counter Check Asset Monitors are being used in the system, restore the
Counter Check Asset Monitors data directory named {66E71F7B-90D6-
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4E62-9881-38388B24CBDF} from safe media. This directory exists for
each AO Server in the system. These directories are located in:

<install drive>:\OperateITData\RAoEng\<AO Server
ID>\AmCat\

Where each <AO Server ID> directory represents one AO Server instance
from which the directory {66E71F7B-90D6-4E62-9881-
38388B24CBDF} was originally saved from. The <AO Server ID>
directory name is formatted as two consecutive GUIDs, for example,
{F9C150F5-2929-4A12-BC28-EOOED6DB 1585} {B925E77F-2A82-
41C6-A981-FAB4386D5701}

2. Maximo Integration:

If using Maximo Integration, the Maximo Integration information (Maximo
equipment ID and maximo credential aspects) MUST be restored to all Asset
Optimization Server nodes. Reference the Service Structure for the Asset
Optimization Server.

It is required that ECS software is installed prior to continuing with Maximo
integration.

a.

Configure ECS software. Refer to the ECS configuration in System 800xA
Asset Optimization 5.1 Configuration (3BUA0001 18*) for more
information.

If the MxDef files were customized, restore the customized MxDef files
from safe media to this directory (assuming the default directory was
selected during Asset Optimization installation):

For 64-bit:

...\Program Files (x86)\ABB Industrial IT\
Optimize IT\Asset Optimization\AOECSConnector
\MaximoDef\CustombDef

For 32-bit:

...\Program Files\ABB Industrial IT\Optimize IT\Asset
Optimization\AOECSConnector\MaximoDef\CustomDef

If Maximo model is customized, restore the AOMaximoModel.xml to the
following location:
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For 64-bit:

...\Program Files (x86)\ABB Industrial IT\
Optimize IT\Asset Optimization\AOECSConnector
\ECSDefinitions

For 32-bit:

...\Program Files\ABB Industrial IT\Optimize IT\Asset
Optimization\AOECSConnector\ECSDefinitions

Refer to System 800xA Asset Optimization 5.1 Configuration (3BUA000I18%*)
for more information on MxDef files.

Ensure that ABB Maximo Connectivity system extension is loaded.

The pending fault reports residing in the system can be restored to the following
directory structure. Restore the entire OptaoACDs folder.

<<install drive>>:\OperateITData\OptaoACDs

3. SAP/PM Integration:

ﬂ If using SAP/PM Integration, the SAP/PM Integration information (SAP

equipment ID and SAP credential aspects) MUST be restored to all Asset

Optimization Server nodes. Reference the Service Structure for the Asset
Optimization Server.

It is required that ECS software is installed prior to continuing with SAP integration.

a.

Configure ECS software. Refer to the ECS configuration in System S800xA
Asset Optimization 5.1 Configuration (3BUA000I 18%) for more
information.

If the SAPDef files were customized, restore the customized SAPDef files
from safe media to this directory (assuming the default directory was
selected during Asset Optimization installation)

For 64-bit:

...\Program Files (x86)\ABB Industrial IT\Optimize
IT\Asset
Optimization\AOECSConnector\SAPPMDef\CustomDef
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For 32-bit:

...\Program Files\ABB Industrial IT\Optimize IT\Asset
Optimization\AOECSConnector\SAPPMDef\CustomDef

Refer to System 800xA Asset Optimization 5.1 Configuration
(3BUA00O] 18%*) for more information on SAPDef files.

c. If SAPModel is customized, restore the AOSAPModel.xml to the
following location:

For 64-bit:

...\Program Files (x86)\ABB Industrial IT\
Optimize IT\Asset Optimization\AOECSConnector
\ECSDefinitions

For 32-bit:

...\Program Files\ABB Industrial IT\Optimize IT\Asset
Optimization\AOECSConnector\ECSDefinitions

Ensure that ABB SAP Connectivity system extension is loaded.

The pending fault reports residing in the system can be restored to the following
directory structure. Restore the entire OptaoACDs folder.

<<install drive>>:\OperateI TData\OptaoACDs

4.  After a restore of a 800xA 5.1 system, the Asset Optimization Server (Monitor
Server/Engine) may appear to be running. The AO Server tab of the
AssetOptimization Server aspect will show a status of good: AM Engine
Running.

a. Clicking the Asset Monitors tab and selecting AMs assigned to this AO

Server will show that the values in the Status column are Not loaded,
enabled.
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Click Load all AMs to reload all the enabled asset monitors assigned to
this AO Server.

ﬂ The DMS Calibration Integration approach is changed 800xA 5.1. Reconfigure
the DMS Calibration Integration based on an engineered solution. Contact ABB
technical support for more information.

PC, Network and Software Monitoring

Use the following procedure to restore PC, Network and Software Monitoring
information:

ﬂ This procedure is only necessary if there are user defined Script, Resource, and
Assembly files in the 800xA System.

1. If user defined Script, Resource, and Assembly files were backed up, copy the
saved files from the safe media to the following directories (assuming the
default directory was selected during installation):

For 64-bit:

...\Program Files (x86)\ABB Industrial IT\Optimize IT\
PC, Network and Software Monitoring\bin\Configuration\
Scripts\User

...\Program Files (x86)\ABB Industrial IT\Optimize IT\
PC, Network and Software Monitoring\bin\Configuration\
Assemblies\User

...\Program Files (x86)\ABB Industrial IT\Optimize IT\
PC, Network and Software Monitoring\bin\Configuration\
Resources\User directory

For 32-bit:

...\Program Files\ABB Industrial IT\Optimize IT\
PC, Network and Software Monitoring\bin\Configuration\
Scripts\User

...\Program Files\ABB Industrial IT\Optimize IT\
PC, Network and Software Monitoring\bin\Configuration\
Assemblies\User

...\Program Files\ABB Industrial IT\Optimize IT\
PC, Network and Software Monitoring\bin\Configuration\
Resources\User directory
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SMS and E-mail Messaging

Restore all GSM Device hardware information. Configure the GSM device per the
information recorded on the SMS and E-mail Messaging GSM Hardware Setup
Worksheet during backup.

PLC Connect
If either the IEC60870 or Basic Project Objects features were installed:

1.

It may be necessary to stop and start the Messenger Server Service in the Service
Structure after the SMS and E-mail Messaging restore operation.

Use standard Windows procedures to access Add/Remove Programs in
Windows Control Panel.

Select ABB PLC Connect.
Select Change/Modify.

The InstallShield Wizard for PLC Connect appears. Refer to System 800xA
Manual Installation (3BSE034678*) and System 800xA Post Installation
(3BUA000156%) and continue install the desired features.

If the IEC60870 feature is installed refer to System 800xA 5.1 PLC Connect
Configuration (3BSE035041%) and reload the saved IEC configuration.

To restore the PreTreat2.dll and PreTreat3.dll files:

1.

If the PLC Connect Communication Server Pre Treatment function is being
used in the application, copy PreTreat2.dll and PreTreat3.dll from the backup
location to the same folder as they were backed up from on the PLC Connect
Connectivity Server. If the default folder is used, that location is \ABB
Industrial IT\Operate IT\PLC Connect\Bin.

Register the PreTreat2.dll and PreTreat3.dll files (refer to System S800xA 5.1
PLC Connect Configuration (3BSE035041%) for more information).

Restart the PLC Connect Connectivity Server for the changes to take effect.
Restore the VB projects for PreTreat2.dll and PreTreat3.dll.
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To restore the PreEvent.dll file:

1.

3.
4.

If the PLC Connect Event Server Pre Treatment function is being used in the
application, copy PreEvent.dll from the backup location to the same folder as it
was backed up from on the PLC Connect Connectivity Server. If the default
folder is used, that location ..\ABB Industrial IT\Operate IT\PLC Connect\Bin.

Register the PreEvent.dll file (refer to System 800xA 5.1 PLC Connect
Configuration (3BSE035041%*) for more information).

Restart the PLC Connect Connectivity Server for the changes to take effect.

Restore the VB application project for PreEvent.dll.

To redeploy the PLC Connect configuration:

1.

Use the Structure Selector to open the Control Structure in the Plant Explorer
Workplace.

Use the Object Browser to navigate to the first Generic Control Network
object.

Select Deploy in the Aspect List area.
Click Deploy in the Aspect Preview area.

The deploy begins and the progress is displayed in the Aspect Preview area.
The deploy is completed when Deploy ended is displayed.

Repeat the procedure for any additional Generic Control Network objects.

800xA for Advant Master and Safeguard

1.

Copy back the saved files
...\ProgramData\ABB\AC400Connect\AdvantBase\Data
\RTA\Init\ folder to the applicable connectivity server in which they belong:

— DATHRI1.CD
— DATHR2.CD
— DATHR3.CD

ﬂ Before restoring these files, ensure that the node being restored is running the
same character conversion language used by the node from which the files were
backed up.
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2.

Restore the MB300 node, network address and REVERSED_SYNCH_MODE
and PU410 redundant cable supervision settings for the RTA board in the RTA
Board Control aspect, using the settings you wrote down before backup.

A restore is required after replacement of the DATHRx.CD files. Ensure that the
RTA board is restarted before being connected to the MB300 network.

For each Connectivity Server, compare the saved files,
AdvDsMasterAdapter.csv and AdvMbAeOPCServer.csv with the installed
version of the files in <installation path>\bin. If any customization was done
to the old files, update the installed version of the files with the corresponding
changes.

800xA for AC 800M
Use the following procedure to restore 800xA for AC 800M information:

1.

The OPC Server Service Account should be set in the OPC Server Setup
Wizard.

Control Builder stores its settings (systemsetup.sys) on disk. Replace the
existing file with the file saved on the safe media. The systemsetup.sys file is
located in the Control Builder working folder.

The OPC Server stores configuration files (*.cfg) and settings
(systemsetup.sys) on disc. Replace these existing files with the files saved on
the safe media. The systemsetup.sys file is located in the OPC Server working
folder. The configuration files are stored in the Files folder in the same
location.

Restore OPC configurations by selecting File > Load Configuration in the
OPC Server Panel.

Restore of Control Builder projects is done by using the ordinary 800xA System
backup/restore utility. This function also includes cold retain files stored by the OPC
Server.

800xA for Harmony

Use the following procedure to restore 800xA for Harmony information:
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1. Log in to the 800xA Installing User account (or a local Administrator account)
on the Configuration Server or Configuration Server with Connectivity Server
node.

2. Select:

Start > All Programs > ABB Industrial IT 800xA > 800xA for OCS
Systems > Harmony > Configuration > Restore Configuration

3. Click Connect in the Harmony Connect Configuration Backup/Restore
window.

4. Enter the name of the Harmony Configuration Server database backup file in
the Backup File field.

5. Click Restore.

6. If a prompt appears indicating that the system version does not match the
backup version, click Yes.

7. If the message Services must be stopped, REBOOT system now
then restart this application! is displayed, restart the node and
repeat Step 2 through Step 6.

8. The Backup/Restore program compares the old configuration in the backup file
to the current configuration of the newly installed system. If the hosts of the
Primary and Redundant Connectivity Servers do not match, a dialog will
appear (Figure 49) allowing the user to map the old Connectivity Server node
names to the new Connectivity Server node names.

a. Select the Create Missing Servers in Installed Configuration (Disaster
Recovery) check box if one or more of the Connectivity Server Nodes
does not appear on the Installed Configuration side of Figure 49.
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. Map Connectivity Servers |
r— Backup File Configuration - Installed Configuration
Frimary CS Redundant CS Frimary CS Redundant CS

Connectivty Server Set 1 [HrDEVEST | [ =l JHCDEWCS1 |

Connectivity Server Set 2 I j I j INJA |

Connectivity Server Set 3 |N£A j | j JH |

Connectivity Server Set 4 I j I j | |

Connectivity Server Set 5 I j I j | |

Connectivity Server Set 6 I j I j | |

Connectivity Server Set 7 I j I j | |

Connectivity Server Set 8 I j I j | |

v iCreate Missing Servers in Installed Configuration [Disaster Recovery}

Reset to Defaults | ak. Cancel

Figure 49. Map Connectivity Servers

9. Click Exit when the restore operation is complete.

Duplicate server objects may be created in the Harmony Configuration Server

ﬂ node after performing a Harmony Restore Configuration on a running system.
Restart the Harmony Connectivity Server nodes to ensure the correct server
objects are utilized.

800xA for AC 870P/Melody

Use the following procedure to restore existing 800xA for AC 870P/Melody
ConfigServer information:

1. Log in to the 800xA Installer account or an 800xA administrator account on the
ConfigServer node.
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2. Use the 800xA for AC 870P/Melody Config backup / restore utility to restore
the Melody Configuration information from a saved backup.

a. Select All Programs > ABB Industrial IT 800xA > 800xA for AC 870P
Melody > Configuration > Restore Configuration.

b. Click Connect in the 800xA for AC 870P/Melody Configuration
Backup/Restore window.

ﬂ The Connect button manually initiates the connection to the configuration
database using the current Windows account security. This account must have
Administrative access to the system and Configuration Server database.

Refer to the MSSQL file folders for the .bak files generated upon successful
backup.

The last successful backup name is preloaded into the screens Backup/Restore
Backup File name field.

c. Enter the name of the 800xA for AC 870P/Melody Config Server database
backup file in the Backup File field.

d. Click Restore.

e. If prompted that the system version does not match the backup version,
click OK.

ﬂ If the message Services must be stopped, REBOOT system now
then restart this application! isdisplayed, restart the node and
repeat Step a through Step e.

f.  Click Exit when the restore operation is complete.

ﬂ After restoring a ConfigServer restart all Config Server and Connectivity Server
sequentially and wait to start the next Connectivity Server until the former
Connectivity Server has finished SQL replication.

This sequence avoids a high Config Server load and replication time-outs due to
parallel replication after a parallel restart of several Connectivity Server.
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Batch

This section is only required when using Batch with 800xA for AC 870P/Melody.
Perform the following restore procedure:

1. Import the Functional Structure and Procedure Structure using the
Import/Export tool.

2. Use the Melody Restore Configuration utility to restore the ConfigServer
configuration.

ﬂ Reading from a network drive is not supported. Copy the file to the local disk
first.

3. Restore the Melody Composer project.

800xA for MOD 300

AdvaBuild is the engineering tool used to restore 800xA for MOD 300 control
system information. The AdvaBuild Administrator User Guide (3BUR001977%*)
instruction provides information needed to manage the AdvaBuild projects.

Basic History Service Data
To restore Basic History Data, use the following steps:

1.  Go to the Maintenance Structure and select the Basic History Backup object
under the Backups, Backup Root object.

2. Select the Backup Info aspect, see Figure 50.
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FlE |(Enter search name) j |N0 Filer j 5 |[replace ~ || %8| @ (0| % | G| 65 2R
|‘Ed Maintenance Struckure j Aspects of 'Basic History Backup; 20... | Modified | Desc... | Inherited | Category name |
— 9 Backup Definitions, Backup Definition Rodt Backup Info 2005-12-01 13:3...  This... False Backup Info
H Basic History Backup, Full Backup Defiritior Full Backup Type Reference 2005-12-01 13:3... False Ful Backup
-3
= 9 Eackups, Backup Roak | Maintenance Structure 2005-12-01 15:3...  [Main... False Maintenance St...
H_ Basic History Backup; 2005-12-01; 13-31, BIName 2005-12-01 13:3... The... False Mame
Ei Synchronization Definitions, Synchronization O @Object Icon 2005-12-0113:3... Icon... False Object Icon
9 Synchronization Packages, Synchronization P
@ Synchronizations, Synchronization Root
+ 9 System Configuration Yersion Definitions, Sysh
@ System Configuration Versions, System Canfig
Q Bl [Basic History Backup; 2005-12-01; 1+ | & o9 <
Skatus IScope ] Storage I Restore ]
Backup Type: External Services
EBasic Histary Ready @

Figure 50. Backup Info aspect

3. Select the Restore tab. See Figure 51 below.

@ B+ [BasicHistory Backup; z005-12-01; 1~ | 5 P M

Status] Scope ] Storage Restore 1

B aszic: Histam @

s

Cancel Apply Help

Figure 51. The Restore tab

4. Click Apply.
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5. The Restore button to the left in the dialog will be enabled. Click the button
and then OK to start the restore.

Information Management

Use the History backup and restore utility to restore the Information Management
History database and synchronize the Aspect Directory contents with the current
Information Management History database configuration.

During the restore, the existing database configuration is replaced by the
configuration being restored. The restore will return all the data in the history logs to
the time the backup was created. Mount points and additional table spaces are
created based on the database being restored.

Oracle data is imported, and the file-based property logs are copied back into the
system. Unless a different mount point is specified, the History database will be
restored to its original location (its location prior to being backed up).

The History database can be restored from any drive on the workstation, including
any mapped network drives. Running the Restore Utility

To restore a backed up History database:

1. Verify PAS is stopped. If the PAS is not stopped, Stop all PAS processes (Refer
to the System 800xA Information Management 5.1 Configuration
(3BUF001092*) instruction for more information).

2. Ensure that no third-party applications access the Oracle database during the
restore operation.

3. Stop the Inform IT History Service Provider:

a. Select the Inform IT History Service Provider object in the Service
Structure in the Plant Explorer.

b. Select the Service Provider Definition aspect.
c. Select the Configuration tab.

d. Disable the Enabled option.

e. Click Apply.
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4. Select Start > All Programs > ABB Industrial IT 800xA > Information
Management > History > Backup and Restore.

5. Verify that the Restore Configuration from the Backup File option, is enabled
in the IM Historian Backup/Restore Utility window.

6. Click Next. A window for setting up the restore operation is displayed.

7.  Specify the location of the backup files in the Path of IM Historian Backup
field.

8. Click Next. The HsBAR Output Window is displayed.
9. Enable the Automatically Close Upon Completion option.

10. After the HsBAR Output Window closes, monitor the progress in the Progress
Status area of the IM Historian Backup/Restore Utility window.

The restore of the system requires an instance that matches the size of the

ﬂ database being restored. When creating the instance, be sure to select Small,
Medium or Large based on the size of the message log in the backup being
restored. Select Large, if the size is not known. The restore operation may fail
with the Oracle Error Message 1652 - Unable to extend tmp segment
in tablespace temp, if the wrong size is selected. Repeat the restore with
the correct instance settings if error occurs.

11. Click Next when the button becomes available. The synchronizer part of the
restore process starts now.

12. Click Finish when a message stating that the execution is complete, is
displayed.

[IC ST iR Ar I TEUUTIFIZSL T I LU 2RI ISP UL ey

145745

14:57:45: Click 'Finizh' to exit the application -
»

[« |

Lanzel |
< Back I Finizh I Cancel

Figure 52. Execution is Complete Message
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If the Progress status dialog box has warning messages with possible solutions as
indicated in Figure 51, read the possible solutions carefully, then click Finish and
proceed with the solution that best fits the problem. Refer to the Information
Management Release Notes for further guidelines.

IM Historian Backup/Restore Utility x|

Progress Status

14:57.35: HistSync: Updating LogSet3, Inform IT Higtory Log Set ;I
14:57:36: HistSync: Updating LogSetz, Inform [T History Log Set

14:57.36; HistSync: Updating LogSetd, Inform IT Higtory Log Set

14:57:36: HistSync: Updating $HSIMMSGLOG_IP_10_126_0_128-1-0, Inform [T Histary Messe
14:57.38: HistSync: Updating $HSFinishedReportz-1-0, Inform IT History Report Log

14:57:40: Execution of Histary Sync iz complate.

14:57:45: Validating AIP Source [nfarmation.. [250]

145745 WARNIMG: 2 higtory logs did not match what iz in the azpect spstem!]

14:57:45 Possible Solutions:

14:57:45: 1] Run 'heDEMaint -checkDB' to determine which logs are not matched

14:587:45:  and hsDEMaint -clean’ to remove thozse logs fram the hiztarian

145745 2] Repeat spstem reztore procedure and ensure that all control objects

14:57:45:  have been properly restored into the spstem.

14:57:45: 3] Run IM Historian B ackup/Restore tool in numeric log synchronize mode

14:57:45:  and reconnect histary logs to existing contral objects

14:57.45:

14:57:45: Click 'Finish' ta exit the application =

« | o
LCancel |

< Back I Finizh I Cancel

Figure 53. Progress Status Dialog Box

Restoring Other Information Management Related Files

There are several other files related to Information Management that need to be
restored as part of total system restore.

More detailed instructions for this procedure can be found in the section of
restoring individual Information Manager applications, in the appropriate
Information Management instruction.

*  History Archive Data: For each archive device, copy the appropriate folders
from the safe media to the location specified by the Device Filename. Copy the
archive status information to:

C:\ProgramData\ABB\IM\Archive
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*  Reports: Restore any report template files created in Microsoft Excel,
DataDirect, and/or Crystal Reports. Also restore report output files created as a
result of running these reports via the Scheduling Services.

*  Desktop Trends: Restore trend display, ticker display, and tag explorer files.

* Display Services: Restore the directories for custom users, as well as display
and user element definitions.

* DataDirect: Restore custom text files for object, object type, and attribute
menus used on the DataDirect windows.

For more information refer Information Management Server on page 181.

ﬂ At the end of this restore process, PAS has to be started again. Verify the ABB
process administration process is set to automatic and the start the process.

Process Engineering Tool Integration

Use the following procedure to restore Process Engineering Tool Integration
information:

Restore the backed up data directory (saved prior to backup of the system) to the
installed directory of Process Engineering Tool Integration.

Assuming the default directory was selected for Process Engineering Tool
Integration installation, restore the entire Xml directory contents to:
...\Program Files\ABB Industrial IT\Engineer IT\Engineering Studio\Process
Engineering Tool Integration\Xml

Structured Data Log (SDL)

For a full description of the Backup and Restore statements, refer to SQL Server
Books Online > SQL Server Architecture > Administration Architecture >
Backup/Restore Architecture and to Transact-SQL Reference.

The SDL database is restored using the SQL Query Analyzer tool installed with the
SQL Server 2000.

The following Transact-SQL statements should be executed:

. Select the “master” database.
USE master
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»  If the logical backup devices are not present create them as shown in the
section Structured Data Log (SDL) on page 95 and make sure that the backup
files are at the location pointed to by these logical devices.

. Restore the SDL database.
RESTORE DATABASE SDL FROM SDL_BU

o Restore the TnT database.
RESTORE DATABASE TnT FROM TnT_BU

800xA for IEC 61850

Restore the backups of the IEC 61850 CET OPC Server projects. Refer to Section 6
of System 800xA IEC 61850 Configuration (9ARD171387%).

ﬂ Handling of IET/CCT projects and PCM 600 projects is not described here as
they are external tools contributing to the IEC 61850 workflow. They do not
reside on 800xA System nodes.

How to make a Full Backup

Follow the recommendations below to make a Full Backup.

1. Create a Full Backup Definition object with definitions of scope and storage
settings.

2. Configure the Backup Definition aspect.

3. Inthe aspect, select the Summary and Start Backup tab and click the Start
Backup button to start the backup.

4. A new Full Backup object is created when the Full Backup is running. It will be
created in the Maintenance Structure under the Backups object. It will be called
<Backup Definition Name>; <Date>; <Time>. For an example of the path, see
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Figure 54 on page 125.

ﬂ <Backup Definition Name> is the name of the Backup Definition object the
backup was created from. <Date> it the date when the backup was started.
<Time> is the time when the backup was started.

A backup consists of a BackuplInfo.xml file, and a set of files containing actual
backup data. The backup object has a Backup Info aspect, with Scope, Storage, and
Status tabs.

Warning messages occur if there are any undeployed graphic or faceplate
elements. They are seen in the Backup Info Aspect and recorded in the Backup
log file. These warnings do not need to be acknowledged.

Backup Object

The Storage tab shows the node on which the backup was made. It also displays the
backup path and the size of the backup.

If the backup is copied to a media, for example a CD or DVD, the media code can be
entered in this dialog as well. See Figure 54 below.

!@'ﬂl MyBackup; 2005-03-08; 09-34 526msec : Backup Info
L~ [MyBackup; 2005-03-08; 09-34 526m - | % 75 -

Status ] Scope | Gto éﬂél

Run backup on node: |

Backup path on node: |

Backup size on disk: |

Media Code: | AAAAA-BEBEE_BBE-021125

| | Help

Figure 54.The Storage Tab of the Backup Info Aspect
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The Status tab displays the progress and status of an ongoing backup as well as the
status of a finished backup. The log file can be displayed on a finished backup.

ﬂ Aspects and objects are restored from the Configuration Wizard,
and not from this tab.

Backup Service

The Backup Service runs on each aspect directory server node in a service group.
The Backup Service is not redundant, but the different backup service providers
enable backups to be run on different nodes.

Backup Service Provider Definition Aspect

It is possible to make specific configurations of the Backup Service Provider object.
Select the object in the Service Structure. Go to the Service Provider Definition
aspect and select the Special Configuration tab. See the figure below.

O % - |BackupService_Basic_TICCD1:Servicnj ﬁ ’(? % - -

Identification | Configuration Special Canfiquration | status |

Path definition

-,
Backup path: | HBACKUP
Free disk space limit

— 400 j e

Low disk space warning limit

I_)ll 2,000 ﬂMB

| Help

Figure 55. Special Configuration Tab
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In the Path definition area a root directory (Backup Path) for all backups can be set.
It is made by the Backup Service provider. The default value for the path is set in the
Storage Path area under the Configuration tab of the Service Definition aspect.

ﬂ The disc that the backup runs on should be on the local workstation.

It is also possible to specify a Free disk space limit. The backup service guarantees
that this amount of disk space is free after any backup is made.

If the limit is passed during a backup, the backup operation will fail and an error,
as a system message and an audit trail, will be issued.

A low disk space warning limit can also be specified in this tab. If there is less disk
space available than the limit, a warning is issued as a system message and an audit
trail is issued.

The Identification, Configuration and Status tabs are standard tabs available for
all service providers.

Scheduling a Backup

ﬂ Scheduled 800xA System backups cannot be aborted from the Application
Scheduler.
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Full Backup Definition objects can be scheduled. Select the Scheduling Structure
and configure what to schedule in an action aspect. Scheduling is a System
Extension which has to be installed.

&8 SEVST-W-0000609 System // Plant Explorer Workplace

| |3 [ Enter search name) ]| [NoFiter <5 [Replace 1| 3| @ (3| %4 3

E;- Scheduling Structure j | Aspects of 'Job Description’ | Modied | Desc... | Inherited | Cakegory name |

[= 95 Schedules and Jobs Ackion Aspect 2003-05-28 16:2...  Sped... Fase Ackion Aspect

= Ev Job Descriptions Job Description Type Reference 2003-05-28 16:2.., False ot Description
%) Job Description, Job Description (| 2 Name 2003-05-25 16:2... The.. Falss MName
@ Rurcing Jobs B obiect Ieen 2002-11-27 18:1...  Icon... True Object Teon
Scheduling Definition 2003-05-28 16:2..,  Defin... False Schedulng Defi.. .

B Scheduling Structure 2003-08-28 16:2,., [Sch.., Fase Schedulng Stru...

& [ = |00 Description:action Aspect Bk -y =

Action: - Time Limk {seconds): 30
Isolated: ¥ Prieity: 1 Atbempks: 1 System Messages: | DECMIEEE -

Select Backup Definition Dbject for scheduled backup

[aspect Data 2 =l

Figure 56. The Action Aspect
In the example above, a Backup Definition object called Aspect Data 2 is selected
to be scheduled.

For more information about scheduling, see the System 800xA 5.1 Administration
and Security (3BSE037410%*) instruction.

How to make a Restore

It is important to follow the instructions and recommendations below before starting
a restore procedure. The restore will recreate an equivalent system, after a node
failure. It is also a recommended way to transfer data between one version of the
system to another during an upgrade.

Preparing the Restoring Process

A restore of a 800xA System is performed from the Configuration Wizard.
The same or a later version of the 800xA system and all System Extensions that was
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installed when the backup was done, need to be installed when the system is being
restored. Make sure the right processes are running and that no system exists.

ﬂ The processes are AfwTraylcon.exe, AfwSMClient.exe and
AbbClientLicenseProvider.exe

Restoring a Backup Containing Aspect Data
1. Open the Configuration Wizard.

2. Select Restore System and click Next in the Configuration Wizard.
See the figure below.

B Configuration Wizard =

Select Type of Configuration

Please choose which task to accomplish by selecting appropriate icon and pressing -.:
Mext

Ackion | Description |
Q7 System software User settings  Windows Users and Groups used by the System software
-',!,—fSystem Adminiskration Start, stop, delete and maintenance of system

I_: Start Server Starts all manually started systems on a server

Stop Server Stops all systems running on a server

B*'Create Syskem Creates a new syskem

WRestore Syskem Restores a saved system

:‘l‘Maintenance Maintenance for Process Portal &,
[ applog Applog settings

% Connect Node Connect this computer to a system

Figure 57.The Configuration Wizard - Restore System

The restore functionality is used to restore backups containing Aspect Data. It is
available from the Configuration Wizard, see Figure 57. The Configuration Wizard
is the only way to restore Aspect Data.
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Backups with only Service Data, on the other hand, can be restored from the Backup
Info aspect when the system is running.

@ Configuration Wizard

System Directories Selection

The system directories have to be selected before restore is started. The
directories must not exist

System paths
Server data: I C:\OperatelTDatal
Server data2: I C:\OperatelTDatal
Project data: I C:\OperatelTDatal
Workplace data: I C:\OperatelTData1\Temp

~System identity
" Use the same system id

(* Generate a new system id

Enter system name: I MyMewSystemMName

View Log ... | < Back I Mext = I Cancel | Help |

4

Figure 58.The Restore Selection in the Configuration Wizard

You need to specify the path to a location of the backup. Specify the root directory
and the application will search for backups below the root. Available backups will
be shown in a list.

Finding the Backup Files

1. Click the Select Path button (Figure 58) to enter the path for available
backups.

2. Click OK to close the dialog and the tree will display available backups. If the
same backup is found more than once you will get a warning and the first one
found will be used.

To get more detailed information about the selected backup in the tree, click the
View Info button and an Information dialog will be displayed.
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Selecting a Backup to Restore

Select one backup to be restored in the tree view to and click Next. From the
selected backup, the aspect directory is restored. During the restore it is possible to
generate a new system id and System Name for the restored system. This is not
needed if no changes will be made. Click Next, see the figure below.

£ co nfiguration Wizard

System Directories Selection
The system directories have to be selected before restore is started, The
directaries must nok exist

Syskem paths

Server data: | Ci\OperatelTDatal |
Project data: | Ci\OperatelTDatal |
workplace data: | C:\OperatelTDatal| Temp |

Syskem identity
(O Use the same system id

@ Generate a new syskem id

Enter system name: MyMewSystemMame
[ < Back ” Mext = ] [ Cancel ][ Help ]

Figure 59. Configuration Wizard - Restore to New System

ﬂ If a backup will be restored to the same network as the original system is running
on, it is necessary to generate a new system id and name during restore. Two
systems with the same id and name can not exist in the same network.

If the restore runs in a different system than the backup was made in, a primary node
in the backup system must be remapped to the node your are running the restore on.
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You remap a node by right-clicking the node in the restored system, and changing
the node name. See the figure below.

Eco nfiguration Wizard

Node Configuration
Restore must be performed on one of the primary nades in the backup,

Primaty nodes:

Modes in restored system  Criginal nodes in backup

MEWNODELQD AIPIDOGG
MEWNODEL0Z2 AIPIDOZT
MEWNODELD3 AIPIDOZ3

Secondary nodes:

Modes in restored system  Criginal nodes in backup

NEWNCDEL04 AIFIDOES
NEWNCDEL0S AIPIDO0E
NEWNODELDG AIPIDO21
i AIPIDO13

J [

[!iewLUg...] I < Back. ” Next = I I Cancel Help

l

Figure 60. Node Configuration - Other Node

3.

Click Next.

Eco nfiguration Wizard

Apply Settings
Configuration wizard will configure the system accarding to the Following
specification:

FEESUmmary info of seleckions™**
SystemMame: AIPIDOGL System
SystemDescription: The system as created by the Configuration ‘Wizard

ServerData: Ci\OperatelTDatal

ProjectData: Ci\OperatelTDatal

WorkplaceData:  C:\OperatelTDataliTemp

Backuphane: Wasa AE testbackup; 2004-04-07; 16-23

BackupPath: CABACKUPYWasa AE testbackup; 2004-04-07; 16-231BackupInfo.xml
Modes:

Mode: has been mapped to node:

AIPIDOA1 SEYST-W-0000609

[ < Back ][ Finish ] [ Cancel |[ Help

Figure 61.Apply Settings
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4. Click Finish to complete the restore.

The Restore is not completed until the Aspect Directory is restored. The system is
running when restore is finished.

Upgrade Older Versions

Backups of older versions of the 800xA System will show up in the backup list in
the Restore Selection dialog, (Figure 58), in the same way as backups from a system
of the same version.

It is possible to restore backups from an earlier version to a later version of the
system. After the restore an upgrade procedure will be performed to convert data.
See also the System 800xA Upgrade (3BSE036342%) instruction.

ﬂ Before the restore is started you will get a report of what your restore will
include. It also includes information about restoring from an older version i.e.
doing an upgrade.

System Configuration Version

The System Configuration Version is created in the same way as a full backup.
The only difference is that the object type name is System Configuration Object
Type. The System Configuration Version is not configurable.

1. Select the System Configuration Version Definition object in the Maintenance
Structure.
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ﬁlw-ﬁisd Product System // Plant Explorer Workplace _ Dlﬁl
[repiace =1 | 48] @ &) | %4 | 8]
IT:: Maintenance Structure j Aspects of 'System Configuration Ve, ., | Madified | Desc... | Inhetited | Category name
Backup Definitions, Backup Definition Ro Backup Definition 9/6j2004 12:57:1... This... False Backup Definition
s

J | p ||§|I {Enter search name) j“No Filker j T/:’

H fspect directary backup, Full Backup Eu\l“1a\ntenancza Struckure 5/19/2003 4:27:4... [Main.., False Maintenance St
i H Full Backup, Full Backup Definition 3Name 5/19/2003 4:27:4... The... False Marne
) Backups, Backup Ract & Chiect ean /27/2004 4283, len... False Obiect Icon
fo H Aspect directory backup; 2004-09-02 System Configuration Version Defi...  10/3{2003 12:17:... False Syskem Configu...

Q Synchronization Definitions, Synchronizat
9 Synchronization Packages, Synchronizatid
Q Synchronizations, Synchronization Root
E| Q System Configuration Yersion Definitions,

|7 Svstem Configuration ¥ersion Definiti ”Q I, = [System Configuration Version Definiti x| % & -
a System Configuration Yersions, System J

Scope | Storage  Summary and Start backup |

The definition of this system configuration wersion is:

Scope: Current version of aspect and object is included in this definition
Service with external data: Basic History System Message

Backup service provider: BackupService_Basic_PPAID 1

Node: PPAID11

Path: CHEACKUP

Available Free disk space: 20192

Lser name: PPADCO&Ippaservicel

System name: v 35d Product System

| Create System Configuration Yersion,.. I

0| | v Cancel | Appliy I Help |

‘ ‘ & - PPaService 1 pRBE

Figure 62. System Configuration Version Definition

2. Select the Backup Definition aspect and set a version identity in the Summary
and Start Backup tab by clicking the Create System Configuration
Version.. button. See the figure above.

3. The tab includes information about Scope, Services, Node and Path etc.

4. Click the Create System Configuration Version button. A dialog is displayed
where you enter the version. Click OK.

5. There is now a complete version of the system with an ID.

The restore process for a System Configuration Version works in an ordinary way,
see Restoring a Backup Containing Aspect Data on page 129.
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Warning and Error Messages

The warning and error messages that can be generated by the 800xA backup/restore
utility are described in the following topics. Suggested solutions are also provided.

Failed to serialize aspect

Example

Tue Jul 01 08:41:03 2003 [Error]: Failed to serialize aspect 'Operator Messages
Link Display' on object "'Web System Workplace'

Reason

It is not possible for the Backup function to save the aspect data.

Solution

Check in the system for the behavior of this aspect.

ASO object class xxxx did not implement IAfwAspectSystemObiject. Failed to
create ASO. Forgot to register dll?

Example

Tue Jun 10 19:02:17 2003 [Error]: ASO object class {7B7A13B3-8BB4-42A3-
8289-987C579797C2}did not implement IAfwAspectSystemObject Failed to create
ASO. Forgot to register dl1?

Reason

This often occurs when a system extension is used, but not installed on the node
from where the backup is taken. It can also happen if an update of a system
extension has been installed, but not added to the system.

Solution

Install and add all system extensions on the node from where the backup is taken.
Make sure that the correct version of the system extension is installed.
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UnplacedObjects.afw

Example
[Warning] c:\\PPABackup\MyBackup\UnplacedObjects.afw created

Reason

During backup process, the backup tool goes through all structures, if there is an
object that doesn't exist in any structure, it will placed in UnplacedObjects.afw and
write a warming in the backup log, therefore, UnplacedObjects.afw is used for all
objects which miss structure.

Solution

Check if there is any important object in UnplacedObjects.afw. If there is an
important object in UnplacedObjects.afw, your backup is considered to be not
complete. In such case, investigate what kind of object it is, and try to repair the
system. One solution could be to add the object into the structure it should belong
to. Take another backup.

The system cannot find the path specified

Example

Error detected for aspect 'Empty A3P' of object 'Document Manager
Templates/Document Manager File Templates/Drawings'

Tue Jun 08 00:43:30 2004 The system cannot find the path specified.

EbServiceHandler: Object Id = {9AFACBAS5-6B6A-462A-9EDF-78765740CD52},
Aspect Id = {89F8A8C4-10F7-4874-B77D-A8E6445D5C93}

EbServiceHandler: Failed to load document into stream!

Reason

When the backup was taken, the FSD cache was set too low. All data has NOT been
backed up. There should be warnings in the System Event list about overflow in the
Fsd cache.
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Solution

Increase the Fsd Cache size (for all nodes).

System Extension "xxxx~ with id ‘Guid’ is not installed on this node

Example

System extension 'Engineering Base' with id {B775BEA4-7859-4649-AE16-
9017908228861} is not installed on this node.

Reason

There is a system extension, which is not available in the node where the backup is
taken, or which is not properly removed. The latter can be the case if AC800
Connect has been upgraded and the old version is still registered in Industrial IT
800xA.

Solution

Use a backup node where all system extensions are installed.
Graphic aspect = xxx cannot be imported

Example

Mon Mar 29 19:52:32 2004 [Error]: Object = WI Mezzanine Deck, graphic aspect =
Page Prev cannot be imported. Source directory =
d:\OperateITData\Temp\ActiveGraphics\{ S00BA917-3D7F-44B6-B647-
90C4B06A98FA } .restore.2.

Reason

Could be different reasons.

Solution

Check the source directory specified in the error message. The log file in this
directory should give some hints of what caused the problem.
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Too many aspects of category

Example

Sat Jun 05 17:04:33 2004: Too many aspects of category 'Name' on object
'{82416BDF-5464-4422-A443-35E08E1065BE}'

Sat Jun 05 17:04:34 2004: Import/Export Error: Object {82416BDF-5464-4422-
A443-35E08E1065BE} ({82416BDF-5464-4422-A443-35E08E1065BE}) -
E_AFW_AD_TOO_MANY_ASPECTS (0x8abb081b) To many aspect of a specific

type.
Sat Jun 05 17:04:34 2004: Failed to restore file C:\BWSC\BWSC Full Backup;

2004-06-03; 03-00\Control Structure28.afw. The importer returned hr =
0x8abb081b

Reason

The system was inconsistent at backup time (there were more than one aspect of
category 'Name' on an object). The backup does not react on this, but restore will
fail. The restore part will be fixed in a later release (it will be possible to import such
an object, but a warning will be granted).

Solution

Open the file (in this case Control Structure28.afw) with the old import/export
utility (<Install path>\bin\AfwImportExport_obsolete.exe), search for the aspect
category and manually remove one of the two aspect categories.

Aspect category is missing

Example

Sat Jun 05 16:41:27 2004: Aspect '{506D9D24-E22A-4EDB-AFBO-
0753B6DB6990}' on object 'SoftPoint Object Types' cannot be restored because the
aspect category is missing

Sat Jun 05 16:41:27 2004: Objectld: {9574CC3B-0ESE-4B14-A83E-
F483CCDEG6E44}
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Sat Jun 05 16:41:27 2004: Aspectld: {506D9D24-E22A-4EDB-AFBO-
0753B6DB6990}

Reason

One or more aspect category has been removed, while there are aspects of that
category still in the system. This inconsistency was present in the system when the
backup was taken.

Solution

If the aspect category has been removed then these aspects may not be of interest
any more. Check if the aspects are needed. If not, ignore this message.

Unknown transaction error

Example 1
Mon Apr 19 13:39:40 2004: Unknown transaction error

Reason

If this is the only error message, there is probably a problem with some windows
resources.

Solution

Check your windows resources.

Example 2

Mon Jun 28 08:37:08 2004: Loading C:\BACKUP\Full Backup; 2004-06-23; 10-
39\Aspect System Structure(.afw ...

Mon Jun 28 08:37:09 2004: Aspect 'Batch Management Operation' on object 'Batch
Management Documents' failed to unserialize itself.

Mon Jun 28 08:37:09 2004: Objectld: {814786F8-E6CC-44B0-9A2A-
1787FADDFEGF}
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Mon Jun 28 08:37:09 2004: Aspectld: {2CE41978-DE94-44AC-9D38-
B216FBA93C3A}

Reason

It is not possible for the Restore function to restore the aspect data with no solution.
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Introduction

This section describes the general procedure that must be performed in order to
recover from a node failure in a complete 800xA 5.1 800xA System (including all
functional area information).

ﬂ 800xA for DCI is not included with the initial release of 800xA 5.1and thus
800xA for DCI connectivity server replacement instructions are not documented
in this user manual. Connectivity server replacement instructions will be provided
with the 800xA for DCI 5.1 release documentation.

Recovery Paths

The three possible recovery paths discussed in this section are:

*  Reinstall Like New on page 141.
*  Reinstall and Restore on page 142
*  Recover Node on page 143

The path chosen depends on the amount of information available for the node and
hardware being replaced.

Reinstall Like New

This is the recommended path when no acceptable disk image or backup of system
function information is available.

Software will need to be installed on the replacement node like it is being installed
for the first time.

The general installation procedure is:
1. Clean (format) the repaired or replacement node.

2. Install the appropriate Windows operating system.
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Install the removable media containing the system planner file for this node.
Install the System Installation Program.

Start the System Installation Program.

AN

Following the instructions to load the:
a. Remaining Windows software.
b. Required third party software.

c.  Required 800xA software.

Refer to the System 800xA Automated Installation (3BSE034679%), the System
800xA Manual Installation (3BSE034678%) or the System 800xA Post Installation
(3BUA000156%) instruction for more detailed information.

Reinstall and Restore

This is the recommended path when:

*  No acceptable disk image exists but an acceptable backup of the system
function information resident to the failed node is available. Use the Backup
and Restore functions and/or the Import and Export functions to recover the
required function (IM, Batch etc.) information

- Or -

*  An acceptable disk image is available but the whole node needs to be replaced
and the replacement is not identical (hard disk drives are too small) to the failed
node. Use the disk imaging software to recover the required information from
the disk image.

Software will need to be installed on the repaired or replaced node like it is being
installed for the first time (Refer to Reinstall Like New on page 141).

Refer to the System 800xA Automated Installation (3BSE034679%), the System
800xA Manual Installation (3BSE034678%) or the System 800xA Post Installation
(3BUA000156%) instruction, for more detailed information.

For detailed information about Backup, Restore, Import, and Export function see
Section 6, Backup and Restore and Section 5, Import/Export.

Refer to the documentation provided with the disk imaging software for detailed
information about recovering data from a disk image.
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Recover Node
This is the recommended path when:
*  An acceptable disk image is available.
- and -

*  Anidentical node (hard disk drives may be larger) is used to replace the failed
node or only the hard disk drive needs to be replaced.

Use the following information and procedures to recover the node.

Disk Image

A node specific disk image should be taken after the 800xA system software has
been installed and the post installation setup procedures have been performed. The
creation of this image is discussed in the 800xA System Installation instruction.
Restoration of this disk image will recover all the information and software
components that were installed when the image was taken. These components are
the operating system, third party software, 800xA software, some function specific
information, etc.

Make a disk image of each node after the operating system and all third party
software is installed. For some applications, especially Information Management, it
is important to make a disk image of each disk that holds configuration and/or
application data. For example, the history database may be distributed on two or
more disks.

Make another, separate disk image of the node after all 800xA System software has
been installed and post installation setup procedures have been performed.

A FAT partition may be required if using certain disk imaging utilities; however,
most disk imaging software now supports FAT or NTES.

Combined Node Types

The following combinations of node type, connectivity software, and application
software are allowed in 800xA systems.

*  Aspect Server and Connectivity Server software.
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Aspect Server

*  Batch, Information Management, and Asset Optimization software.
*  Single node engineering system.

When replacing these nodes, restore the base node type first and then restore
connectivity and application specific information.

The Aspect Server is the central part of an 800xA system. Most 800xA systems are
engineered to contain redundant Aspect Servers because recovering fully from
losing the only Aspect Server in a single Aspect Server system is very complicated.
Optimally, the Aspect Server should not contain other Connectivity Server or
Application Server software with the exception of Central Licensing System,
Engineering Studio software and SMS and E-mail Messaging.

Use the following procedures to restore a failed redundant Aspect Server in 800xA

5.1.

To restore a redundant Aspect Server:

1. Repair or replace the failed node.

The following steps should be considered while replacing an Aspect Server node
in a system:

1) Delete the Event Storage provider that will be replaced.

2) Add a new Event Storage provider.

2.  Remove the failed node from the Domain:

a.

s

o 8 o

g

Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

Select the active domain.

Select Computers.

Right click the name of the failed node.

Select Delete on the pop-up menu.

Select Start > Programs > Administrative Tools > DNS.

Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.
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AN

h. Right click the failed node.
i.  Select Delete on the pop-up menu.

j-  Select DNS\primary_domain_controller_name\Reverse Lookup
Zones\1st_three_segments_of_IP_address_in_reverse_order.

k. Right click the failed node (listed as last segment of IP address).
1. Select Delete on the pop-up menu.

Physically disconnect the failed node from the network.

Restore a previously saved disk image.

Remove the node from the domain on the node itself.

Connect the node to the network and to the Windows domain.

ﬂ Verify the reverse and forward lookup zone for the DNS are correct. Also verify
that the DNS name and IP address of the node are still correct.

10.

11.

12.

Open the Configuration Wizard on the node being restored and select Connect
Node.

Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

Verify connection with the Service Connection Viewer (use the appropriate tray
icon).

Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.

When restoring a CLS Client node, it may be necessary to reselect the CLS
Server node using the License Status Viewer window.

When restoring the CLS Server software it may be required to reload the
800xA licenses:

a. Select Start > All Programs > ABB Industrial IT 800xA > System >
Licensing> License Entry.

b.  Select the file containing the licenses from the 'Load/Replace Licenses'
under the File menu.
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Connectivity Servers

The following types of Connectivity Servers are described in this replacement
procedure.

800xA for AC 800M.

«  FOUNDATION Fieldbus.

«  PROFIBUS and HART.

e 800xA for Advant Master.

*  800xA for Harmony.

¢ 800xA for AC 870P/Melody.
«  800xA for MOD 300.

e 800xA for SafeGuard.

800xA for AC 800M

800xA for AC 800M nodes can contain the following software:

e 800xA for AC 800M (on all AC 800M nodes).
. OPC Server for AC 800M.
o Control Builder M.

800xA for AC 800M

To restore individual 800xA 5.1 AC 800M Connectivity Server nodes:
1. Remove the failed node from the domain.

2. Disconnect the failed node from the network.

3. Restore the saved disk image to the replacement node.

If an error message is received while trying to login after the node is restored,
remove the node from the domain and then add it to the domain.

Verify the reverse and forward lookup zone for the DNS are running.

4. Remove the failed node from the Domain Server files:

a. Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

b. Select the active domain.
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A A

11.

12.

13.

14.

c. Select Computers.

d. Right click the name of the failed x.

e. Select Delete on the pop-up menu.

f.  Select Start > Programs > Administrative Tools > DNS.

g. Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

h. Right click the failed node.

i.  Select Delete on the pop-up menu.

j-  Select DNS\primary_domain_controller_name\Reverse Lookup

Zones\1st_three_segments_of_IP_address_in_reverse_order.
k. Right click the failed node which is listed as last segment of IP address.
1. Select Delete on the pop-up menu.
Connect the replacement node to the network.
Configure the name of the replacement node to be the same as the failed node.
Add the replacement node to the domain.
Confirm that the name and IP address are correct for the replacement node.

Verify that the System Software User Settings action (within the Configuration
Wizard) is correctly applied to the node.

Open the Configuration Wizard on the node being restored and select Connect
Node.

Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

Verify connection with the Service Connection Viewer (use the appropriate tray
icon).

Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.

Reset any objects, programs, etc. that were left in an undesirable state to a state
that will allow normal operation. For example, if the failure occurred while a
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backup was in process, the backup dialog should be closed. Refer to the
appropriate functional area documentation for more information.

15. Reboot the failed node to ensure that all processes startup properly. Refer to the
appropriate functional area documentation for more information.
OPC Server For AC 800M

If OPC Server for 800M software was installed on the repaired/replaced node:

1.
2.

Start the OPC Server Setup Wizard on the repaired/replaced node.

Configure the appropriate OPC Server for AC 800M settings (Service
Account) to the same values used on the repaired/replaced node.

Copy the backed up OPC Server configuration files (*.cfg file extension) to the
working directory (C:\ABB Industrial IT Data\Control IT Data\OPC Server for
AC 800M\ Files for example).

Copy the backed up system setup file (systemsetup.sys) to the working
directory (C:\ABB Industrial IT Data\Control IT Data\OPC Server for AC
800M for example).

Control Builder M

If Control Builder M software was installed on the failed node:

1.
2.

Start the Control Builder M Setup Wizard on the repaired/replaced node.

Configure the appropriate Control Builder M settings (Language) to the same
values used on the repaired/replaced node.

Copy the backed up system setup file (systemsetup.sys) to the working
directory. The working directory is usually C:\ABB Industrial IT
Data\Engineer IT Data\Control Builder M Professional.

FOUNDATION Fieldbus
Use the following procedures to restore FOUNDATION Fieldbus nodes.

Nonredundant Aspect Server Containing Local HSE Subnet Configuration. To
restore an individual nonredundant Aspect Server node:

1.

Remove the failed node from the domain.
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2.  Remove the failed node from the network.

3. Repair or replace the failed node.

4. Restore the saved disk to the replacement node.

In case of a completely new installed system node, which replaces the existing

@ node, the used Device Types must be re-installed via Device Library Wizard.
Refer to Device Management & Fieldbus on page 102 for details, how to re-
install Device Types on a system node.

If an error message is received while trying to login after the node is restored,
remove the node from the domain and then add it to the domain.

Verify the reverse and forward lookup zone for the DNS are running.

5. Remove the failed node from the Domain Server files:

a.

S

o 8 o

ar

k.

L.

Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

Select the active domain.

Select Computers.

Right click the name of the failed node.

Select Delete on the pop-up menu.

Select Start > Programs > Administrative Tools > DNS.

Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

Right click the failed node.
Select Delete on the pop-up menu.

Select DNS\primary_domain_controller_name\Reverse Lookup
Zones\1st_three_segments_of_IP_address_in_reverse_order.

Right click the failed node which is listed as last segment of IP address.

Select Delete on the pop-up menu.

6. Configure the node to have the same DNS name and IP address as the failed
node.
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7.

10.

11.

12.

13.

14.

15.

Connect the node to the network and to the Windows domain.

Verify the reverse and forward lookup zone for the DNS are correct. Also verify
that the DNS name and IP address of the node are still correct.

Verify that the System Software User Settings action (within the Configuration
Wizard) is correctly applied to the node.

Open the Configuration Wizard on the node being restored and select Connect
Node.

Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

Verify connection with the Service Connection Viewer (use the appropriate tray
icon).

Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.

Reset any objects, programs that were left in an undesirable state to a state that
will allow normal operation. Refer to the appropriate functional area
documentation for more information.

Stop all processes that were left incomplete by the failed server. Refer to the
appropriate functional area documentation for more information.

Restore application-specific information from the most recent node backup.

Nonredundant Aspect Server (HSE Subnet Configuration on different node).

Simply restoring a recent 800xA system backup can possibly overwrite actual HSE
Subnet configuration changes.

To determine whether the 800xA system backup contains the latest configuration
changes and restore a nonredundant Aspect Server:

L.

M

Open a Plant Explorer workplace on another node containing the HSE Subnet
configuration.

Select the Control Structure.

Select the HSE Subnet\FFUpload aspect.

Select the HSE Upload tab.

Check the time found in the Version Information\HSE Subnet field.
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6. Determine if any changes have been made from the time the backup was made.

7. If the 800xA system backup does contain the latest configuration changes,
proceed to the next step. If the 800xA system backup does not contain the latest
configuration changes, copy all files (*.pro, *.bak, *.log files and the
libraries.hwm file) from HSE Subnet configuration folder to a temporary folder
and then proceed to the next step.

8.  Remove the failed node from the domain.

9. Remove the failed node from the network.

10. Repair or replace the failed node.

11. Restore the saved disk to the replacement node.

In case of a completely new installed system node, which replaces the existing

@ node, the used Device Types must be re-installed via Device Library Wizard.
Refer to Device Management & Fieldbus on page 102 for details, how to re-
install Device Types on a system node.

If an error message is received while trying to login after the node is restored,
remove the node from the domain and then add it to the domain.

Verify the reverse and forward lookup zone for the DNS are running.

12. Remove the failed node from the Domain Server files:

a.

S

o 8 o

i

Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

Select the active domain.

Select Computers.

Right click the name of the failed node.

Select Delete on the pop-up menu.

Select Start > Programs > Administrative Tools > DNS.

Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

Right click the failed node.
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i.  Select Delete on the pop-up menu.

j-  Select DNS\primary_domain_controller_name\Reverse Lookup
Zones\1st_three_segments_of IP_address_in_reverse_order.

k. Right click the failed node which is listed as last segment of IP address.
1.  Select Delete on the pop-up menu.

13. Configure the node to have the same DNS name and IP address as the failed
node.

14. Connect the node to the network and to the Windows domain.

Verify the reverse and forward lookup zone for the DNS are correct. Also verify
that the DNS name and IP address of the node are still correct.

15. Verify that the System Software User Settings action (within the Configuration
Wizard) is correctly applied to the node.

16. Open the Configuration Wizard on the node being restored and select Connect
Node.

17. Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

18. Verify connection with the Service Connection Viewer (use the appropriate tray
icon).

19. Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.

20. Reset any objects, programs that were left in an undesirable state to a state that
will allow normal operation. Refer to the appropriate functional area
documentation for more information.

21. Stop all processes that were left incomplete by the failed server. Refer to the
appropriate functional area documentation for more information.

22. Restore the most recent 800xA system backup.

23. If the 800xA system backup did not contain the latest configuration changes,
copy all files (*.pro, *.bak, *.log files and the libraries.hwm file) from
temporary folder to the HSE Subnet configuration folder. Overwrite the
existing files.
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Redundant Aspect Server (or Any Node) Containing Local HSE Subnet
Configuration. The general restore procedure restores only 800xA System data of
the node (e.g. for a redundant aspect server). The HSE Subnet configuration data
must be restored manually.

1.

2
3.
4

Remove the failed node from the domain.

Remove the failed node from the network.

Repair or replace the failed node.

Restore the saved disk to the replacement node.

In case of a completely new installed system node, which replaces the existing
node, the used Device Types must be re-installed via Device Library Wizard.
Refer to Device Management & Fieldbus on page 102 for details, how to re-
install Device Types on a system node.

If an error message is received while trying to login after the node is restored,
remove the node from the domain and then add it to the domain.

Verify the reverse and forward lookup zone for the DNS are running.

Remove the failed node from the Domain Server files:

a.

S

o 8 o

ar

Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

Select the active domain.

Select Computers.

Right click the name of the failed node.

Select Delete on the pop-up menu.

Select Start > Programs > Administrative Tools > DNS.

Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

Right click the failed node.
Select Delete on the pop-up menu.

Select DNS\primary_domain_controller_name\Reverse Lookup
Zones\1st_three_segments_of_IP_address_in_reverse_order.

Right click the failed node which is listed as last segment of IP address.
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6.

7.

10.

11.

12.

13.

14.

15.

1. Select Delete on the pop-up menu.

Configure the node to have the same DNS name and IP address as the failed
node.

Connect the node to the network and to the Windows domain.

Verify the reverse and forward lookup zone for the DNS are correct. Also verify
that the DNS name and IP address of the node are still correct.

Verify that the System Software User Settings action (within the Configuration
Wizard) is correctly applied to the node.

Open the Configuration Wizard on the node being restored and select Connect
Node.

Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

Verify connection with the Service Connection Viewer (use the appropriate tray
icon).

Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.

Reset any objects, programs that were left in an undesirable state to a state that
will allow normal operation. Refer to the appropriate functional area
documentation for more information.

Stop all processes that were left incomplete by the failed server. Refer to the
appropriate functional area documentation for more information.

Restore HSE Subnet configuration manually from a recent 800xA system
backup:

a. Create and share the folder for the HSE Subnet configuration of Fieldbus
Builder FF according to the instructions in the 800xA - System, Post
Installation Setup instruction.

b. Select directory of the most recent 800xA system backup. The node and
path of the backup is shown on the Maintenance Structure\Backup
object\Storage tab in the Plant Explorer Workplace.

c.  Verify that the directory contains a folder with the name 1B0397BA-
124C-4A0A-B3FE-AEE68ESEDF96. The number is the GUID of the
FBBFF system extension and is identical for all system versions.
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d. Copy all *.pro files from that folder to the HSE Subnet configuration
folder.

e. Remove the ReadOnly attribute from all the *.pro files copied to the HSE
configuration folder.

Redundant Aspect Server (HSE Subnet Configuration on different node).
Refer to FOUNDATION Fieldbus on page 148.

FOUNDATION Fieldbus Connectivity Server (OPC Server FF), Redundant
FOUNDATION Fieldbus Connectivity Server (OPC Server FF), FOUNDATION
Fieldbus Connectivity Server as part of any combined server (CS + AS, CS +
AS + AO). To restore a FOUNDATION Fieldbus Connectivity Server:

1. Remove the failed node from the domain.
2.  Remove the failed node from the network.
3. Repair or replace the failed node.
4

Restore the saved disk to the replacement node.

In case of a completely new installed system node, which replaces the existing

@ node, the used Device Types must be re-installed via Device Library Wizard.
Refer to Device Management & Fieldbus on page 102 for details, how to re-
install Device Types on a system node.

If an error message is received while trying to login after the node is restored,
remove the node from the domain and then add it to the domain.

Verify the reverse and forward lookup zone for the DNS are running.

5. Remove the failed node from the Domain Server files:

a. Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

b. Select the active domain.

c. Select Computers.

3BSE046784-510 E 155



FOUNDATION Fieldbus Section 7 Single Node Replacement

10.

11.

12.

13.

d. Right click the name of the failed node.
e. Select Delete on the pop-up menu.
f.  Select Start > Programs > Administrative Tools > DNS.

g. Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

h. Right click the failed node.

i.  Select Delete on the pop-up menu.

j-  Select DNS\primary_domain_controller_name\Reverse Lookup

Zones\1st_three_segments_of IP_address_in_reverse_order.
k. Right click the failed node which is listed as last segment of IP address.
1.  Select Delete on the pop-up menu.

Configure the node to have the same DNS name and IP address as the failed
node.

Connect the node to the network and to the Windows domain.

Verify the reverse and forward lookup zone for the DNS are correct. Also verify
that the DNS name and IP address of the node are still correct.

Verify that the System Software User Settings action (within the Configuration
Wizard) is correctly applied to the node.

Open the Configuration Wizard on the node being restored and select Connect
Node.

Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

Verify connection with the Service Connection Viewer (use the appropriate tray
icon).
Check CPU load using the Task Manager utility. When the processor load

settles, the connection is finished.

Reset any objects, programs that were left in an undesirable state to a state that
will allow normal operation. Refer to the appropriate functional area
documentation for more information.
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14.

15.

16.

17.

Stop all processes that were left incomplete by the failed server. Refer to the
appropriate functional area documentation for more information.

Restore manually any system setting changes done after last node backup (e.g.
DCOM settings).

Restore user changed registry settings of OPC FF if applicable (as documented
in the 800xA - Device Management FOUNDATION Fieldbus, Configuration
instruction).

Download project data into the OPC Server FF node with Fieldbus Builder FF:

a. Open the HSE Subnet project that was affected by the repair/replacement
action.

b. Go into commissioning mode.
c. Select the OPC Server FF node.

d. Execute command Object\Download.

Client nodes (Fieldbus Builder FF engineering nodes). To restore a client node:

1.

2
3.
4

5.

Remove the failed node from the domain.
Remove the failed node from the network.
Repair or replace the failed node.

Restore the saved disk to the replacement node.

In case of a completely new installed system node, which replaces the existing
node, the used Device Types must be re-installed via Device Library Wizard.
Refer to Device Management & Fieldbus on page 102 for details, how to re-
install Device Types on a system node.

If an error message is received while trying to login after the node is restored,
remove the node from the domain and then add it to the domain.

Verify the reverse and forward lookup zone for the DNS are running.

Remove the failed node from the Domain Server files:

a. Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.
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10.

11.

12.

b. Select the active domain.

c. Select Computers.

d. Right click the name of the failed node.

e. Select Delete on the pop-up menu.

f.  Select Start > Programs > Administrative Tools > DNS.

g. Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

h. Right click the failed node.
i.  Select Delete on the pop-up menu.

j- Select DNS\primary_domain_controller_name\Reverse Lookup
Zones\1st_three_segments_of_IP_address_in_reverse_order.

k. Right click the failed node which is listed as last segment of IP address.
1. Select Delete on the pop-up menu.

Configure the node to have the same DNS name and IP address as the failed
node.

Connect the node to the network and to the Windows domain.

Verify the reverse and forward lookup zone for the DNS are correct. Also verify
that the DNS name and IP address of the node are still correct.

Verify that the System Software User Settings action (within the Configuration
Wizard) is correctly applied to the node.

Open the Configuration Wizard on the node being restored and select Connect
Node.

Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

Verify connection with the Service Connection Viewer (use the appropriate tray
icon).

Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.
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13.

14.

15.

Reset any objects, programs that were left in an undesirable state to a state that
will allow normal operation. Refer to the appropriate functional area
documentation for more information.

Stop all processes that were left incomplete by the failed server. Refer to the
appropriate functional area documentation for more information.

Manually restore any additional user specific FF configuration data exported
from Fieldbus Builder FF by copying these export files back to the desired
location.

Configuration data from Fieldbus Builder FF may be:

—  Partial exports of FBB FF configuration (Linking Device nodes, H1 Link
nodes, Function Block Application Diagrams etc.).

—  Parameter values of block instances, HSE Subnet objects, HSEHostCI860
objects.

HART and PROFIBUS
Use the following procedures to restore HART and PROFIBUS nodes.

Nonredundant Aspect Server Containing PROFIBUS/HART Connectivity
Server. To restore an individual nonredundant Aspect Server node:

1.

2
3.
4

5.

Remove the failed node from the domain.
Remove the failed node from the network.
Repair or replace the failed node.

Restore the saved disk to the replacement node.

In case of a completely new installed system node, which replaces the existing
node, the used Device Types must be re-installed via Device Library Wizard.
Refer to Device Management & Fieldbus on page 102 for details, how to re-
install Device Types on a system node.

If an error message is received while trying to login after the node is restored,
remove the node from the domain and then add it to the domain.

Verify the reverse and forward lookup zone for the DNS are running.

Remove the failed node from the Domain Server files:
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10.

11.

12.

a. Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

b.  Select the active domain.

c. Select Computers.

d. Right click the name of the failed node.

e. Select Delete on the pop-up menu.

f.  Select Start > Programs > Administrative Tools > DNS.

g. Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

h. Right click the failed node.

i.  Select Delete on the pop-up menu.

J- Select DNS\primary_domain_controller_name\Reverse Lookup

Zones\1st_three_segments_of_IP_address_in_reverse_order.
k. Right click the failed node which is listed as last segment of IP address.
1. Select Delete on the pop-up menu.

Configure the node to have the same DNS name and IP address as the failed
node.

Connect the node to the network and to the Windows domain.

Verify the reverse and forward lookup zone for the DNS are correct. Also verify
that the DNS name and IP address of the node are still correct.

Verify that the System Software User Settings action (within the Configuration
Wizard) is correctly applied to the node.

Open the Configuration Wizard on the node being restored and select Connect
Node.

Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

Verify connection with the Service Connection Viewer (use the appropriate tray
icon).

Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.
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13.

14.

15.

Reset any objects, programs that were left in an undesirable state to a state that
will allow normal operation. Refer to the appropriate functional area
documentation for more information.

Stop all processes that were left incomplete by the failed server. Refer to the
appropriate functional area documentation for more information.

Perform the following action as detailed in the Device Management
PROFIBUS & HART Configuration instruction:

—  Install all required PROFIBUS and HART Device Types be used in on the
system node. Refer to the System 800xA Configuration (3BDS011222%*)
manual for details.

Redundant Aspect Server Containing PROFIBUS/HART Connectivity Server.

To restore an individual redundant Aspect Server node:

1
2
3.
4

Remove the failed node from the domain.
Remove the failed node from the network.
Repair or replace the failed node.

Restore the saved disk to the replacement node.

In case of a completely new installed system node, which replaces the existing

@ node, the used Device Types must be re-installed via Device Library Wizard.
Refer to Device Management & Fieldbus on page 102 for details, how to re-
install Device Types on a system node.

If an error message is received while trying to login after the node is restored,
remove the node from the domain and then add it to the domain.

Verify the reverse and forward lookup zone for the DNS are running.

Remove the failed node from the Domain Server files:

a. Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

b. Select the active domain.
Select Computers.

d. Right click the name of the failed node.
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10.

11.

12.

13.

e. Select Delete on the pop-up menu.
f.  Select Start > Programs > Administrative Tools > DNS.

g. Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

h. Right click the failed node.
i.  Select Delete on the pop-up menu.

j-  Select DNS\primary_domain_controller_name\Reverse Lookup
Zones\1st_three_segments_of_IP_address_in_reverse_order.

k. Right click the failed node which is listed as last segment of IP address.
1.  Select Delete on the pop-up menu.

Configure the node to have the same DNS name and IP address as the failed
node.

Connect the node to the network and to the Windows domain.

Verify the reverse and forward lookup zone for the DNS are correct. Also verify
that the DNS name and IP address of the node are still correct.

Verify that the System Software User Settings action (within the Configuration
Wizard) is correctly applied to the node.

Open the Configuration Wizard on the node being restored and select Connect
Node.

Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

Verify connection with the Service Connection Viewer (use the appropriate tray
icon).

Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.

Reset any objects, programs that were left in an undesirable state to a state that
will allow normal operation. Refer to the appropriate functional area
documentation for more information.
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14.

15.

Stop all processes that were left incomplete by the failed server. Refer to the
appropriate functional area documentation for more information.

Perform the following action as detailed in the Device Management
PROFIBUS & HART Configuration instruction:

—  Install all required PROFIBUS and HART Device Types be used in on the
system node. Refer to the System 800xA Configuration (3BDS011222%*)
manual for details.

Redundant PROFIBUS/HART Connectivity Server. To restore a redundant
PROFIBUS/HART Connectivity Server:

1.

2
3.
4

Remove the failed node from the domain.
Remove the failed node from the network.
Repair or replace the failed node.

Restore the saved disk to the replacement node.

In case of a completely new installed system node, which replaces the existing
node, the used Device Types must be re-installed via Device Library Wizard.
Refer to Device Management & Fieldbus on page 102 for details, how to re-
install Device Types on a system node.

If an error message is received while trying to login after the node is restored,
remove the node from the domain and then add it to the domain.

Verify the reverse and forward lookup zone for the DNS are running.

Remove the failed node from the Domain Server files:

a. Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

b.  Select the active domain.

c. Select Computers.

d. Right click the name of the failed node.

e. Select Delete on the pop-up menu.

f.  Select Start > Programs > Administrative Tools > DNS.
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10.

11.

12.

13.

14.

15.

g. Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

h. Right click the failed node.
i.  Select Delete on the pop-up menu.

j- Select DNS\primary_domain_controller_name\Reverse Lookup
Zones\1st_three_segments_of_IP_address_in_reverse_order.

k. Right click the failed node which is listed as last segment of IP address.
1. Select Delete on the pop-up menu.

Configure the node to have the same DNS name and IP address as the failed
node.

Connect the node to the network and to the Windows domain.

Verify the reverse and forward lookup zone for the DNS are correct. Also verify
that the DNS name and IP address of the node are still correct.

Verify that the System Software User Settings action (within the Configuration
Wizard) is correctly applied to the node.

Open the Configuration Wizard on the node being restored and select Connect
Node.

Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

Verify connection with the Service Connection Viewer (use the appropriate tray
icon).

Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.

Reset any objects, programs that were left in an undesirable state to a state that
will allow normal operation. Refer to the appropriate functional area
documentation for more information.

Stop all processes that were left incomplete by the failed server. Refer to the
appropriate functional area documentation for more information.

Perform the following action as detailed in the Device Management
PROFIBUS & HART Configuration instruction:
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Install all required PROFIBUS and HART Device Types be used in on the
system node. Refer to the System 800xA Configuration (3BDS011222%*)
manual for details.

Client Nodes (Device Management PROFIBUS & HART Engineering Nodes).

To restore a client node:

1.

2
3.
4

Remove the failed node from the domain.

Remove the failed node from the network.

Repair or replace the failed node.

Restore the saved disk to the replacement node.

In case of a completely new installed system node, which replaces the existing
node, the used Device Types must be re-installed via Device Library Wizard.
Refer to Device Management & Fieldbus on page 102 for details, how to re-
install Device Types on a system node.

If an error message is received while trying to login after the node is restored,
remove the node from the domain and then add it to the domain.

Verify the reverse and forward lookup zone for the DNS are running.

Remove the failed node from the Domain Server files:

a.

=

© & o

i

Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

Select the active domain.

Select Computers.

Right click the name of the failed node.

Select Delete on the pop-up menu.

Select Start > Programs > Administrative Tools > DNS.

Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

Right click the failed node.
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10.

11.

12.

13.

14.

15.

i.  Select Delete on the pop-up menu.

j-  Select DNS\primary_domain_controller_name\Reverse Lookup
Zones\1st_three_segments_of IP_address_in_reverse_order.

k. Right click the failed node which is listed as last segment of IP address.
1.  Select Delete on the pop-up menu.

Configure the node to have the same DNS name and IP address as the failed
node.

Connect the node to the network and to the Windows domain.

Verify the reverse and forward lookup zone for the DNS are correct. Also verify
that the DNS name and IP address of the node are still correct.

Verify that the System Software User Settings action (within the Configuration
Wizard) is correctly applied to the node.

Open the Configuration Wizard on the node being restored and select Connect
Node.

Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

Verify connection with the Service Connection Viewer (use the appropriate tray
icon).

Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.

Reset any objects, programs that were left in an undesirable state to a state that
will allow normal operation. Refer to the appropriate functional area
documentation for more information.

Stop all processes that were left incomplete by the failed server. Refer to the
appropriate functional area documentation for more information.

Perform the following action as detailed in the Device Management
PROFIBUS & HART Configuration instruction:

—  Install all required PROFIBUS and HART Device Types be used in on the
system node. Refer to the System 800xA Configuration (3BDS011222%)
manual for details.
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800xA for Advant Master and Safeguard

To restore individual 800xA 5.1 800xA for Advant Master and Safeguard
Connectivity Server nodes:

ﬂ If the user wants to restore a image taken after last SW change on the
Connectivity Server then:

1. Disconnect the CS from MB300 network.

2. Move the RTA board from the failed node to the replacement node.

3. Restore the image on the replaced HW.

4. Start up the CS and Verify connection with the Service Connection Viewer (use
the appropriate tray icon).

5. Restart the node and connect the CS to MB300 network.

If Recover Node then:
1. Disconnect the failed node from both MB300 and IP networks.

2. Move the PU515A RTA board or a PU410 RTA unit from the failed node to the
replacement node. Note that the RTA configuration, dialogs, and status
indications do not differ or depend on the type of RTA hardware used, once the
installation is completed.

3. Restore the saved disk image to the replacement node.

ﬂ If no error message occurs then go directly to point 10.

ﬂ If an error message is received while trying to login after the node is restored,
remove the node from the domain and then add it to the domain again.

4. Remove the failed node from the Domain Server files:

a.

S

o 8 o

ar

Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

Select the active domain.

Select Computers.

Right click the name of the failed node.
Select Delete on the pop-up menu.

Select Start > Programs > Administrative Tools > DNS.
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e N %

11.

12.

13.

14.

15.

g. Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

h. Right click the failed node.

i.  Select Delete on the pop-up menu.

j- Select DNS\primary_domain_controller_name\Reverse Lookup

Zones\1st_three_segments_of_IP_address_in_reverse_order.
k. Right click the failed node which is listed as last segment of IP address.
1. Select Delete on the pop-up menu.

Connect the replacement node to the 800xA network but not the MB300
network.

Configure the name of the replacement node to be the same as the failed node.
Add the replacement node to the domain.
Confirm that the name and IP address are correct for the replacement node.

Verify that the System Software User Settings action (within the Configuration
Wizard) is correctly applied to the node.

Install MS hotfixes, 800xA servicepacks and rollups installed after recover
image were taken.

Open the Configuration Wizard on the node being restored and select Connect
Node.

Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

Verify connection with the Service Connection Viewer (use the appropriate tray
icon).

Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.

Reset any objects, programs, etc. that were left in an undesirable state to a state
that will allow normal operation. Refer to the appropriate functional area
documentation for more information.
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16.

17.

Stop all processes that were left incomplete by the failed node. Refer to the
appropriate functional area documentation for more information.

Copy the three backed up RTA Board configuration files (DATHR*.CD) to the
\..ProgramData\ABB\AC400Connect\AdvantBase\Data\RTA\Init\ folder.

ﬂ Before restoring these files, make sure the node being restored is running the
same character conversion language used by the node from which the files were
backed up.

ﬂ In the Windows Explorer, select Tools > Folder to view and access the
ProgramData folder. The Folder Options dialog appears. Select the View tab in
the Folder Options dialog. Click Show hidden files and folders option.

18.

19.

20.
21.

Restore MB300 network configuration settings by setting network, node,
PU410 redundant cable supervision, and clock master settings to those
recorded during backup.

For each Connectivity Server, compare the saved files,
AdvDsMasterAdapter.csv and AdvMbAeOPCServer.csv with the installed
version of the files in <installation path>\bin. If any customization was done
to the old files, update the installed version of the files with the corresponding
changes.

Restart the RTA Board in the RTA Board Control configuration dialog.

Connect the replacement node to the MB300 network.

800xA for Harmony

Use the following procedures to restore an 800xA for Harmony Configuration
Server, 800xA for Harmony Client, Primary or Secondary 800xA for Harmony
Connectivity Server nodes in 800xA 5.1 systems.

To restore an individual node:

1.

2
3.
4

Remove the failed node from the network.
Repair or replace the failed node.
Restore a previously saved disk image.

Remove the failed node from the Domain Server files:
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a. Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

b.  Select the active domain.

c. Select Computers.

d. Right click the name of the failed node.

e. Select Delete on the pop-up menu.

f.  Select Start > Programs > Administrative Tools > DNS.

g. Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

h. Right click the failed node.
i.  Select Delete on the pop-up menu.

J- Select DNS\primary_domain_controller_name\Reverse Lookup
Zones\1st_three_segments_of_IP_address_in_reverse_order.

k. Right click the failed node which is listed as last segment of IP address.
1. Select Delete on the pop-up menu.

5. Configure the node to have the same DNS name and IP address as the failed
node.

6. Connect the node to the network and to the Windows domain.

Verify the reverse and forward lookup zone for the DNS are correct. Also verify
that the DNS name and IP address of the node are still correct.

7. Open the Configuration Wizard on the node being restored and select Connect
Node.

8. Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

9.  Verify connection with Service Connection Viewer (use the appropriate tray
icon).

10. Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.
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ﬂ Do not use a SQL Server generated backup done through a SQL Maintenance
Plan or manually through the SQL Enterprise Manager for the restore operation.
The 800xA for Harmony backup/restore utility does not support this format.
Ensure that your Maintenance Procedures include a 800xA for Harmony backup
utility generated backup each and every time you do a backup of your Aspect
System. These two backups must be synchronized at the time of a restore
operation.

When restoring an 800xA for Harmony Configuration Server, the Harmony

@ configuration must be current (in sync) with the Aspect Server configuration
running. If the disk image being utilized to restore is current, step 11 can be
skipped. If the Harmony configuration is not in sync, the potential exists that
duplicate Harmony objects will be created in the Aspect Server.

11. If the node being restored is a Harmony Configuration Server node or a
combined Primary Harmony Connectivity/Configuration Server node:

Log into 800xA Install account or local administrator account.

b. Select Start > Programs > ABB Industrial IT 800xA > 800xA for OCS
Systems > Harmony > Configuration > Restore Configuration.

c. Click Connect.
d. Choose the backup file to restore.
e. Click Restore.

800xA for AC 870P/Melody

Use the following procedures to restore a 800xA 5.1 Melody Operator Workplace,
Connectivity Server, and Configuration Server node:

To restore an individual node:
1. Remove the failed node from the network.

2. Repair or replace the failed node.
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3. Restore a previously saved disk image.

ﬂ If the node being restored is the Melody Configuration Server node, stop the
Server Aspect Controller in the Service Structure to avoid automatic
synchronization of the obsolete Configuration Server database of the restored
disk image.

4. Remove the failed node from the Domain Server files:

a.

=

o 8 o

i

k.

L

Select Start > All Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

Select the active domain.

Select Computers.

Right click the name of the failed node.

Select Delete on the pop-up menu.

Select Start > Programs > Administrative Tools > DNS.

Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

Right click the failed node.
Select Delete on the pop-up menu.

Select DNS\primary_domain_controller_name\Reverse Lookup
Zones\1st_three_segments_of_IP_address_in_reverse_order.

Right click the failed node which is listed as last segment of IP address.

Select Delete on the pop-up menu.

5. Configure the node to have the same DNS name and IP address as the failed
node.

6. Connect the node to the network and to the Windows domain.

ﬂ Verify the reverse and forward lookup zone for the DNS are correct. Also verify
that the DNS name and IP address of the node are still correct.

7. Open the Configuration Wizard on the node being restored and select Connect
Node.

172

3BSE046784-510 E



Section 7 Single Node Replacement 800xA for MOD 300

8. Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

ﬂ The amount of time it takes to connect to the 800xA system depends on the type
of node (Melody Connectivity Server or Melody Operator Workplace) being
restored.

9.  Verify connection with Service Connection Viewer (use the appropriate tray
icon).

10. Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.

11. If the node being restored is the Melody Configuration Server node:
Log into the 800xAlnstaller account or an 800xA administrator account.

b.  Select Start > All Programs > ABB Industrial IT 800xA > 800xA for
AC 870P Melody > Configuration > Restore Configuration.

c. Click Connect.

d. Choose the backup file to restore.

e. Click Restore and follow the instructions of the Backup and Restore tool.
f.  After successful restoration of the Melody Configuration Server, reboot all

Melody Connectivity Servers one at a time.

g. Restart the Server Aspect Controller in the Service Structure.

800xA for MOD 300

Use the following procedures to restore a MOD 300 Connectivity Server node. The
MOD 300 function is only available for 800xA 5.1 systems.

The MOD 300 Connectivity Server does not have any configuration or process data
that must be restored.

If the MOD 300 Connectivity Server must be replaced:
1. Remove the failed node from the network.
2. Repair or replace the failed node.

3. Move the RTA board from the failed node to the replacement node.

ﬂ The RTA board may or may not function. Ensure that it is functional before
moving it to the replacement node. Replace the RTA board if it is not functional.
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4. Restore a previously saved disk image.
5. Remove the failed node from the Domain Server files:

a. Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

b. Select the active domain.

c. Select Computers.

d. Right click the name of the failed node.

e. Select Delete on the pop-up menu.

f.  Select Start > Programs > Administrative Tools > DNS.

g. Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

h. Right click the failed node.
i.  Select Delete on the pop-up menu.

j-  Select DNS\primary_domain_controller_name\Reverse Lookup
Zones\1st_three_segments_of IP_address_in_reverse_order.

k. Right click the failed node which is listed as last segment of IP address.
I.  Select Delete on the pop-up menu.

6. Configure the node to have the same DNS name and IP address as the failed
node.
7.  Connect the node to the network and to the Windows domain.
ﬂ Verify the reverse and forward lookup zone for the DNS are correct. Also verify
that the DNS name and IP address of the node are still correct.

8. Open the Configuration Wizard on the node being restored and select Connect
Node.

9. Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

10. Verify connection with the Service Connection Viewer (use the appropriate tray
icon).
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11.

12.

Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.

Confirm settings for time synchronization, communications settings for DCN
address and omf shared memory, redundant Connectivity Server name, and
Hyper Terminal installation are correct according to the 800xA System Post
Installation Setup instruction.

ﬂ Refer to the 800xA for MOD 300 5.1 Configuration (3BUR002417%*) instruction,
Appendix F, for more information on customized data settings.

Application

Servers and Software

The following types of Application Servers and software are detailed in this
replacement procedure.

Central Licensing System.

Engineering Studio.

PC, Network, and Software Monitoring.
Batch Management.

Information Management.

Asset Optimization.

SMS and E-mail Messaging

Diagnostic Collection Tool.

Common Application Software

All 800xA System nodes (except the domain server) contain Central Licensing
System (CLS) client and Engineering Studio.

Diagnostic Collection Tool

Diagnostic Collection Tool software must be installed on all nodes including
Domain Controllers. Just restore these nodes based in the node type and the DCT
software will automatically be restored.
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Central Licensing System

The Primary Aspect Server is the license server and all other nodes contain CLS
client software. Just restore these other nodes based on the type of node it is and the
CLS client software will automatically be restored. When restoring a CLS Client
node, it may be necessary to reselect the CLS Server node using the License Status
Viewer window.

Engineering Studio

Engineering Studio software is loaded during the system installation process. There
are no designated Engineering Studio nodes. Therefore, just restore the node based
on the type of node it is and the Engineering Studio software will automatically be

restored. Refer to the appropriate instruction for more detailed information.

PC, Network and Software Monitoring
There are two ways that PNSM can be used and this determines where it is installed.

There is the full version of PNSM that is licensed and PNSM Basic Computer
Monitoring that is unlicensed but has limited functionality. Both of these used the
same PNSM installation. There is a separate server and client and a client only
installation.

The PNSM Basic Computer Monitoring Server installation can be installed on any
800xA node including Aspect Servers.

The full version of PNSM can installed on any Connectivity Server subject to
loading restrictions. Frequently is it installed on its own Connectivity Server or on a
Connectivity Server together with Asset Optimization.

Irrespective of the use of PNSM and where the PNSM Server is installed use the
following procedures to restore a failed node that contained PC, Network and
Software Monitoring (PNSM) client or server node in 800xA 5.1 systems.

To restore a PNSM node:

1. Remove the failed node from the network.
2. Repair or replace the failed node.

3. Restore a previously saved disk image.

4

Remove the failed node from the Domain Server files:
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10.

a. Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

b.  Select the active domain.

c. Select Computers.

d. Right click the name of the failed node.

e. Select Delete on the pop-up menu.

f.  Select Start > Programs > Administrative Tools > DNS.

g. Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

h. Right click the failed node.

i.  Select Delete on the pop-up menu.

J- Select DNS\primary_domain_controller_name\Reverse Lookup

Zones\1st_three_segments_of_IP_address_in_reverse_order.
k. Right click the failed node which is listed as last segment of IP address.
1. Select Delete on the pop-up menu.

Configure the node to have the same DNS name and IP address as the failed
node.

Connect the node to the network and to the Windows domain.

Verify the reverse and forward lookup zone for the DNS are correct. Also verify
that the DNS name and IP address of the node are still correct.

Open the Configuration Wizard on the node being restored and select Connect
Node.

Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

Verify connection with the Service Connection Viewer (use the appropriate tray
icon).

Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.
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Batch Management

11. When restoring a PNSM Connectivity Server node:

Restore any user defined assemblies, scripts, and resource files.

Restore and reload any Management Information Base files (MIBs) that
were not part of the standard MIBs loaded with the software.

Restart the node.

Use the following procedures to restore a failed Batch Management client or server

node.

Clients and Redundant Servers (800xA 5.1)

To restore an individual Batch client or redundant server node:

1. Remove the failed node (or node containing failed operating system hard disk
drive or corrupted operating system) from the domain.

2. Disconnect the failed node from the network.

3. Restore the saved disk image to the replacement node.

remove the node from the domain and then add it to the domain.

ﬂ If an error message is received while trying to login after the node is restored,

ﬂ Verify the reverse and forward lookup zone for the DNS are running.

4. Remove the failed node from the Domain Server files:

a.

s
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g

Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

Select the active domain.

Select Computers.

Right click the name of the failed node.
Select Delete on the pop-up menu.

Select Start > Programs > Administrative Tools > DNS.
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e

11.

12.

13.

14.
15.

g. Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

h.  Right click the failed node.

i.  Select Delete on the pop-up menu.

j-  Select DNS\primary_domain_controller_name\Reverse Lookup

Zones\1st_three_segments_of_IP_address_in_reverse_order.
k. Right click the failed node which is listed as last segment of IP address.
1. Select Delete on the pop-up menu.
Connect the replacement node to the network.
Configure the name of the replacement node to be the same as the failed node.
Add the replacement node to the domain.
Confirm that the name and IP address are correct for the replacement node.

Verify that the System Software User Settings action (within the Configuration
Wizard) is correctly applied to the node.

Open the Configuration Wizard on the node being restored and select Connect
Node.

Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

Verify connection with the Service Connection Viewer (use the appropriate tray
icon).

Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.

Restart the secondary Batch Server.

Restart the primary Batch Server.

All necessary information will be deployed to the new node and all services
configured for the failed node are started on the replacement node.
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Nonredundant Servers

Nonredundant servers (and single node system) can be restored however, some
information will be lost. How much data is lost depends on when the node was last
backed up. In some cases, failure of a nonredundant server node will leave parts of
the system in an incomplete state. Some manual actions may be required to clean up
the system before it will function correctly.

ﬂ Any running batch control recipes will be lost when the node fails. Be sure to
restore the batch (SQL Server) database along with the rest of the batch
information.

To restore an individual Batch nonredundant server node:
1. Remove the failed node from the domain.
2. Disconnect the failed node from the network.

3. Restore the saved disk image to the replacement node.

ﬂ If an error message is received while trying to login after the node is restored,
remove the node from the domain and then add it to the domain.

ﬂ Verify the reverse and forward lookup zone for the DNS are running.

4. Remove the failed node from the Domain Server files:

a. Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

b. Select the active domain.

c. Select Computers.

d. Right click the name of the failed node.

e. Select Delete on the pop-up menu.

f.  Select Start > Programs > Administrative Tools > DNS.

g. Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

h. Right click the failed node.

i.  Select Delete on the pop-up menu.
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A

11.

12.

13.

14.

15.

16.

j-  Select DNS\primary_domain_controller_name\Reverse Lookup

Zones\1st_three_segments_of_IP_address_in_reverse_order.
k. Right click the failed node which is listed as last segment of IP address.
I.  Select Delete on the pop-up menu.
Connect the replacement node to the network.
Configure the name of the replacement node to be the same as the failed node.
Add the replacement node to the domain.
Confirm that the name and IP address are correct for the replacement node.

Verify that the System Software User Settings action (within the Configuration
Wizard) is correctly applied to the node.

Open the Configuration Wizard on the node being restored and select Connect
Node.

Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

Verify connection with the Service Connection Viewer (use the appropriate tray
icon).

Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.

Reset any objects, programs, etc. that were left in an undesirable state to a state
that will allow normal operation. Refer to the appropriate functional area
documentation for more information.

Stop all processes that were left incomplete by the failed server. Refer to the
appropriate functional area documentation for more information.

Restore application-specific information from the most recent node backup.

The server is now ready for normal operation.

Information Management Server

Use the following procedures to restore a failed Information Management server
node.
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To restore individual 800xA 5.1 Information Management nodes:

1. Remove the failed node from the domain.

2. Disconnect the failed node from the network.

3. Restore the saved disk image to the replacement node.

remove the node from the domain and then add it to the domain.

ﬂ If an error message is received while trying to login after the node is restored,

ﬂ Verify the reverse and forward lookup zone for the DNS are running.

4. Remove the failed node from the Domain Server files:

a.
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i

Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

Select the active domain.

Select Computers.

Right click the name of the failed node.

Select Delete on the pop-up menu.

Select Start > Programs > Administrative Tools > DNS.

Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

Right click the failed node.
Select Delete on the pop-up menu.

Select DNS\primary_domain_controller_name\Reverse Lookup
Zones\1st_three_segments_of_IP_address_in_reverse_order.

Right click the failed node which is listed as last segment of IP address.

Select Delete on the pop-up menu.

5. Connect the replacement node to the network.
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10.

11.

12.
13.
14.

15.

16.

17.

18.
19.

20.

Configure the name of the replacement node to be the same as the failed node.

Open the services control panel and change the "ABB Process Administration
Service" to Manual.

Add the node to the domain. This will require a reboot.
Confirm that the name and IP address are correct for the replacement node.

Verify that the System Software User Settings action (within the Configuration
Wizard) is correctly applied to the node.

Run the pasPwdAdmin tool to reset the IM User Settings for the domain
service account.

It is assumed at this step, a History Restore will be performed on the node.

Reboot.
Use the history Oracle Instance wizard to drop the oracle configuration.

Open the Configuration Wizard on the node being restored and select Connect
Node.

Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

Verify connection with the Service Connection Viewer (use the appropriate tray
icon).

Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.

Reboot the node.

Reset any objects, programs, etc. that were left in an undesirable state to a state
that will allow normal operation. Stop the Inform IT history Service for this
IM. In particular, review the SoftPoints, Scheduler, Calculations located in the
Node Structure to determine if all objects and properties are operating as
expected and set to the proper state. Refer to the appropriate functional area
documentation for more information.

Select Start > All Programs > ABB Industrial IT 800xA > Information
Management > Configuration Assistant.
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21.
22.

23.
24.

25.
26.
27.
28.
29.

Click Run Selected Configuration Tool.

There are two valid recover paths for single node replacement. In the first path,
a valid IM backup (as described in Information Management on page 90) exists
for the IM node.

Based on the restore path available, create an oracle instance.

a. If a valid IM backup will be restored, use the configuration wizard to
create a database for restore of a History configuration. Select Small,
Medium or Large for the database size. If the system had a large
IMMSGLOG, select Large. Refer to the information used during initial
installation to replicate database sizes, locations, memory space
allocations, etc.

b. If no valid IM backup exists, create the database for the configuration
created or for the configuration which has to be created. After the database
is created, go to Step 24.

Refer the restore section of Information Management on page 120.

Enable PAS (enable the service, start PAS). Follow the IM post configuration
steps if not completed.

Start the program:

Start > Programs > ABB Industrial IT 800xA > Information Mgmt >
Configuration Assistant.

Review and verify the steps in the Configuration Assistant.
Select the incomplete steps in the Configuration Assistant.
Click Run Selected Configuration Tool to complete the steps.
Close the dialog.

Verify whether the system is running.

a. If the system was completely restored from a backup, numeric and
message collection and archive should continue from the previous point.

b. If restore without backup, for the first time the system runs all the logs
which should be recreated if enough disk space and oracle space was
allocated. The time it takes to recreate everything will depend on the size
of the configuration. When the logs are created, run hsDBMaint —stagger
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(refer IM manuals). Once stagger is complete, run PASGUI -> Restart
ALL and then activate all the logs.

As a final step, review all the node functionality to make sure the configuration.

Asset Optimization

Use the following procedures to restore a failed Asset Optimization client or server
node in 800xA 5.1 systems.

Backup Service Providers Configuration

Before the Asset Optimization node is removed from the 800xA System, be sure to
export the service groups and the service providers configured to run on the node.
If an Asset Optimization node is removed from an 800xA system, all the service
providers assigned to such node will be automatically removed from the Service
Structure.

Asset Optimization Services are:
*  AssetMonitoring Service
*  AOAssetTree Service

To export the Service Providers running in a node:

1. Open Plant Explorer workplace.

2. Navigate to the Service Structure.

3. Identify all the service providers running in the node to be removed.
4

Drag and drop the identified service providers objects in the Import/Export
tool.

5. Save the resulting AFW file with the other files in your backup media.

Restore Procedure

To restore an Asset Optimization node:

1. Remove the failed node from the network.
2. Repair or replace the failed node.

3. Restore a previously saved disk image.
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4. Remove the failed node from the Domain Server files:

a. Select Start > Programs > Administrative Tools > Active Directory
Users and Computers on the primary (or only) Domain Server node.

b. Select the active domain.

c. Select Computers.

d. Right click the name of the failed node.

e. Select Delete on the pop-up menu.

f.  Select Start > Programs > Administrative Tools > DNS.

g. Select DNS\primary_domain_controller_name\Forward Lookup
Zones\domain_name.

h. Right click the failed node.
i.  Select Delete on the pop-up menu.

j-  Select DNS\primary_domain_controller_name\Reverse Lookup
Zones\1st_three_segments_of_IP_address_in_reverse_order.

k. Right click the failed node which is listed as last segment of IP address.
1.  Select Delete on the pop-up menu.

5. Configure the node to have the same DNS name and IP address as the failed
node.

6. Connect the node to the network and to the Windows domain.

ﬂ Verify the reverse and forward lookup zone for the DNS are correct. Also verify
that the DNS name and IP address of the node are still correct.

7.  Open the Configuration Wizard on the node being restored and select Connect
Node.

8.  Select the appropriate Aspect Server. This will connect the restored node to the
800xA system.

ﬂ The amount of time it takes to connect to the 800xA system depends on the type
of node (Aspect Server, Connectivity Server or client) being restored.
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9.  Verify connection with Service Connection Viewer (use the appropriate tray
icon).

10. Check CPU load using the Task Manager utility. When the processor load
settles, the connection is finished.

11. Import service provider configuration information from the AFW file using the
Import/Export tool (select Import All from the Action menu).

12. Restore Asset Optimization backup information. Refer to the Backup and
Restore information in the 800xA System Administration and Security
instruction for details.

SMS and E-mail Messaging
SMS and E-mail Messaging software is found on the primary Aspect Server.

Before the primary Aspect Server node is removed from the 800xA System, be sure
to export the Messenger service group and service provider configured to run on the
node.

Upon restoring the primary Aspect Server, import the saved Messenger service
group and service provider.
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Introduction
This section provides guidelines, reference, and troubleshooting information related
to configuring and maintaining Information Management software.

Some procedures in this section require editing the Windows Registry on the
Information Management server. It is recommended that you make a backup of
the node before making any changes to the registry.

Common Issues

Common issues describes a list of items that to check to help solve problems.
Table 3 provides common issues that may occur and a where to go column with
possible resolutions.

Table 3. Common Issues

Area Issue Where To Go

Operating | For general Oracle problems, check the DNS Server. | See Oracle Fails to Start on page

System & 237.

Third-

party

Software

800xA Make sure all required software and extensions are | See Checking What Other

System |loaded to support implemented system functionality, |Software is Installed on page
particularly connectivity and controllers. Not having | 195.

the required software on all nodes of your system
may lead to such problems as not being able to
access certain objects.
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Table 3. Common Issues (Continued)

Area Issue Where To Go
Cannot access history data. See What To Look For When
Logs Do Not Collect Data on
page 228.
Check the PAS Service Account. If this account is not | See PAS Service Account on
configured correctly, it may cause many problems, page 201.
including failure to start history.
Insufficient Oracle tablespaces may cause the See Insufficient Oracle
following problems: Tablespace on page 231 and
e can't create OPC message log. Insufficient Temp Tablespace
, and Rollback Segments on page
. e can't restore database.
History i 233.
e can’'t consolidate OPC or PDL messages or PDL
data.
History fails to start. See Cannot Start History on
page 230.
Cannot create history database (System Version 4.0 |See Cannot Create Oracle
or higher). Database Instance on page 230.
When working with history, make sure the user See Cannot Access History
(currently logged in as) belongs to the HistoryAdmin |Database via SQL on page 233.
and ORA_DBA groups.
Make sure ORACLE_SID is included as part of the
local user’s environment settings.
Cannot access Information Manager history aspects | See Cannot View Report from IM
like the log status page or the tabs in the template. report logs on page 231.
Open ODA on client nodes cannot access ODA tables on | Check whether or not the ODA
Data server. client is installed, and check that
Access the configuration references the

server’s IP address.
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Common Issues

Table 3. Common Issues (Continued)

Area Issue Where To Go
Cannot log in to DataDirect (server not found error Use the ADSS Config tool in the
message). Windows Control Panel to check
whether or not COM data
provider is started, also check
ABB Data Service Supervision in
Desktop the Windows Services utility.
Tools
Cannot retrieve messages or PDL data. Use the ADSS Config tool in the
Windows Control Panel to check
the ADO data provider.
Some icons not available in DataDirect. Check the View tab in the
Options dialog.
Reports | When Excel (DataDirect) reports don’t run: See:
e Make sure the DataDirect add-ins are added for |  DataDirect Add-in Not
the 800xAService Account Installed for 800xAService
e Check the DataServerLogin parameter Account on page 243
When reports take too long to complete, or seemto |*  Reading DataDirect (Excel)
hang, check the maximum time and timeout settings Reports from a FileViewer
on the report action. Aspect on page 243
e  Fixing Large Reports (Long
Execution Time) on page
242
Install/ Following upgrade or re-installation of Information See the System 800xA Manual
Upgrade |Management software, the Windows Installer is Installation (3BSE0346787),

launched when you attempt to use an application.
The installer attempts to repair an Information
Management software installation and does not allow
any other applications to run.

System 800xA Post Installation
(3BUA000156%), and the System
800xA Upgrade (3BSE036342%)
instructions.
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Getting Information for Support

This section describes the type of information that will help ABB technical support
personnel diagnose and solve problems related to Information Management
software, and provides guidelines on how to gather this information.

Table 4. Information for Diagnosing Problems

What information to gather

How to gather

Version of software including
patches

Version Information on page 193

Circumstances under which
the problem occurs

Whether it is spurious or
consistent

The components and/or
applications that are affected

Various sources, including:

Windows Event Viewer on page 193

Events Related 800xA Services on page 193
System Status on page 194

Performance Counters on page 208

SQL Queries on page 220

Debug Files and Trace Monitors for Display and DataDirect on
page 223

Log files

Diagnostic Log Files on page 204

Windows and 800xA services,
including PAS Service Account

Services and Processes Related to Information Management
on page 196
PAS Service Account on page 201

Oracle tablespace

Insufficient Oracle Tablespace on page 231

Insufficient Temp Tablespace and Rollback Segments on page
233

Screen shots if possible

Windows Print Screen or equivalent utility

Installed software and system
extensions.

Checking What Other Software is Installed on page 195
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Version Information

Get the version information for your Information Management installation from the
Version Information tool by selecting the following:

Start > Programs > ABBIndustrial IT 800xA > Information
Management > Version Info

Windows Event Viewer

Check the application log of the Windows event viewer for messages related to
Information Management services or 800xA users. Figure 63. You may have to save
the log to a file and send it to the supportline. Check Microsoft documentation for
the procedure to save to a file.

E Computer Management : = Ellil
=) Fle pction View Window Help | =12 x|
s a@EE B @
@ Computer Management (Local) & | | Type | Date | Time: | Source | Cateqgor | Event | User | CDI:I
5] ﬁs System Tools € Errar 12/31/2004 4056 PM  ABE Data Service Supervision  Mone z B00xAService  EM:
= £] Event viewer (D Information  12/31/2004  340:56FM  ADS hone 00 WA ER
Application Errar 123102004  3:40:56PM ADS Hare 100 HjA EM_
; eErmr 12/31/2004  3:40:56 PM ADS Mone 100 MiA Enp
B Sﬁared Folders eErmr 121312004  340:56 PM ADS Mone 100 MiA ERy
E Local Users and Groups @Information 12131j2004 ADS Hone 100 HiA EN
-- Performance Logs and Al JegError 2 & lone Z
f Device Manager @Infurmation 125:46 PM  ABE Data Service Supervision Mone a xAService  EMN
= @ Storage QErrur 12/31j2004  3:25:46 PM  ABE Data Service Supervision MNone 2 B00xAService  EM
- Remaovable Starage @Information 12/31/2004 32546 FPM ADS Mone 100 M EMe
o[B8 Disk Defragmenter || €3 Error 12/31j2004  3:25:46FM  ADS Hone 100 HfA EN
Disk Management eErmr 123102004 HZS4EPM ADS MHong 100 Mfa En
[1‘-‘%@ Services and Applicatio'ns 'ﬂ QErmr 121312004 32546 PM ADS Hong 100 M/A . ENe Y

Figure 63. Example, Windows Event Viewer Application Log

Events Related 800xA Services

Events related to 800xA services are collected by an alarm/event list aspect on the
Services object in the Service structure, Figure 64. You may create a more refined
list by adding an aspect to a specific service, for example Industrial IT Archive
Service, or to a specific Service Group or Service Provider object. Set the
Configuration Name to Services: Service Event List Configuration and set the
filter for Object and descendents.
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A8l

Plant Explorer Workplace

IRep\ace |ﬁ‘ L7 |)¥l‘|%|J|

P ||@|I (Enter search name} j”No Filter
I‘i‘:g Service Structure j Aspects of 'Services | Madfied [ Desc... [ Inhericed [ Categary name
E‘"S oy = MName 3/3/2005 5:45:36... The... False Mame
f larm & Event, Service Obiject Factory 3/3/2005 5:45:36... False Object Factory
ja Alarm Logger, Service [E=]3ervice Event List 3312005 2:56:1... This... False Alarm and Even...
f AspectDirectory, Service Service Event List Configuration 10/19/2003 5:57:..,, The.. False Alarm and Even,..
@f" BackupService, Service Service Event List Configuration O... 10/19/2003 10:1..., The.. False Alarm and Even...
ﬁ Basic Hiskory, Service % Service Structure Ff4/2005 9:07:35... [Serv... False Service Structure
& Batch Service, Service |8 System Stabus Viewer f22/2000 10:47:...  This... False Systern Stabus ...
&ﬁ Calculation Server, Service HO 9 = |Sarvlces:Eervlce Ewent List ;I % §os - =
f Cross referencing server, Ser
‘f" External Alarm, Service ‘ xRV N ‘ BN | Ly | + S+ C¢HAe
File: Set Distribution, Service —
A . Event SourceName MessageDescription NodeName

‘f" Industrial IT Archive, Service

f Inform IT History, Service

f" Lock Server, Service

4" MasterBus 300 RTA Manager:
‘f MasterBus ModeStatus Server
y MasterBus TTD Configuration
f MasterBus TTD Data Server, S
‘f" OpcDa_Connector, Servics

. Aren Piabs Accees Caviina

Figure 64. Alarm/Events List Aspect for 800xA Services

System Status

Check the System Status Viewers in the Plant Explorer on the Node Administration
and Service structures, Figure 6. Add Alarm and Event Aspects at the Node and
Service Group level for system messages (Events Related 800xA Services on page
193).
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Checking What Other Software is Installed

m All Nodes : System Status Yiewer

=10l x|

JJ EE - |AII Modes: System Status Yiewer ;I =] @ R |
&= 0 EG IE Mode Administration Structure j 5 7
Objects Statu: Time Description Details | Propagatio S;I
-4 ROC132, Node
B nlarm Logger_ROC132, Service Provider T X Yes J
g Basic History_ROC132, Service Provider T X Yes
g Event Collector_ROC132, Service Provider T Service state: 5. X Yes
g External Alarm_ROC132, Service Provider T ... |Service state: St.. X Yes
% OPCDA_Provider_ROCI132, Service Providet (1) |3/2/2005 4:39:2... |Service state: In..| X  |Yes
4 ROC133, Node [
{4 ROC179, Node [
4 ROC1ED, Node [

4«

-

ﬁ TAR105 Systen Plant Explorer Workplace l jﬂ oy ]
JE” jel ||E“ (Enter search name) j“mn Filter =5 ||Raplaca ;” ﬁ| o i |’§\‘ @m
I"Eg Service Struckure j Aspects of ‘Services' | Modified I Desc... | Inherited | Categary name I
5 G Services 3 Name 332005 5:45:36... The ... False Mame
- f Alarm & Event, Service Object Fackory 332005 5:45:36. . False Object Factory
el 09 Alart Logger, Service [E=]Service Event List False: Alarm and Even...
B f fAspectDiractory, Service Service Event List Configuration False Alarm and Even...
- f BackupService, Service Service Event List Configuration O, False Alarm and Even...
= f Basic Histary, Service . Service Structure False Service Structure
j Batch Service, Service
[ @9 Calculation Server, Service
(=R f Cross referencing server, S
) 09 External Alarm, Service Q =] -ISerchs:Systam Status Viewsr = % g - -
- @e File Set. Distribution, Servic
g Industrial T awchive, servief 1 41 = [ 5 €9 [T service structure % %
- f Inform IT Hiskory, Service
B g& Lack Server, Service Dbjects Statu: Time Description Details | Propagatio| Suppress
@9 MasterBus 300 RTA Manage) =i Services
g MasterBus NodeStatus Serv . Blarm & Event, Servit [
# MasterBus TTD Configuratio # #larm Logger, Servic
g MasterBus TTD Diata Server ' AspectDirectary, Ser| [
- OpcDA_Connector, Service # BackupService, Servi
- f Open_Data_sccess, Servics .9& Basic Histary, Service [
g Property Transfer, Service ﬁ Calculation Server, 5 L
- Scheduler, Service & Cross referencing set [
f Server Aspect Controller, 5g &ﬁ External Alarm, Servi L]
[ Soft alarms, Servics # File Set Distribution,
@e Softpoint Server, Service f’ Industrial IT Archive, [
[ System Message, Service # Tnform IT History, Se
- f Time, Service QS" Lack Server, Service| [LJ
ﬁ Open_Data_pAccess, [
‘f Scheduler, Service L
é Soft Alarms, Service | [

Figure 65. Status Viewer Example

Checking What Other Software is Installed

The information icon on the Plant Explorer tool bar displays a window that lists the
800xA software products installed on the system. Not having the required software
on all nodes of your system may lead to such problems as not being able to access
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certain objects. For example, if the AC800 Connect product is not installed on the
Information Management server, you will not have access to AC800 objects on that

node. If Engineering Studio is installed in the system, the engineering studio client

must be installed on the Information Management server.

Services and Processes Related to Information Management

This section describes Windows and 800xA system services related to Information

Management as follows:

*  Windows Services on page 196 - accessible in Windows Services utility

*  800xA Service Groups and Service Providers on page 198 - accessible via

Plant Explorer Service structure

*  Processes on page 200 - accessible via Windows Task Manager

Windows Services

Access to the Windows services is via the Services utility under Administrative
Tools in the Windows Control Panel. Check whether the service is running, and
verify the start-up mode and log-in are set correctly, Table 5.

Table 5. Windows Services

Service

Description

Start-up Mode and
Log-in

ABB Process
Administration

Starts all non-AFW processes including Display Data
Server, OMF, and parts of history. Processes under
control of ABB Process Administration Service (PAS)
may be started and stopped individually or as a group
by the PAS dialog.

AUTOMATIC - starts with
Windows start-up

Runs as 800xa Service
account

ABB Data Supports data access for the Information MANUAL - is started by
Supervision Management Desktop Tools: Desktop Trends, Display | PAS
History Starts Information Management History. MANUAL - is started by
Services PAS
Runs as 800xAService
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Table 5. Windows Services

Service Description Start-u&gl\’ll_ci):e and
IS Admin Required for viewing reports stored in Information AUTOMATIC - starts with
Management report logs. Windows start-up
Runs as local system
OMF/OMO Used by History internally and for numeric log MANUAL - is started by
consolidation. PAS
Runs as 800xa Service
Oracle Oracle 11 services: NOTE: AUTOMATIC - start
Services For 64-bit: with Windows start-up
Oracle ADVA VSS Writer Service Manual
OracleJobSchedulerADVA Disabled
OracleMTSRecoveryService Automatic
OracleOraDB11g_ADVA64CIrAgent Manual
OracleOraDB11g_ADVAG4TNSListener Automatic
OracleOraDB11g_ADVACMAdmin Manual
OracleOraDB11g_ADVACMan Manual
OracleServiceADVA Automatic
For 32-bit:
Oracle ADVA VSS Writer Service Manual
OracleJobSchedulerADVA Disabled
OracleMTSRecoveryService Automatic
OracleOraDB11g_ADVACIrAgent Manual
OracleOraDB11g_ADVATNSListener Automatic
OracleServiceADVA Automatic
Run as local system
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Table 5. Windows Services

Service

Description

Start-up Mode and
Log-in

ODA Services

ABB_ODA Manual

ABB_ODA_AGENT Automatic

Runs as 800xa Service
account and is managed
by PAS.

Runs as local system

800xA Service Groups and Service Providers

The following Information Management functions are managed by service
providers in the 800xA system:

Calculations

Archive - Industrial IT Archive (under PAS supervision)
History - Inform IT History, started by PAS if not running and stays running.
Can be stopped or restarted by the user if necessary.

Application Scheduler
Softpoint Server

The Service Provider represents the service running on a specific node. Service
Providers are located under their respective service categories in the Service
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structure, Figure 66.

ﬁIRDEBS System 12-dec-04 version of PPA4.0 // Plant Explorer Workplace : ;|g|5|
J | P! ||E|I {Enter search name) j”No Filter j & ||Replace ;” ﬁ| o i X am
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E--Q Services - Alarm Expression 9f20/2002 6:20:2... Speci... True Alarm Expression
f AdvMbStatusList, Service Emame 11312005 10:07:3... The... False Mame
f alarm Logaer, Service %5 Made Administration Structure 1/3/2005 10:08:5... [MWod... False Node Administr...
f alarm Manager, Service @Object Icon 5/6/2003 6:33:39... Icon... True Object Icon
f AspectDirectory, Service Service Provider Definition 2{28/2005 5:41:0.., False Service Provide. ..
f BackupService, Service Service Provider Type Reference 11312005 10:07:3... Thes... False Service Provider
f Basic Histary, Service 2 Service Structure 11312005 10:07:3... [Serv... False Service Structure
f Batch Service, Service
f Calculation Server, Service
f Cross referencing server, Service
y Event Collector, Service JJ % - |IM_InF0rm IT History_ENGE;‘l:Service;I ?j ’(? - -

f External larm, Service _ _
7 File et Distribution, Service Configuration |Status |
f Industrial IT Archive, Service

= f Inform IT History, Service Service: IInFDrm IT History Vill
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@ﬁ IM_EMGE4, Service Group Group: IIM_ENG64 Wiew |
---@ I0_Inform IT History_ENGE4, Service Provider
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§§ IM_RiOCS0, Service Group Current Service

-#m [M_TAR238, Service Group
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]@9 Opchid_Connector, Service
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T - -

Figure 66. Service Structure

The archive service is under the control of PAS. Manually restarting the archive
service will cause all the IM History to restart (PASGUI - > restart all). The History
Service is started by PAS if it is not running and should always be enabled. The
service can be stopped or started at any time without affecting history runtime.

Most Information Management components DO NOT support redundancy. For
@ those components, no service group should have more than one service provider.
Two exceptions are Softpoints as of 800xA 4.1 and Calculations as of 800xA 5.0.
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Creating Softpoint Service Providers

The Softpoint Service Group/Service Provider must be manually created as part of
the Softpoint Configuration. This is described in the section on softpoints in System
800xA Post Installation (3BUA000156%).

Calculation and Scheduler Services on Non-Information Management Server
Nodes

Calculations and Application Scheduler may also be installed and run on other types
of server nodes in the 800xA system (not Information Management servers). In this
case, the service group/service provider objects for those services must be created
manually for each of those non-Information Management servers.

Processes

Processes related to Information Management are listed in Table 6 and are
accessible via the Windows Task Manager.

Table 6. Processes

Service Related Processes
Display Services ADSdpADO ADSdpOPC
ADSdpDCS ADSdpOPDHDA
ADSdpDDR ADSS (Startup program for the rest of the
ADSdpLOG programs)
ADSspCOM
Supporting Services omfCleanup omoNameBroker
omfNameProc omoNodeBroker
omfPM omoService
omfService omoStorageDomain
omfTimer omoTypeDirectory
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Table 6. Processes (Continued)

Service Related Processes

History EHOPAEServer hsHistoryService
hsAdmin hsHistSvcPASAdmin
hsAchiveService hsHistorylcon
hsCollection hsProfileServer
hsEventLogCollector  hsRetrieval
hsHDAServer hsServer
hsLogman hsStorage
hsMsgServer hsSuperlPC (Startup program)
hsPDLStorage msgApiSrv

PDLAPISRV

Calculation Service CalculationService

Open Data Access Odaserver Odaservice
ABB_ODA_AGENT - oaagent.exe
ABB_ODA - oasoa.exe, oastrtr.exe

Scheduler AfwScheduler

PAS (overall startup) PAS_Service

PAS Service Account

The PAS service account is configured via the Information Management
Configuration wizard as a post installation step (or during Information Management
software installation for 800xA 5.0 and higher). This establishes the user account
under which most Information Management services run including History and
Display Services. The PAS service account must be configured to match the ABB
Service Manager (core services) account. You can check this quickly via the
Windows Services Manager. Check the Log On As settings for the ABB
ServiceManager, ABB Data Service Supervision, and History Service, Figure 67.
All three services should have the same log on setting.

Also, this user must be represented in the User structure under the Administrators
User Group, Figure 68.
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If you need to change the PAS Service account, be sure to use the PAS Password
Administration tool (Start > Settings > Control Panel > Administrative Tools >
PAS > Password Administration). The tool under the History menu only sets the
History account, it does not set the other services. The tool can also be started by
typing "pasPwdAdmin.exe" in the Run dialog. After setting the password, the
station should be rebooted for all the changes to take effect.

Services (Local)

ABB ServiceManager Mame / I Description I Status | Startup Type | Log On As | ;I
AEE Data Service 5... Started Manual B00xadom|S00xaservice )
Stop the service %ABB MG Server For... MMS Lo, ., Maral Local System
ECE L LR AEE Process Admini... Started Automatic Local System
ELEE Seryice Eedundant Larted Lutornatic Local System
Description: _ Autormatic
fnr:nc:;;reocrto?ﬂlt?olsﬂ;:ifzgm:v;?rfw s ABE Systemn Motifica,., Process Po... Autarnatic Local System
services. %ABB Tool Routing 5., Tool Routin,.. Manual Local System
%Alerter Motifies sel... Disabled Local Service
%Application Layer G... Providess,., Manual Local Service
%Application Manage... Processesi,.. Started Manual Local System
%ASP.NET State Serv... Providess... Manual Mebwork Service
%Automatic Updates Enables th...  Started Automatic Local System
%Background Intellig... Transfers... Started Manual Local System
%ClipBook Enables Cli... Disabled Local System
%COM+ Event System  Supports 5., Started Manual Local System
%COM+ Syskem Appli... Managest... Manual Local System
%Computer Browser Maintains a... Started Autarmnatic Local System
%Cryptographic Servi... Providesth... Started Automatic Local System
%DHCP Client Registers a...  Started Aukomatic Mebwork Service
%Distributed File Syst... Integrates ... Started Automatic Local System
%Distributed Link Tra... Enables cli...  Started Aukomatic Local System
%Distributed Link Tra... Enables th... Disabled Local System
%Distributed Transac... Coordinate... Started Aukomatic Mebwork Service
D3 Client Resolves a...  Started Aukomatic Mebwork Service
%Error Reporting Ser...  Collects, st...  Started Automatic Local System
%Event Log Enables ev... Started Automatic Local System
%File Replication Allowes Files. .. Manual Local System
and Support Enables He Started Sutomatic Local System
%HistoryService Started Manual B00xadom|800xaservice )
HTTP 55L This servic,..  Started Manual Local System
%Human Interface D... Enables ge... Disabled Local System LI

Figure 67. Verifying PAS Service Accounts
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gﬁmuc% System 12-dec-04 version of PPA4.0 // Plant Explol

J | 22 ||| Enter search name) =l|[meF

I T:ﬂ User Struckture ﬁ

E--g User Groups
| Administrators - 800xadomiIndustrialITAdmin, User Group

ﬁ B00xADOMB00xaadmin, User

B00xADOME00xaservice, User

s‘j Application Engineers, User Group

| Everyone - 800xadom’IndustriallTUser, User Group
{ Operatars, User Group

3 Srfhmisea Mavalanare | lear Croan

Figure 68. Checking the Service Account in the User Structure
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Diagnostic Log Files

Some Information Management applications generate log files to facilitate
troubleshooting, Table 7.

Table 7. Log Files

Application

Location of Log Files

Information
Management History

Enter %HS_LOG% in the Windows Explorer, Figure 69. This points to
C:\ProgramData\ABB\IM\History\log on the system drive (typically C:). An
example log file is shown in Figure 70.

Application Scheduler

Go to C:\ProgramData\ABB\IM\Scheduler\ on the system drive

Process Administration
Service

Go to C:\ProgramData\ABB\PAS\Pas0.log

Open Data Access

The ODA Server logging function records status information for each
query against the Numericlog table.

Logging is disabled by default. It is recommended that you leave logging
disabled unless you are having problems and need to provide ABB
support with a record of query activity. To enable logging, see the section
on ODA in System 800xA Information Management 5.1 Configuration
(BBUF001092%).

The log files will be located at:
C:\ProgramData\ABB\IM\ODA

Calculations For 800xA 5.0, the Calculation server outputs diagnostic debugging
messages to a series of files named CalcsDebug*.log, located in the
C:\ProgramData\ABB\IM\Calculations directory.
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Table 7. Log Files

Application

Location of Log Files

Installation

C:\programData\ABB\IM\Install
and
C:\programData\ABB\PAS

Oracle Diagnostic
Logs

alert_adva.log in C:\oracle\diag\rdbms\adva\adva\trace

Find problems by searching for words like ERROR or ORA- (Be sure to
include the hyphen after the A in ORA-. Otherwise, the search will stop at
the word oracle which may occur thousands of times.)

ORA-1652: unable to extend temp segment by 128 in tablespace TEMP

ORA-000060: Deadlock detected. More info in file
C:\ORACLEW\admin\ADVA\udump\ORA04016.TRC.

This log may be lengthy. If it is difficult to read with notepad, try wordpad
or Microsoft Word. If this file gets too big (over years), stop PAS, stop
Oracle, then delete the file.

tnslistener log (listener.log) location:
C:\oracle\diag\tnsisnr\eng58\listener\trace

Upon a reboot the current log is saved as the log.old log and a new log is
started.

In some cases you may need to zip up the complete contents of the log
folder and send it to a supportline center.
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rogram Files

File Edit ‘iew Favorites Tools Help

sHBack + = - | Q) search | (% Folders | €4 | FrER P SO 4
Address I
Folders x |[ =
ocuments and Settings' All Users' Application Data', ABB'IM ;|g|5|
File Edit Wiew Favorites Tools Help | ﬂ'
JBack ~ ) - » | ) search |ﬁf! Folders | & X ) | -
Address IE] CiiDocuments and Settingsiall Userstapplication DatalABEYIM|Historylog j Go
Folders x | Size | Type | Date Modified -
@ Desktop N 4 KB  Text Document 12/29}2004 6:00 AM
D My Documents ArchiveService.log 9KE  Text Document 3212005 11:32 AM
= ,J My Computer ArchiveServiceD.Iog.oId 11KE OLD File 3/2/2005 11:31 AM
5 4% Floppy (A1) EHOPCAEServerD.log 6 KB Text Document 3212005 11:32 AM
B % Locsl Disk (C) EHOPCAEServerD.log.old 6KE OLDFile 3/2/2005 11:31 AM
I [ Documents and Settings EvtTrigDataCollAction.log ZKB Text Document 12/22}2004 5:55 PM
[ 800%aAdmin historyBackup.log 45 KB Text Document 12/29}2004 §:56 AM
[ &00xainstal historyRestore. log 40KE  Text Document 12/30/2004 3:01 PM~—
() B00%ASEervice - hsadmind. log 11 KE Text Document 3212005 11:32 AM
) Administrator [ hsdrino. log.cld 12K8 OLDFie 3/2/2005 11:31 AM
Bl ) all Users hsarchRErvO. log 10KE  Text Document 3212005 11:32 AM
Bl [ Application Data hsarchREryD.log.old 10KE OLD File 3212005 11:31 AM
I [ ABB hsBackupApp0.log 18KE Text Document 12/30/2004 3:34 PM
BHim hsBackupapp0.log.old 10KE OLD File 12/29}2004 10:15 AR
[ Archive hsCFgServerD.log 7KE  Text Document 3212005 11:32 AM
Bl [ History hsCFgServerD.Iog.oId 8KE OLD File 3212005 11:31 AM
[ config hsCollectionn.log 13KE  Text Document 3212005 11:32 AM
[ conkext hsCollectionn.log. old 15KE OLD File 3212005 11:31 AM
9 log hsConsolidaten.log 17 KB Text Document 12/31}2004 2:59 PM
[ aracle hsConvertDBEOZS00.log 11 KB  Text Document 12/30/2004 3:11 PM
[ POL hsConvertDBo2500.log.old 11KE OLD File 12{28/2004 1:44 PM
& |Reports [ Fi bt 1 PVDEARE AR L 141D Trak P - m.lorl.mnm T T
|58 ohjects {Disk free space: 54.8 GE) 16.2 ME | ‘_‘l My Computer 4

Figure 69. Accessing History Log Files
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.,J historyBackup.txt - Notepad - |EI|1|

File Edit Format Help

| v

l hsear wversion hsBARC.cC,v 20.1 2004,/08/11 22:13:42
hsBar irnwvoked with the following command:
"hsBar -mb -h g:ZhsBar“tarz227 "
HD bhackup--destination file is 'g:\hsBaritar227?'
Using 'DivHsDataHistory' for temp and oracle export directory
Connected to oracle as <ops$ocshiss
WARNING: This backup s executing with History Running.
If PoL data s added, modified, or deleted during this backup, oracle may
not he ahle to enable constraints for the POL tag1 The restore log should
reviewed to verify the oracle import of all the constraints succeede
Database backed up by exq utility
command :exp USERID= e="D: \HsData\H1story\BARExport dmp" OwnNER=0ps$ocshis BU

Export: Release 8.1.7.4.1 - Production on wed Mar 2 15:38:05 2005

(<) Copyright 2000 oracle Corporation. Al11 rights reserved.

Connected to: oracledi Release 8.1.7.4.1 - Production
Jserver Release 8.1.7.4.1 - Production
Export done in WESISOBS59P1 character set and WEBISO8859P1 NCHAR character set

about to export specified users .
exporting pre-schema procedural objects and actions
exporting foreign function Tibrary names for user OPS$OCSHIS
exporting object type definitions for user OPS$OCSHIS
about to export OPS$OCSHIS's objects
exporting database Tinks
exparting sequence numbers
exporting cluster definitions
about to export OPS$OCSHIS's tables wia Conventional Path L

exparting table ARCHIVE_DE 97 rows exported
exporting takle ARCHIVE_LOG 63?5 rows exported
exporting takle ATTR_ID_TO_MNAME 217 rows exported
exporting takle CLASS_ID_TO_MAME 34 rows exported
exporting takle DIR_LIST 4 rows exported
exporting takle ENG_UNIT_DESC 0 rows exported
exporting takle FILE_LIST 103 rows exported
exporting takle HIER_INFO 106 rows exported
exporting takle HISTORY_ASSOCIATIONS 251 rows exported
exporting takle HISTORY_ASSOCIATIONS_RST 0 rows exported
exporting takle HISTORY_ASSOC_OCC_END 247 rows exported b
exporting takle HISTORY_ASSOC_OCC_END_RST 0 rows exported
exporting takle HISTORY_ASSOC_OCC_START 251 rows exported
exporting takle HISTORY_ASSOC_OCC_START_RST 0 rows exported
exporting takle LOG_MAR_TAELE 105 rows exported
exporting takle LOGE_SOURCE 209 rows exported
exporting takle MODIFIABLE_COLUMNS 62 rows exported
i 0 rows exported
exparting table  MODIFICATIONS_ATTRIBUTES_RST 0 rows exported

exporting tahle MSG237
EXP-00002: error in writing to export file
EXP-00002: error in writing to export file
EXP-00000: Export terminated unsuccessfully
wWaARNING: This backup s executing with History Running.

up, oracle may
restore loo should =il

0 0
not be able to enable constraints for the PoL tables. The

Figure 70. Example Log File
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Performance Counters

You can add counters to the standard Windows performance monitor to evaluate and
debug the performance of Information Management history processes (System
Version 4.0 or higher). These counters are active as long as the Windows
performance monitor is open. For long term monitoring, you can record the counter
statistics in a log file.

A quick summary of the available counters is provided in Table 8.

Table 8. Information Management Performance Counters

Name

Description

IM API Counters

These counters let you monitor the number of messages in the queue,
incoming messages per minute, and messages processed per minute
for OPC message log and/or PDL message log. Use these counters
when configuring your message logs to help you correctly size the
message logging application, or to debug the message logging
application when the performance is slow.

IM Archive Counters

These counters let you monitor the available disk space for archiving
and/or the number of archive failures. Use these counters to debug the
archive application when the performance is slow.

IM Collection Counters

These counters let you monitor the number of points per minute being
collected for DA (real-time) and/or HDA (history) data.

IM Storage Counters

This counter lets you monitor the number of points per minute being
stored in history.

Adding a Counter

To add a counter:

1. Launch the Performance Monitor from the Windows task bar
(Start>Settings>Control Panel>Administrative Tools>Performance).

2. Right-click on the monitor, then choose Add Counters... from the context
menu, Figure 71.
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Reliability and Performance Monitor

@ File  Action Wiew Favorites  MWindow  Help | - 18] x|
= | 2|0 = | H o
@ Reliability and Performance M B =
: & - k2 f ¥
=l g Monitaring Tools ,_ = |EE!|RJ| — DD!|IH ’”.
i Performance Monitor
== reliability Maonikar 100
& Data Colleckor Sets
[ Reports
G0+
60
404
204
1] T T
9:34:54 PM 9135124 PM 9:35:54 PM 913632 PM
Lask 9,374 Average | 12,291 Minimum | 0.000
Mairmurn | 5,937 Duration | 1:40
Show | Color | Seale | Counter Instance | Parent Chiject Computer
v
4| »

Figure 71. Adding a Counter
3. Choose whether to use counters on the local computer (Use local computer
counters radio button), or use counters from a different computer. To use a
different computer, select Select counters from computer:, then select the
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computer from the associated pull-down menu, Figure 72.

Add Counters | x|
~Awvailable counters r~Added counters
Select counkers from computer: Counter | Farert | Tnst... ‘ CompLter |
I <Local computer= j Browse... |
ICFIPYE s ;I
IM API hsMsgServer Counters
IM API PDL Message Counters —
IM Archive Counters
IMHDA Collection Counters
IMHDA Log Counters
..................... =
Instances of selected object:
<Al instances >
o
j Search |
Add == | Remove =<
™ Show description Help o

Figure 72. Selecting the IM Counter Category
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Performance Counters

4.  Select the applicable counter category from the Performance Object menu,
Figure 72 (IM API Counters, IM Archive Counters, IM Collection Counters, or

IM Storage Counters).

Add Counters

i~ Available counters
Select counters Fram computer:

ﬂ Browse. ., |

ILFIFYE |} AI

I <Local computer =

IM API hsMsgServer Counters =

Msgs/Minuke In
Msgs/Minuke Cuk

IM API PDL Message Counters

IM Archive Counters =

Instances af selected abjeck;

Figure 73. IM API Counters

IM API Counters on page 211

IM Archive Counters on page 213

IM Collection Counters on page 214

M HDAcollection counters

IM Log Collection counters

IM Storage Counters on page 215
Logging Counter Statistics on page 216

IM API Counters

Refer to the applicable section referenced below for details on selecting a
specific counter from the selected category:

There are three counters in the IM API Counters category. You may choose to use
all available counters by selecting All counters, or just certain counters by selecting
Select counters from list:, and then selecting the counters, Figure 74.
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Each counter has two instances. You may choose to use all (both) instances or one
specific instance. Refer to the instance descriptions in Table 9.

Add Counters [ %]
~ Available counters r~Added counters
Select counters from computer: T | oy | Tnst... | Computer |
I <Local computer = j Browse. .. |
IM API hsMsgServer Counters =] ;I
IM API PDL Message Counters
IM Archive Counters
T™M HNA Collackinn Counkers M LI
Instances of selected object;
j Search |
Add = | Remove <=
™ show description Help | oK I el

Figure 74. IM API Counters Dialog

Table 9. IM API Counters & Instances

Counters Instances Description
Msgs in Queue — Number of messages waiting to be stored
Msgs/Minute In — Number of messages coming into the queue
Msgs/Minute Out — Number of messages leaving the queue
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Performance Counters

Table 9. IM API Counters & Instances

Counters Instances Description
— hsMsgServer Messages stored in the IMMSGLOG
— PDL msgs Messages stored in the PDLMSGLOG

IM Archive Counters

There are two counters in the IM Archive Counters category. You may choose to use
all available counters by selecting All counters, or just certain counters by selecting

Select counters from list:, and then selecting the counters, Figure 75.

There is one instance of each counter. Refer to the instance description in Table 10.

i~ Avalable counters ~Added counters
Select counters from computer: Counter | FParent ‘ Inst. . | Computer
I <Local computer = j Browse. ., IM Archive Counters
IM Archive Counters = d "
Disk Free
Failures iy
IM HDA Collection Counters
IM HDA Log Counters
IM Storage Counters
=
Instances of selected abject:
j Seatch
,WI Remove <=

I~ Show description

Help (o]'¢

Cancel

Figure 75. IM Archive Counters Dialog
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Table 10. IM Archive Counters & Instance

Counters Instances Description
Disk Free — Amount of disk space available for storing archive entries
Failures — Number of failed archive attempts

IM Archive Information Management Archive Service

IM Collection Counters
There is one counter in the IM Collection Counters category (Pts/Minute), Figure 76

The Pts/Minute counter has two instances. You may choose to use all (both)
instances or one specific instance. Refer to the instance description in Table 11.

Add Counters [ ]

—Added counters

—fwailable counters

Select counters Fram computer: Counker ‘ Parenk | et . | Computer |
I <Local computer = j Browse... | IM Archive Counters =
IM HDA Collection Counters = ;I * - -
PtsfMinute
IM HDA Log Counters =]
b i
Logs/Minuke
IM Storage Counters =

Instances of selected abject:

j Search |
Add =z | Remoye <=
™ show description Help | oK I Cancel

Figure 76. IM Collection Counters
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Performance Counters

Table 11. IM Collection Counter & Instances

Counters Instances Description
Pts/Minute — Number of points being collected per minute
— IM log collection Number of HDA requests
— IM HDA Collection Number of values collected

i Awailable counters

IM Storage Counters

There is one counter in the IM Storage Counters category (Pts/Minute), Figure 77.

The Pts/Minute counter has one instance. Refer to the instance description in

Table 12.

Select counters from computer:

I <Local computer= j Browse. .. |
IMHDA Collection Counters = ;I
PtsfMinute
IM HDA Log Counters = i
Lags/Minute
IM Storage Counters =

Instances of selected object:

j Searoh |

add>> |

Add Counters [x]

r~Added counters

Counter

| Parent | Insk... ‘ Computer |

-

Remove ==

M Archive Counters B

[ Show description

Figure 77. IM Storage Counters Dialog

Help | K I Cancel
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Table 12. IM Storage Counter & Instance

Counters Instances Description

Pts/Minute — Number of points being stored per minute

IM Storage IM Storage

Logging Counter Statistics

To record counter statistics for long term monitoring, you can set up one or more log
files. For each log, you must add one or more counters whose statistics will be
logged. This is similar to the procedure described in Adding a Counter on page 208.
You must specify a user account with administrator privileges under which the log
will run. As an option you may specify a file type, and set up a schedule for the log.
By default, the log will sample the specified counter(s) every fifteen seconds and
will store the data as a binary file. The binary file must be viewed using the
performance monitor. As an option you may specify another file format, for
example - text, and set up a schedule for the log.

The files are stored in C:\perflogs, Figure 78.
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@ C:.perflogs 10l =l
File Edit View Favorites Tools  Help | ",'
QBack - &) - ¥ | ) Search |ﬁ_‘;‘; Folders | & @ X ) | B
Address I@ Ciiperflogs j e
Falders X || Mame = | Size | Type | Date Modified l
=l < Local Disk (C:) ;I E asdf_000001.blg 128 KB Performance Monitor ... 3/14/2005 5:18 PM
[ 9.2.0.6.5 ODEC Driver Patct @ ROC79Log_000001.blg 64 KB Performance Monitor ... 3/14/2005 5:32 PM
I25) backupreports
123 Dedl

IC5) Documents and Settings

|C5) HsData

I23) Inetpub —
IC5) Mew Folder

[C3) OperatelTData

IC3) ORAZZ0ES

I23) oracle

I£3) ©raHome_1

oz loa:

IZ3) Program Files hd
| | »

|2 ohjects {Disk free space: 65.3 GB)

1526 B o P
Figure 78. Location of Performance Logs

To set up a log:

1. Open the performance monitor.

2. Expand Performance Logs and Alerts.

3. Right click on Counter Logs and choose New Log Settings from the context
menu, Figure 79.
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fi& Performance

@ File  Action VWiew Favorites Window  Help

=10 x|
JRE

- E@ BB &8 D) -

D Console Rook Iame

| Comment | Log File Type | Log File Mame

gﬁ System Monitor

H ' Syskem Cwverview
=43 Performance Logs and Alerts

' dave

Mew Log Settings...

ale Mew Log Setkings From...

Wigw 3
Mew Window from Here

Mew Taskpad Yiew. ..

Refresh
Expork List, ..

Figure 79. Creating a New Log

This sample log provides ano...  Binary File

Binary File

Ci\PerflogsiSyste
Ci\Perflogsidave

4. Enter a name for the log, Figure 80.

M ame:
IHDE?SLod
()8 I Cancel |

Figure 80. Entering a Name for the Log

5. Use the Add Counters button to start a dialog for adding counters to this log.
The procedure is basically the same as described in Adding a Counter on page

208, Figure 81.

6. Change the Run As specification to an administrator user account on this
workstation. The log will not run as the <default> user.

7. As an option you may change the file format and schedule, Figure 82.
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Rocraiog 21

General | Log FiIesI Schedulel

Current log file name:

// Add Counters

AddDbiects...‘l AddEounters...l) Femove |

N—
Sample data every:

Interval: |15 _,::' Units: Iseconds 'l - Change the User
Account
\/

Rurn &gt |ftt Set Pazsword... )l

QK I Cancel | Apply |
Figure 81. Adding Counters and Specifying the User Account

Rocraiog 21 21

General LogFiles | Schedulel Generall Log Files  Schedule |
i~ Log file type and name r— Start log
Log file type: " Manually [using the shortcut menu)
Binary File - Configure...
y =l @ ar | 53003PM = on | 3/14/2008 =]

Text File [Comma delimited)
Text File [T ab delimited
Binary File

Binary Circular File
SOL Database
Example:
 After |1 = Urits: [ days -
IE:\PerfLogs\HDE?SLUQ_DDDDD‘I .blg I =l itz I 14 J

~Stop log
& Manually [using the shortcut menu)

Ak | 5:30:09 PM = | 3/15/2005 =

Comment: € yhen the o file s full

I ‘when a log file closes:

[~ Ovenwiite existing log file ™ Start & nevlog)file

[~ Run thiz command:

Figure 82. File Type and Scheduling Options
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SQL Queries

The SQL queries described in this section may be used to troubleshoot history
applications. Use the Windows command prompt and log in to SQLPLUS as the
ops$ocshis user. An example is shown in Figure 83.

If you cannot log in to SQLPlus, make sure the Oracle_SID environment variable
@ is set to adva. See Cannot Access History Database via SQL on page 233.

| Administrator; indows' system32'cmd.exe

C:Users B@Bxalnstall>
C:sUserss8@Bxalnstall>*sglplus ops%ocshis

SQL*Plus: Release 11.1.8.7.8 - Production on Thu May 6 23:85:41
Copuyright <c)> 1982, 2008, Oracle. All rights reserved.
Enter password:

Connected to:
Oracle Databasze 1lg Release 11.1.8.7.8 - Production

SQL> select % from object_table where object_type = 2;
OBJECT_ID

_NAME

806
$HSIMMSGLOg_%P_lB_12E_B_58—1—u

SQL> exit
Dizconnected from Oracle Database 1lg Release 11.1.8.7.8 - Production

C:sUsers\B@Bxalnstall>

Figure 83. Example SQL Query

In this example, the first query is used to get the message IDs for all message logs
on this node. The second query gives you the number of messages in the log whose
ID is specified (in this case 171).

220

3BSE046784-510 E



Section 8 Information Management

SQL Queries

These and other queries are described in Table 13.

Table 13. SQL Queries

Query

Description

select count(*) from object_table where
object_type = 1;

Get number of Information Management
History log configurations that exist in Oracle.
This may be useful if you suspect that log
configurations that exist in the aspect system
are not being created in Oracle.

select object_id, object_name from object_table
where object_type = 2;

Get the ID for all message logs on the node.
IDs are used in other queries to identify the
message log.

select count(*) from msgnnnn

nnnn = message log ID

Get the number of messages stored in the
specified log. This is useful when you are
unable to retrieve message from a data access
application such as the DataDirect message
Log dialog, and you want to determine whether
the problem is with the message log or the data
access application.

select to_char(sysdate,' DD-MON-YYYY
HH:MI:SS') time, m.idx, c.* from msgcount&1 c,
msg&1 m where m.idx = (select max(idx) from
msg&1)

Get the message log size
Parameter 1 = log id

select idx, to_char(localtime, 'dd-mon-yyyy
hh24:mi:ss') Il ." I Ipad(time_nano/10000,3,'0")
localtime, message from msgé&1

where utc > (select max(utc)-&2 from msg&1)
order by utc, time_nano

Get last X messages stored
Parameter 1 = log id, Parameter 2 = number of
messages

select m.idx, rpad(a.str_value, 120) II
rpad(a.nbr_value, 15) lI
rpad(to_char(a.date_value, 'MM/DD/YYYY
HH24:MI:SS"), 30) Attribute_Value from msg&1

&2 from msg&1) and m.idx = a.idx

m, msgattrs&1 a where m.idx > (select max(idx)-

Get vendor attributes for last x messages
stored

Parameter 1 = log id, Parameter 2 = # of
messages
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Table 13. SQL Queries (Continued)

Query

Description

select m.idx, to_char(m.localtime, 'mm-dd
hh24:mi:ss') Il '." Il Ipad(m.time_nano/10000,3,'0")
localtime,

v.category_name,
v.attr_name,

rpad(a.str_value, 71) |l rpad(a.nbr_value, 15) lI
rpad(to_char(a.date_value, 'MM/DD/YYYY
HH24:MI:SS'"), 30) Attribute_Value

from msg&1 m, msgattrs&1 a, msgvendors v

where m.idx > (select max(idx)-&2 from
msg&1) and m.idx = a.idx and v.attr_id = a.attr_id

order by a.attr_id

Get last X messages and the associated
vendor attributes with attribute names
Parameter 1 = log id, Parameter 2 = #
messages

select * from msgvendors order by
vendor_name,category_name,glb_category,
category,seq_nbr

Get category definitions of vendors attributes

select localtime as Time, time_nano/10000 as
msec, source as Source,
SUBSTR(MSGATTRVAL('ObjDescription',idx),1,2
50) as Description,
SUBSTR(MSGATTRVAL('Area’,idx),1,250) as
Area, condition, sub_cond,
SUBSTR(MSGATTRVAL (‘State',idx),1,250) as
State from IMMSGLOG_IP

order by localtime

Example query against the Information
Management Message Log

select name,variablevalue,occurrence,taskid from
task_variables_occurrences

where taskid in(select taskid from task connect by
parentid = prior taskid start with taskid =

(select taskid from task where name =
'‘P050006"))

Gets batch variables directly from the lower
level tables without having to use the views
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Debug Files and Trace Monitors for Display and
DataDirect

Display Services and DataDirect provide several tools for troubleshooting data
access applications:

e DataDirect Debug File on page 223
* Display Services Trace Log and Communication Statistics on page 223
*  Trace Monitor on page 224

DataDirect Debug File

This function is available via the Setup tab on the DataDirect Options dialog. When
this option is selected DataDirect writes status information to a text file that you can
use for troubleshooting. The file name is debug.txt. This file is located in

% ABB_ROOT%InformIT\DataDirect\tmp. The default path for % ABB ROOT%
is: C:\Program Files\Abb Industrial IT\

Display Services Trace Log and Communication Statistics

The Trace log displays system error messages and user defined messages with time
stamps, Figure 84. Messages are sent to the trace log via the trace script. To open the
trace window, choose Help > Diagnostics >Trace Log on the Display Client menu
bar.

Advalnform Dizplay Trace Log

[0 32 45-T BroveserE stensive-< < [Filetigent) HightMenuSuppnrt[name=D:scuttﬁzaammnd,typail
03:32:45-T-BrowezerEstensive-<< [Filedgent] GetLegalChildstype=015PLAY childs= etstat=1]
03:32:45-T-BrowserEstensive-<< [Filehgent] GetLegalChildz[type=GROUP chidz=DISPLAY rel
03:32:45-T -BrowserEstensive-<< [Filzdgent] RighttenuSupporthame=0: scott¥zoommod type:
03:32:45-T-Browser: E stenzive-< < [Filzdgent] RighttenuSuppart{name=0: rcottfzoommod bype:
0332 45-T-Browser: E stenzive-< < [Filzbgent] RighttenuSuppart{name=0: zocottfzoommod bpe:
0332 45-T-Browser: E stenzive-< < [Filzdgent) RighttenuSuppart{name=0: zcottfzoommod . bpe:
0332 45-T-BrowserE stensive-<< [Filedgent] GetRiohtM enultype=01SPLAY action=5 retstat=1"

Figure 84. Example Trace Log

Help > Diagnostics >Communication Statistics opens the Communication
Statistics dialog, Figure 85.
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Communication Statistics

— Synchronous
iy ey Clear |

Butes: 92394 Bytes: 5718 Help |

Messages: Messages: 24

J
Jdd

Meg. pending: Meg. pending:

—Agpnchronaus

— Fix ¥
Eytes: I 0| | Bytes: I 4402
Messages: I 0 Messages: I 220
Mzg. pending: I 0 | | Mzg. pending: I 0

Figure 85. Communication Statistics

For further information refer to the applicable sections in System 800xA Information
Management 5.1 Display Services (3BUF001093%).

Trace Monitor

The Display Services Trace Monitor lets you track problems related to the data
providers. To use the Trace Monitor:

1. From the Windows task bar choose: Start > Programs > ABB Industrial IT
800xA > Information Mgmt > Display Services > Server > Trace Monitor.
This displays the Select Process dialog.

2. Use this dialog to open the Trace Monitor. As an option, you can also use this
dialog to send the trace output to a log file (reference Figure 86):

Select All Processes.
b.  Enter the path specification for the log file (optional and recommended).

c. Click OK when you are finished. This opens the Trace Monitor window,
Figure 87. The window will be empty until you set up the monitor.
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Trace Monitor

Select Process

Check = (=
hzHistorySync. exe B7.. ~—

A" Processes AfwFsdiode.exe 36.
AfwaD5erver.exe A mm
Dfssve.exe 16...
svchost.exe 39..
ADSdpDDR.exe T2
ADSspCOM. exe T2
Batch_ShowRed exe 38,

AbwSyzhdzgSrv. exe

¥ &l Processes

r— Options
[T Show Time

I Show FID
™ Mewest in top

Buffer size [lines) I‘I 000

|

Cancel |

Sel’ld Output AfwScheduler exe 20... [—Log ta file
H ANALTELT CDU”UQETE.ERE al=nn N

toa |Og file ADSdpL%G.exe 51 K IC:\temp\DataF‘rowderTrace_log Browse...l
Batch_phazed.exe 29.. — -
BatchOpcieServer exe 47... Linez in file IEDDD Files |5
omoService. exe 5]
AdvieSty.exe 9. (= Ovenwrite ) Sppend
PAS_Service.exe 828 LI

Figure 86. Select Process Dialog

§ABBMon - ALL .

File WYiew Window Help

28| - 18]

& &l @ x|

A

Now using C:%tewpiDataProviderTrace. log

Figure 87. Trace Monitor Window

3. From the Windows task bar choose: Start > Programs > ABB Industrial IT
800xA > Information Mgmt > Display Services > Server > Trace Settings.
This displays the Trace Settings dialog.

4. Use this dialog to set up the Trace Monitor (reference Figure 88):
Specify the server (typically localhost).

b.  Use the Task drop-down menu to select Use name below.

c. Enter the name of the data provider for which this monitor is being set up.
Enter the name exactly as it is indicated in the Display Server Status
dialog (Start > Programs > ABB Industrial IT 800xA > Information
Mgmt > Display Services > Server Status).

3BSE046784-510 E

225



Trace Monitor Section 8 Information Management

d. Select all traces in the Flags list.

« ABBTrace ll

— Server Info
Server Ibcdhoﬂ
Cancel |
Fart ID
Defaults |
r Trace Info
Task = ~ | AND channel ID
OR
Mame DBA
Flags
Walue | Diescription ;I
1024 TRACE_ORACLEID
2048 TRACE_SALLIGHT
4036 TRACE_SaLHEAWY
8192 TRACE_GENERALZ
16384 TRACE_OMF
32768 TRACE_TIMING A
| | »

Figure 88. Trace Settings Dialog

e. Click OK. This activates the Trace Monitor which will begin displaying
trace information, Figure 89. The setup dialog will remain open. Do not
close it at this time. You’ll need to use it to stop the monitor when you are

finished.
UoA—1—-value: “uUd, LEVEL: IKAL,L_UKAL,LILJ.U
DEL-I-Walue: §00, Lewvel: TRACE 3JALLIGHT
DEL-I-Walue: 1000, Level: TRACE SALHEAVY
DEL-I-Walue: 2000, Lewvel: TRACE GENERALZ
DEL-TI-Value: 4000, Lewvel: TRACE ONF
DEL-I-Walue: §000, Lewvel: TRACE TIMNING

DEL-T-ReadFromQueue:1, id:345, stat:0, Client:5000c00, Func:1145515400
DEAL-T-53IP message, Func: 0x7544, Length: 0O

DEAL-T-53IP message, Func: 0x7544, Length: 0O

DEL-T-ReadFromQueues:1, id:345, stat:0, Client:k00, Func:l
DEL-T-ReadFromQueues:1, id:345, stat:0, Client:k00, Func:l

DEAL-T-[1458] Dynamic Select |select table Name from ims tables| MaxRows: 100
DEA-T-[148] Dynamic Zelect |[select table Name from ims_tables| MaxRows: 100
DEA-E-Zelect, Exception while processing:|select table Name from ims_tables|
DEAL-E-OError Nuwber S50040e37000Description [Cracle] [ODBC] [Cra] ORA-00942: table or wview does not existOl
_DEL-T-Dynamic Select Pesult: 542

DEL-T-ReadFromQueues:1, id:345, stat:0, Client:b00, Func:1145515400

Figure 89. Example Trace Monitor Output
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If you are sending the output to a log file, this same information will be available in
the specified log file. You can take a snapshot of the Trace Monitor as a further
option (View > Snapshot).

Turn the Trace Monitor off when you are finished. Select <No trace> in the
@ Trace Settings dialog, Figure 90, and click OK. Click Cancel to close the dialog.

x|
—Server Info
0k I
Server I\ocalhosl
Cancel
Fart Ig 4'

Defavlts |

~ Trace Info

Task Use name belo VIAND channel ID

ul3]

Mame DBA

Flags

Yalue | Description -
<Motrace>

1 TRACE_FILEID P

2 TRACE_PIPEID

4 TRACE_SOCKETIO

Figure 90. Turning the Monitor Off

History

This section provides guidelines for troubleshooting problems related to History.

Checking Upstream for History Problems

Problems with numeric and/or message data collection in Information Management
history may actually be due to problems upstream in the 800xA system. Before you
spend time and effort troubleshooting the Information Management history
configuration check the following upstream applications:

* related basic history trend logs.

*  OPC DA data source - subscribe to live data via the Control Connection aspect.
»  status of the System Message Service in the Service structure.

»  verify that messages are available via alarm/event lists.
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What To Look For When Logs Do Not Collect Data

Data Not Available in Basic History Trend Logs

If you cannot read data from the basic history trend logs, make sure you have added
history source aspects in the structures where those logs reside. Refer to the section
on configuring property logs in System 800xA Information Management 5.1
Configuration (3BUF001092%).

Data Available in Basic History Trend Logs But Not IM History Logs

*  Sample Blocking Rate - It is common when you first activate a log to see the
operator trend data, but no history (Information Management-based) data. This
is due to the sample blocking rate configured on the Data Collection tab of the
Log Template. The blocking rate controls the frequency at which data is
collected by the history log from the source trend log. If you experience this
lag, check the blocking rate to determine whether or not that is the cause.

* Restart Basic History - Sometimes it is necessary to restart Basic History on
Information Management and Connectivity servers after logs have been added.

e Stagger - It is strongly recommended that you use the hsDBMaint stagger
function to evenly distribute collection from the basic history logs. Failure to
stagger the Information Management logs may result in excessive and
unbalanced disk I/O load on both the Connectivity and Information
Management servers, and may result in missing data in the Information
Management logs.

To check whether or not the stagger function has been run, you can generate a
statistical file for the collection process as described in Performance Counters on
page 208. Search on the keyword secondary to find the SECONDARY LOG
QUEUE STATS section, Figure 91. If all logs having the same blocking rate are
grouped together (for example, 12,000 logs with 1-hour blocking rate, and 3000
logs with 4-minute blocking rate), then stagger has not been run. Also look for stale
request messages in the hsCollection log file, Figure 92.

Run this function from the hsDBMaint main menu. History must be running when
you run the stagger function. Refer to the section on history database maintenance
in System 800xA Information Management 5.1 Configuration (3BUF001092%).
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SECONDARY LOG QUEUE STATS:
Mext 2ndary Logs (including TogID = 2010 will be collected in 1:44 (MMMM:ISS)
15000 = Mumber of 2ndary Log Queus Entries Currently In Use
15000 = Wumber of 'secondary' Logs Represented By These Entries
2 = number of Time slots In The queue
Before G50.00 = Average number of requests per minute
St 1 cCurrent size of 2ndary Log Queue = 1920000 bytes
agger storedresponded(0]), waitingForstorage(l), MotsStoradyet(Z)
The Current Time 5 Tue Mar 29 2005 21:54:16. 000000

3000 3000 O 0 0 0:04:00 Tug Mar 29 20053 21:56:00
12000 12000 0O 0 0 1:00:00 Tue Mar 29 2005 22:00:00

Bl LOG QUEUE STATS:
Mext Zndary Logs (including logIDb = 59910 will be collected in 0:07 (MMMM:SS)
15000 = Number of Zndary LOg Queus Entries Currently In Use
15000 = Mumber of 'sSecondary' Logs Represented By These Entries
59 = number of Time slots In The Queus
After 950,00 = Aver‘age number of requests per minute
Stagger current size of 2ndary Log queue = 1520000 bytes
Storedresponded(0), waitingForstorage(l), MNotStoredvet(Z)
The Current Time is wed Mar 30 2005 23:08:23,000000

#Entrs #Logs Ack Msd Fails B-Rate Mext Collection Time
375 375 0 0 0 0:04:00 wed Mar 30 2005 23:08:30
375 375 0 o] o] 0:04:00 wed mar 30 2005 23:09:00
100 100 0 0 0 1:00:00 wed Mar 30 2005 23:09:00
375 375 0 0 0 0:04:00 wed Mar 30 2005 23:09:30
375 375 0 0 0 0:04:00 wed Mar 30 2005 23:10:00

Figure 91. Checking Stats File for Stagger

&, hsCollectionn.log - Notepad =

File Edit Format Help

-—-->ALIGMMENT QUEUE STATS<---—-
Hext aligned Log (logIp = 16670 to be activated in 0:00 (MMMM:SS)

LogsToactivate aActivationsalignment Time

4444 Sat Mar 19 2005 15:02:00
2045 Sat mar 19 2005 18:02:02
7393 Sat Mar 19 2005 19:02:08

Mumber of Logs waiting to be aligned - 13882

Humber of Mumber of Entries waiting to Align = 3

current size of alignment Queue = 344224 hytes

————>END OF ALIGNMENT QUEUE STATS<-———

hscActLog. C 507 19-19:02:00| STARTUP COMPLETE.

hscstartlp.c @ 370 19-18:02:00| Setting reTranslate response Handle, -1 to 5

hssignals. c @ 740 19-19:03:29| add event 8 0x1l00e6aBc, h = 0x000005F8 SIGALRM

hsc2ndLoga. © @ 1418 19-19:05:08| Total 100 stale reguests] MO_DATA for ID=26547(cfg=0x120e44d0)¢ ' PPAZ.1 HDA')
@
@

[~
ra

hsc2ndlogg. 1418 19-1%:06:08| Total 200 stale reguests] NO_DATA for ID=22700(cfg=0x1205hel0)( 'PPAZ.1 HDA')
hsc2ndlogd. 1418 19-19:06:08| Total 300 stale requests] NO_DATA for ID=28649(cfg=0x12133a90)¢ PPAZ.1 HDA')

Figure 92. Stale Requests Messages in hsCollection Log File
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[ hsCollection0.log - Notepad [_[o]x]
Fle Edt Format Wew Help

<4428>| 2: 199 OxBabhlc30 {86578CFE-E2A1-4052-8586-830AA21E0CE3 F<[Contral Structufe]RDDt/IMDA/OOAlOK/GFDup 01,/ TAG-000000 (MEASURE, LOG_305aC_Tws 4|
<4428>| Collection received 2 ReadRaw ( 2 STILL_IN_S¥NC J Tailures in the last 5 minute:

<4428>| First Reported:

<4428>| 1: 197 0xBahblc30 {482AF4EE-66A1-4D1E-8906-FOR8C2247498 < [Control Structure]Root/IMDASD0_LOK/Group_01/TAG-000001 :MEASURE, Log_30sac_lw>
<4428>| 2: 199 0xBahhlc30 {B657BCFE-E2A1-4052-8B86-830AA21E0CE3 p<[Control Structure]Root /IMDA/00_10K/Group_0l,/TAG-000000 MEASURE, Log_3058c_lws
<4428>| Collection received 2 Readraw ( 2 STILL_IM_S¥NC ) Tailures in the last 5 minutes.

<4428>| First Reported:

<4428>| 1: 197 0xBahblc30 {482AF4EE-66A1-4D1E-8906-FOR8C2247498 < [Control Structure]Root/IMDASD0_LOK/Group_01/TAG-000001 :MEASURE, Log_30sac_lw>
<4428>| 2: 199 0xBahhlc30 {B657BCFE-E2A1-4052-8B86-830AA21E0CE3 p<[Control Structure]Root /IMDA/00_10K/Group_0l,/TAG-000000 MEASURE, Log_3058c_lws
<4428>| Collection received 2 Readraw ( 2 STILL_IM_S¥NC ) Tailures in the last 5 minutes.

<4428>| First Reported:

<4428>| 1: 197 0xBahblc30 {482AF4EE-66A1-4D1E-8906-FOR8C2247498 < [Control Structure]Root/IMDASD0_LOK/Group_01/TAG-000001 :MEASURE, Log_30sac_lw>
<4428>| 2: 199 OxBapblSEO {BGETBCFE—BZA1—4052—8886—8§0£A@}E0c63}<[c8nt:n1 STructure]Root,/IMDA/00_L10K/Group_01/TAG-000000 1 MEASURE, LDG_30s52C_lws

| et £ PR yaeiiag - Romii S e

OoLCoDODoO0 OO

Figure 93. Enhanced Output shows the Full Path of the History Log with the Error

Logs Not Activating

When using the Bulk Configuration tool in Microsoft Excel to create a large number
of property logs, the logs will not activate automatically. To start the logs use the
Log List aspect on the Inform IT History Objects object in the Node Administration
structure. Refer to the section on starting and stopping data collection in System
800xA Information Management 5.1 Configuration (3BUF001092%).

Cannot Start History

e PAS Service account not correctly specified. See PAS Service Account on
page 201.

e Check the hsSuperIPC log file for errors or failures. See Diagnostic Log Files
on page 204.

e Invalid user/password for History Service Account.

Cannot Create Oracle Database Instance

*  Domain controller and Information Management server may be out synch.
Check the time setting on both nodes. If they are off by 10 minutes or more the
wizard may fail to create the database. Also check Time Zone settings.

*  Failure to create the Oracle Listener service. This is the last step of the
oracle 11 install utility. The user can re-run the utility to configure the listener.

e Current user not in HistoryAdmin group. Verify that the user you are
currently logged in with is a member of the HistoryAdmin group. If not, it is
recommended that you log in as the user that installed the software. This user is
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a member of the HistoryAdmin group. As an alternative, you may add the
current user to HistoryAdmin. If you add a new user you must restart history
via PAS.

Cannot View Report from IM report logs

Verify the IIS is configured on the IM server.

Insufficient Oracle Tablespace

Oracle tablespaces will be sized correctly if you made the correct choices for small,
medium, and large for each log type in Oracle Instance wizard. Also, putting Oracle
and file-based data on dedicated data drives rather than the system drive allows
tablespaces to autoextend up to the free space available on the drive where they
reside. If you do not make the correct selections based on your storage
requirements, you may run out of tablespace under the following conditions:

Creating a OPC Message log that is larger than can be supported by the
allotted tablespace. For example, if you selected Small OPC message log (up
to 500K entries), then you attempt to create a 12-million entry message log,
history will not allow this. In this case, you must adjust the
INFORM_HS_RUNTIME and HS_INDEX tablespaces. See Table 14.

If you attempt to configure more numeric logs than supported by the
allotted tablespace. Adjust the HS_ CONFIG and HS_ICONFIG tablespaces.
See Table 15.

If your PDL application grows larger than is supported by the allotted
tablespace. Adjust the HS_PDL and HS_IPDL tablespaces. See Table 16.

Table 14. OPC Message Logs (Includes PDLMSGLOG)

Tablespace Small - 500K Entries | Medium - 3M Entries | Large - 12M Entries
INFORM_HS_RUNTIME 214Mb 1287Mb 5224Mb
HS_INDEXES 190Mb 1144Mb 4589Mb
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Table 14. OPC Message Logs (Includes PDLMSGLOG)

Tablespace Small - 500K Entries | Medium - 3M Entries | Large - 12M Entries
Temp 512Mb 1024Mb 2048Mb
Rollback (Undo) 256Mb 512Mb 1024Mb

Table 15. Numeric File-based Logs

Tablespace Small - 10K Logs Medium - 25K Logs Large - 50K Logs
HS_CONFIG 40Mb 85Mb 171Mb
HS_ICONFIG 40Mb 94Mb 188Mb

Table 16. PDL Objects and PDL Data

Tablespace Small - 10K Objects |Medium - 25K Objects | Large - 50K Objects
HS_PDL 60Mb 355Mb 710Mb
HS_IPDL 50Mb 149Mb 298Mb

*  Consolidation of OPC and PDL messages, and PDL data. If the
INFORM_HS_RUNTIME and HS_INDEX tablespaces run out of space, OPC
and PDL message consolidation will fail. If the HS_PDL and HS_IPDL (index)
tablespaces run out of space, PDL data consolidation will fail.

Extending Tablespace

The user interface for extending tablespace has changed as of 800xA 5.0. For
details, refer to the section on History database maintenance in the applicable
version of the Information Management History Configuration Guide.

232 3BSE046784-510 E



Section 8 Information Management Insufficient Temp Tablespace and Rollback Segments

Insufficient Temp Tablespace and Rollback Segments

®

The Oracle Temp tablespace and rollback segments are used during certain history
operations, including restore, archive, message and PDL consolidation, deletion of
PDL data, and reporting.

With Information Management version 4.0 and later (using Oracle 9) rollback
segments have been replaced with UNDO tables.

Complex queries against PDL and PDL deletion operations may use a significant
amount of this tablespace. If you get an indication of insufficient temp or rollback
space in these situations, it is recommended that you adjust the query or delete the
PDL data in smaller increments.

Restoring a history database also uses the Oracle Temp tablespace and rollback
segments. If you run out of space during a restore operation, the restore will fail, and
you will be required to increase the temp and rollback space before retrying the
restore.

Use the Oracle Instance Maintenance wizard to extend the applicable tablespace.
The recommended guideline is to double the current size.

You cannot decrease the temp or rollback size. Therefore, you should take care to
increase the size by a reasonable amount that will provide the space you need.
The only way to revert back to a smaller size is to make a backup of your
database, drop and recreate the Oracle instance, and then restore the database.

Generally, you should extend a tablespace by modifying (increasing) the existing
file. Use the Add function when you need to add tablespace on a different drive.

Cannot Access History Database via SQL

Check the user account and environment variables as described below and shown in
Figure 94:

*  Make sure the user (currently logged in as) belongs to these local groups:
—  HistoryAdmin
— ORA_DBA

. Make sure the ORACLE_SID is included as part of the local user’s
environment settings
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EL-PS 1=

| adtion vew || &= 5 Bm|X 2B 2

Tree I

Marng | Description |

23 Adrinistrakars Administratars have complete and u...

@ Computer Management (Local) 2
Backup Operatars Backup Operators can override secu

[=] ﬂ Syskem Tools

[k @l Event Yiewer S Guests Guests have the same access as me... ﬂﬂ
- g System Information 5 Power Users Power Users possess most administr,.. Genelal' Network Idenhhcatlon' Hardwa|e| User Profiles  Advanced I
B ﬁ Performance Logs and Alerts Raphcator Supports file replication in a domain = =
+]-g -] Shared Folders Users Users are prevented from making ac.., Environment Yariables 2xl
Device Manager Debugger Users Debugger users can debug processe. ..
=5 Local Users and Groups A IM Histary Admin Group i~ User wariables For ptt
Users OR&_DBA Members can connect to the Oracle ...
el Histnrﬁdmi‘n f-'rnperties B ]/ I7 Local Users Group
\Documents and SettingsipttiLocal Se...
General | C:\Documents and SettingsipttiLocal Se...
g Histomyadmin
& Hew... Edt... | Delete |
,— Description It History &dmin Growy |
—System variables
Members:
: ORA_DEA Properties 21| Yariable [ iralue [=]
mAdmmlmlw ABE_DATA C:\Documents and SettingshAll Usersiap. .. —
ocshis General | ABE_DLL CHAMWINNTisystem3z)y
ﬂ PTTOOMAINSH ABB_LOG C\Documents and Settingsiall Usersiap...
ABE_ROOT C:\Program Files\ABE Industrial IT}
g BIFELIBIES ABB_TEMP C:iDocuments and SettingsiAll Usersiap. .. j
Mew,.. | Edit... | Delete |
Description, : o |
mAdministramr || | |
i
ocshis
add. | FEmevE | R TTOOMAINl

Figure 94. Checking User Groups and ORACLE_SID Environment Variable

Entry Tables and Error Reports for Numeric Logs

The hsDBMaint Entry Tables Report provides good information for troubleshooting
numeric logs. This report will help you to determine whether the problem is with
history or another application such as the core system, or data access application.

To generate this report, open a Windows command prompt and enter:

hsDBMaint -report > report.txt 2> error.txt
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This creates two text files in the location from which you ran the report. For
example, in Figure 95, the reports are created in C:\Documents and Settings\ptt.

Command Prompt

Microsoft Windows 2888 [Version 5.88.21951]
{C> Copyright 1985-2888 Microsoft Corp.

C:xDocuments and Settingssptt>hsDBMaint —report > report.txt 2> error.txt

[EX C:'Documents and Settings',ptt _‘I@I ;Iglll

File  Edit View Fawvorites Tools  Help ﬁ

e Back v = - | i search |%FOIders @“ﬁ X = | -

Address ID C:\Documents and Settingsiptt j 6o | Lirks **
Folders X | | Mame | Size | Tvpe |:|
Desktop a | | Local Settings File Folder

Y My Documents __5endTo File Folder
El"@. My Computer __| Application Data File Folder
-4 314 Floppy (A __IMetHood File: Folder
-5 FTP Area on 10,126,167 (B | | Deskiop File Falder
1= Local Disk, st} 1 |C2 Cookies File: Folder
B0 ajs [Z2My Documents File Folder
{2 Corfig.Msi [(rolupInstalFies File Folder
B2 del 4] Recent File: Folder
[_]D Diocuments and Settings "— ntuser.ini 1KB Configuration Settings
D Adrninistrator & 290ec04_0043_1... 45,090 KE  Easy CD Creator Im...
D Al Users @DSJanDS_DD‘IS_I. ag 58,586 KB Easy CD Creator Im...
D Default User 6KE  Text Document
D Frt 1KE Text Document
EHED imuser 7I0KE  Text Document
-3 [pte : 1,065KE DAT File
-0 Application Data % ntuser.dat.LOG 1KE  Text Document =
4] - |2 Jl=d | o

Figure 95. Location of Table Entry and Error Reports

The entry table provides statistics that help you to verify whether or not numeric
logs are functioning properly. You can also look up the Log ID for a specific log
name. Figure 96. Log IDs are used in SQL queries against historical tables.

Rows marked with an asterisk (*) indicate logs with errors. A summary is provided
at the end of the report. An example error report is shown in Figure 97. This
information is useful for level-4 (development) support.
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ECL=TEY
File Edit Format Help

InCtarlos) Fri Mar 25 16:22:26 2005 =
S start Time End Time dbratio Mext ROWS GoodDt BadDt NoDt 740 Log Mame

A 04 Mar 05 15:49:37 25 Mar 05 16:14:14  1.00:1 -1 30544 21781 8763 0 12 $HSFermenterd, Fermente
A 04 Mar 05 15:49:37 25 Mar 05 16:15:14  1.00:1 -1 30535 21771 8764 0 14 $HsBrewkettlel, amountH
A Q4 mar 05 15:4%:37 25 Mar 05 16:15:14 1.00:1 -1 30660 218596 8764 v 16 $HSErewkettlel,FlInlet
A 04 Mar 05 15:49:37 25 Mar 05 16:16:14  1.00:1 -1 89373 80608 8765 0 18 $H3Brewkett]el,FllLeavel
A 04 mMar 05 15:49:37 25 Mar 05 16:13:14  1.00:1 -1 30301 21539 8762 0 20 $HsBrewkertlel,FzInlet
A Q4 mar 05 15:49:37 25 Mar 05 16:14:14 1.00:1 =il, 30302 21530 8743 v] 22 $HsBrewkettlel,FzLevel
A Q4 Mar 05 15:49:37 25 Mar 05 16:14:14 1.00:1 -1 30302 21530 8783 v 24 §HSBrewkettlel,F3inlet
A 04 Mar 05 15:49:37 25 Mar 05 16:14:14  1.00:1 -1 30302 21539 8763 0 26 $HSBrewkettlel,FiLavel
A 04 Mar 05 15:49:37 25 Mar 05 16:14:14  1.00:1 -1 30303 21540 8753 0 28 $HsBrewkettlel,F4Inlet
A Q4 mar 05 15:49:37 25 Mar 05 16:15:14 1.00:1 -1 30545 21781 8764 v] 30 §HSBrewkettlel,FdLevel
A Q4 Mar 05 15:4%:37 25 Mar 05 16:15:14 1.00:1 -1 30303 21540 8783 v 32 §HSBrewkettlez, amountH
A 04 Mar 05 15:49:37 25 Mar 05 16:16:14  1.00:1 -1 30661 21896 8765 0 34 $HSBrewkettlez,FlInlet
A 04 Mar 05 15:49:37 25 Mar 05 16:13:14  1.00:1 -1 89370 80608 8752 0 36 $HSBrewkaerttle2,FllLevel
A Q4 mar 05 15:4%:37 25 Mar 05 16:14:14 1.00:1 -1 30302 215309 8743 v 38 §HSBrewkettleZ,FZInlet
A 04 Mar 05 15:49:37 25 Mar 05 16:14:14  1.00:1 -1 30302 21539 8763 0 40 $H3Brewkettlez,F2Lavel
A 04 Mar 05 15:49:37 25 Mar 05 16:14:14  1.00:1 -1 30302 21539 8763 0 42 $HsBrewkettle?,F3inletr
A Q4 mar 05 15:49:37 25 Mar 05 16:14:14 1.00:1 =il, 30302 215309 8743 v] 44 $HsBrewkettle2,F3iLevel
A Q4 Mar 05 15:4%:37 25 Mar 05 16:15:14 1.00:1 -1 30304 21540 8784 v 46 tt]‘EZ,F4 )t/

A B S3Sen A \

Mar us loild il

. . 1 1
Error Indication Mar 0§ 16:14:14 1.00:1 Entry Tables
Mar 05 16:14:14 1.00:1
Mar 05 16:14:14 1.00:1
| - - | Log IDs
I 5462 active Logs 0 Inactiwve Logs I
| Good values 539830646 o] |
IbadData Va]lues 12904187 o} I
nobata walues 4] 4]
IPercent Good 97.6654 MA, I Entry Tables Summary
!Logs with Errors: 3 !

Figure 96. Example Entry Tables Report

rrors.bxt - Notepad
File Edit Format Help

hsProcessohjs. @ 544 | 1. START 'Processobjsstart .

I0= 72,File= 31, , , , , , ,Bad DSxw 2
ID= 772,File= 381, 0 0 0 0 0 ,Bad Dsxw 2
ID= 774, File= 382, 0 0 0 0 0 ,Bad DSxw 2
hsProcessobjs. @ 808 | 1. sSTOP  'Processohjsstart ‘- 5459, time = 00:17:28 or 1048 sec
hsProcessob]s. @ 344 | 1. START 'Processohjsstart .

hsprocessobjs. @& 808 | 1. sToP  'Processobjsstart f— 3, Time = 00:01:44 or 104 sec

Figure 97. Error report
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Oracle Fails to Start

Problems with the DNS Server may in turn cause problems with Oracle. If you are
having problems with Oracle, check whether or not the DNS server is functioning
properly by testing the nslookup command. Run the command for the local node
and an external web site (for example www.cnn.com).

ﬂ External sites can only be tested if the DNS server has forwarding enabled to
resolve non-ppa zones AND a route to the internet is available.

Also try using both IP address and workstation name. Some examples are illustrated
in Figure 98.

ommand Prompt

C:~\Documents and Settings“ftt>nslookup 18.126.3.187
Server: engl2.rochny.uspra.abb.com
Address: 18.126.8.12

Mame = tarl@?7.rochny.uspra.abh.con
Address: 18.126.3.187

C:“Documents and Settings“ftt>nslookup 127.8.68.1
Server: engl2.rochny.uspra.abb.com
Address: 18.126.8.12

localhost
127.8.8.1

C:~Documents and Settings:ftt>nslookup www.cnn.com
Server: engl2.rochny.uspra.abb.com
Address: 18.126.8.12

Mame : cnn.

com
Addresses 64.236.16.52, 64.236.16.84, 64.236.16.116, 64.236.24.4
64.236.24.12, 64.236.24.28, 64.236.24.28, 64.236.16.28

Aliases WU . CNN . COm

C:~\Documents and Settings:ftt>nslookup tariB@?
Server: engl2.rochny.uspra.abb.com
Address: 18.126.8.12

Name = tari@? _rochny.uspra.abb.comn
Address: 18.126.3.187

C:“Documents and Settings“ftt>nslookup localhost
Server: engl2.rochny.uspra.abb.com
Addrezs: 18.126.8.12

localhost .rochny_uspra.abb.com
127.8.8.1

Figure 98. Checking the DNS Server
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Section 8 Information Management

Event Monitoring

Data coming from 800xA can stop sometimes and new updates are no longer
received. Error messages are generated by IM, but they are not alarms. IM has its
own OPC/AE Server to log events into the 800xA Event Storage Service when
needed. Messages will be logged to indicate potential problems with A/E and
Numeric Log collection as well as status information from Archival. The messages
are of category IM History. The user needs to review the messages that IM is

creating to ensure that IM is operating correctly.

Perform the following to set up and review these messages:

1. Create two new Aspects on the Inform IT History object in the Service

Structure:

— Alarm and Event List.
—  Alarm and Event List Configuration.

2. From the Configuration View of the Alarm and Event List Configuration

Aspect, select Simple Event > IM History (Figure 99).

@ Inform IT History : Alarm and Event List Configuration

ST -

"Fher | Runtivo Ftors | Cokis| Sot_ | Color | Fomat] Summon|

Source

IE\'ms 'I

Categories

B[ CondRion Events =
B-[7 Simple Events
[~ Defaut
License Managemen
Batch Management £
# [~ Operation
User Annobation
 Un-categorized Sinp
[~ Process Evenks
[7 System Events
OPC_SERVER_E|
" System Event fo
W
[~ MOD Disgnostic
[T Network Messag
[~ OPC_SERVER_EI
[~ GPC_SERVER_EI
~ Services
I System Administ

I System Simple E
[ System Status —

™ ‘Windows Events o
i il

Time | Condition State | Avea | Attribute Fiker |
Fiter On
& Event Time " Acknowlsdge Tme

Wiew From
' Newest

 Time: | si21 12:00:00

Wiew To
= Oldest

kL

 Time | siz1 12:00:00
" Duration

[

= =

Figure 99. Alarm and Event Configuration
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3. From the Configuration View of the Alarm and Event List Aspect, select the
Object radial button (Figure 100).

@ Inform IT History : Alarm and Event List i -10] x|
|l # ~[1nform 17 History:alarm and Evert Le =] % &5 a0 - - = |
~C
" Library Struckure ICc\mr.\m Alarm List Configuration: Alarm and Event List Configuration d
& Object |nform IT History: Alsrm and Event List Configuration =l

Alarm filker

& all alarms

" Object alarms

" Object and descendents

" Object and descendents in structure:

I I

List Title (For Alarm Band): I

[V show Tool Bar

I™ Show Status Bar

I Automatic enabling of Live Values (Current Value column is required)
I™ Automatic start of list when alarms are updated in stop mode

Figure 100. Object Configuration

4. The Alarm and Event List Aspect will now show only messages of category IM
History. Use the Configuration View of the Alarm and Event List
Configuration Aspect to configure the columns to display as shown in the
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following screen shot (Figure 101).

@8 Inform IT History : Alarm and Event List . =10] x|

I Ik o |
Q| i ‘I‘@@ HBE GIQ

Figure 101. Object Configuration

Diagnostics

Informational diagnostics such as the change of state of an archive volume or an IM
service do not require any action to be taken. Other diagnostics require some action
be taken as follows.

Diagnostics that need immediate action are as follows:

*  Ones that contain an ORA-nnnnn error or text starting with Failed to Extend.
An ORA-nnnnn event or an event starting with “Failed to Extend” indicates a
problem with the IM’s Oracle instance. Check the IM History Oracle Instance
Wizard and the alert_adva.log file for indication of a full table space or other
issue.

Diagnostics that need attention at some point in the future are as follows:

*  Collection received x ReadRaw failures in the last y minutes. ReadRaw errors
that occur repetitively indicate that either you are collecting too much from the
Connectivity Servers or you have not optimized the collection of IM Numeric
data from the Direct Logs.

Data Access Applications

This section provides guidelines for troubleshooting data access applications. This
includes DataDirect, Desktop Trends, Display Services, reports, and the Application
Scheduler.
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General Troubleshooting Tips

e Ifreports fail in unusual ways, check the Windows system heap as described in
Table 3 in Common Issues.

*  Using Run Now from the Scheduling Definition aspect - This creates a new
Green Running Jobs object, which will disappear upon successful completion,
or turn red on failure. The Running Jobs object has an aspect which will report
the error encountered.

*  Using the Test Action on the Action Aspect (Figure 102) - This runs the
report via the interactive or workplace user, instead of the Scheduler. This will
help you determine whether or not the scheduler is having problems. If you see
dialogs asking for userid/password or data source, this indicates the report will
not run when executed by the Scheduler. Also check the ODBC source
Localhost to make sure it was not configured with a userid (should be blank).

JJQ - |ABLNumericArchive:Action Aspect ;I .’c'j ,(? !

Test Action |
FtaaTu B B rchivve Action| Time Limit. {seconds]: l_ References N ﬁ
Isolated: W Pricrity: ll— Abternpts: ll_ Sy fcdd To Aspect Meru .. j
\ Properties... /

Archive Group I tar 105 Archivearoup: ABLMumeric T Wew. T

Archive Group State IInit

Service Group fim_TaR105

Archive Device ItarlDSArchivel j View... vl

Figure 102. Test Action Function on the Action Aspect

¢ Macro Security and Pop-up Dialogs - Security issues often cause reports to
hang due to resulting pop-up messages. Any error causing a dialog to pop up in
Excel for a report template interactively will also do so for the 800xA service
account running the task in the background. Macro Security settings can cause
this. If Visual Basic macros are defined in a particular report, Excel Macro
Security settings may need to be set lower for the 800xA Service Account. If
you are on the local workstation, listen for beeps. Beeps are an indication that a
dialog is popping up in the background.
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Make sure that you are logged in with the 800xA Service Account when
checking security issues, as this is the account used for generating the report.

Run Report Template manually in Excel - Use F9 with the Report Template
opened in Excel. Then Test functions separately. To pinpoint which
function(s) are failing, it helps to whittle the report down to individual function
calls and testing individually to identify the problematic one.

Try to run an empty report. Uncheck all Excel add-ins including DataDirect
This eliminates some situations where excel might pop up a dialog.

Test the function calls Interactively in Excel - The Microsoft Excel Function
wizard tries to execute functions each time a new parameter is entered. This
may cause Excel to crash. When using the function wizard, it is recommended
that you disable the functions from the option page.

General support for Crystal Reports - Refer to the following web site:
http://support.businessobjects.com/search/

www.crystalkeen.com
www.crystalbook.com
www.mindconnection.com
www.tech-tips.com

http://msdn.microsoft.com/library/default.asp?url=/library/en-
us/crystlmn/html/crsamsamples.asp

www.hammerman.com
www.kenhamady.com
www.chelseatech.co.nz

Fixing Large Reports (Long Execution Time)

If a report is taking much longer than it should to finish executing and no Time
Limit was configured for the action, other jobs in the queue may not run as
scheduled. To fix this, abort the job along with any Excel programs which may still
be running. Set a maximum time for Report Action Aspects, so the system will
terminate the report instance if a report hangs. This will give other working reports
the chance to execute. Also, increase the action time limit for large reports.
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Jobs waiting in the queue are shown in blue, and their state in the Job Log will be
Not run. If software is not installed properly, the Scheduler service may need to be
disabled and re-enabled and running jobs queue be manually deleted.

DataDirect Add-in Not Installed for 800xAService Account

The DataDirect Add-in must be installed for each user account that will use
DataDirect. This includes the Application Scheduler which runs as the
800xAService account.

Add-ins are automatically added for the installing user. If software is installed as a
user other than 800xAService, the DataDirect add-in must be added manually for
the 800xAService account. This must be done on all nodes where DataDirect
reports will be run by the application scheduler. Refer to the section on DataDirect
(Excel Data Access) in System 800xA Information Management 5.1 Data Access
and Reports (3BUF001094%).

Reading DataDirect (Excel) Reports from a FileViewer Aspect

This may cause both Excel and Plant Explorer windows to freeze. To fix this,
change the file opening set-up for Microsoft Excel Worksheets as follows:

In Windows Explorer, choose Tools > Folder Options.
Select the File Types tab.

Select the XLS Microsoft Excel Worksheet file type.
Click Advanced.

Uncheck the browse in same window check box.
Click OK in the Advanced dialog.

Click OK in the Folder Options dialog.

N kR =

Scheduler Service Group

The Service Group selection field in the Application Scheduler lets you choose
which server will execute a given job in the case where there are multiple nodes
running the Scheduling services. Jobs that do not have a service group selected will
display <default> in this field and will be executed by the primary service group.
The primary service group is determined to be the first service group created, not
necessarily the first one listed in the Service structure.
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It is recommended that you use this field to specify where (on which server node)
the scheduled job will run.

For systems having more then one Scheduler Service Group, make sure the default
Scheduler Service Group is pointing at the node where Crystal Reports is loaded. If
the default Service Group does not have Crystal reports, the report will fail to
execute with the following error:

/FAILED: Unable to open report into Crystal: Object variable of With block
not set.

The default Service Group for a Service is the first one listed in the Service structure
under the Scheduler category (they are listed alphabetically). You can add a
character for example - x,y,z, etc. can be added to the front of the names to get them
in the desired order.

Launch Permissions

The scheduler has 2 automation interfaces:

*  EXSingleAuto.clsExcel Automation — Excel Automation
*  CRSingleAuto.clsAutoSingleCR — Crystal Reports Automation

Installing a security fix may change the behavior of Excel or Crystal Reports.
If this occurs, use the following procedure to fix this problem:

1. Use the Windows Task Manager to terminate the EXSingleAuto.ex and
EXCEL.EXE processes, Figure 103. Multiple instances of the EXCEL.EXE
process indicates there are multiple instances of the report in the scheduling
queue. In this case you may want to disable the scheduling definition to prevent
further report instances from queuing.

2. Locate the DataDirect.INI file under:

C:\Documents and Settings\800xAServiceAccount\Application Data
\ABB Industrial IT\Inform IT\DataDirect\

where 800xaServiceAccount is the 800xa Service account as specified on
the Software and User Settings tab of the 800xA System Configuration
Wizard.
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B windows Task Manager 10l =|

File ©Options Yiew Help

Applications ~ Processes |Performance|

Image Name |__ e[ cru  cruTime [ Memusage [ 4|
hsPDLCollectar, 64 Juli) 0:00:03 15,052 K
hsMsgServer exe 3616 oo 0:00:00 12,680 K
hsLogman.exe 3608 oo 0:00:00 6,020 K
HSHIST~1.EXE 2352 Juli) 0:00:01 15,564 K
hsHDAServer .exe 3580 oo 0:00:00 12,968 K
hsEventLogColle 3548 00 0:00:01 12,764 K
hsCollection.ex 3540 00 0:00:00 14,044 K
hsCfgServer . exe 3532 00 0:00:00 7,200 K
hsarchive.exe 3964 00 0:00:00 7,952 K
hsarchive.exe 3504 00 0:00:00 74K
hsadmin.exe 3468 00 0:00:00 12,396 K
frzhser.exe 7a0 00 0:00:00 1,076 K

frxzhapp.exe 812 00 0:00:00 Fan kK
ExSingleAuto. ex 0 \ 3
explorer. exe 1044 oo 0:00:06 5,332 K

EXCEL.EXE 2005 Juli) 0:00:00 21,064 K
EHOPCAEServer.e 3460 Juli) 0:00:00 6,304 K
DSentry exe 1228 oo 0:00:00 1,308 K
Directed. exe 1168 oo 0:00:00 4,995 K
dbsnmp.exe 964 00 0:00:00 7,340 K
CSRSS.EXE 00 00 0:00:06 04k x|

End Process |

[Processes: 115 [cPU Usage: 13% [Mem Usage: 973776k | 3513616k

Figure 103. Terminating the EXSingleAuto and EXCEL Processes

3. Build an identical structure under both the All Users and Default User paths in
the same directory as follows:

C:\Documents and Settings\All Users\Application Data\ABB Industrial
IT\Inform IT\DataDirect\

and

C:\Documents and Settings\Default User\Application Data\ABB
Industrial IT\Inform IT\DataDirect\

4. Copy the DataDirect.INI file into both of these new paths.

Installation and Software

This section includes information on where to install various software applications,
software components, databases, and licensing information.
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Oracle

Oracle must be installed using the 800xA Administration account. Also Oracle
MUST be installed either from DVD, CD or Local disk. DO NOT use a network
disk. If the software is provided on a network disk, you must copy it to a local
temporary location in order to perform the installation.

Oracle 11 folder should be copied to a path without spaces to do the installation.
c:\oraclel1 OK
c:\my software folder\oracle11 Not OK.

Where to Install Information Management Software

Install the Information Management server software on an application server
dedicated to Information Management functionality. This application server will
also require all client/connect software components for all other functions being
installed in the system. For example, if your system uses AC 800M controllers, you
will also be required to install AC 800M Connect, and if your system uses Batch
Management functionality, you will require the Batch Management client. Refer to
the section on installing application servers in System 800xA Manual Installation
(3BSE034678%).

Install the Information Management Client Toolkit on ALL OTHER 800xA
system nodes (except the domain controller). This includes aspect servers,
connectivity servers, Batch and Asset Optimization application servers, workplace
clients, and engineering stations. Refer to the step-by-step instructions for each node
type in System 800xA Manual Installation (3BSE034678%).

The Information Management Display and Client Services are applications for
data access. They are automatically installed on the Information Management
server. You may also install these desktop applications on remote workstation
clients. These remote workstation clients DO NOT require any other 800xA system
software to be installed. Refer to the section on installing the Information
Management Display and Client Services in System 800xA Manual Installation
(3BSE034678%).
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Checking the Information Management Installation

Checking the Information Management Installation

Use Windows Add/Remove program (on Windows Control Panel) to verify that all
Information Management components have been installed. These components are

easy to recognize by the ABB Inform IT prefix, Table 17.

Also check the C:\ProgramData\A BB\IM\Instal\WILogResults log file after
installation. Use the HTML pages to view the installation logs.

Table 17. Information Management Components

Server

Client Toolkit"

Desktop Tools?

ABB Inform IT - Application Scheduler
ABB Inform IT - Calculations

ABB Inform IT - DataDirect

ABB Inform IT - Desktop Trends

ABB Inform IT - Display Services
ABB Inform IT - History

ABB Inform IT - Open Data Access
ABB PAS - System Services

ABB Open Access for 800xA

ABB Inform IT -
Application Scheduler
ABB Inform IT -
Calculations

ABB Inform IT - History
Client

ABB Inform IT - Open
Data Access

ABB Inform IT - DataDirect
ABB Inform IT - Display
Services (Client only)

ABB Inform IT - Desktop
Trends

ABB Inform IT - Open Data
Access Client

NOTES:

1. Client toolkit is installed on all nodes that are not Information Management servers. If the Client Toolkit is not
installed, when you attempt to view aspects related to Information Management those views will not be available.
2. Desktop Tools are installed on remote workstation clients or client toolkit nodes.

Guidelines for Configuring the History Database Instance

Take care to allocate sufficient disk space when you configure the History database
instance (post installation step). This will minimize the risk of having to re-allocate
space later, after historical data collection/storage has begun.

Be sure to configure the Oracle History table space for Index and Runtime large
enough to support your storage requirements. If these are not properly sized (when
you create the Oracle database instance), messages will be lost when these tables
reach their maximum size.

If your history application needs to support very large message logs, for example -
OPC message log: 12 million entries and PDL message log: 6 million entries - it is
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recommended that you increase the Oracle temp space accordingly. This is
described in the section on extending tablespace for Oracle-based history files in
System 800xA Information Management 5.1 Configuration (3BUF001092%).

For guidelines on sizing the history database, refer to the section on creating the
History database instance in System 800xA Information Management 5.1
Configuration (3BUF001092%).

For all systems, except very small systems:

1. Designate two separate disk drives for Oracle-based data storage and file-based
numeric logs. DO NOT use the drive where the Information Management
software and Oracle program files are installed.

2. Start with the option for OPC Message base installation. Use the database
instance wizard’s dialogs to refine your system sizing requirements.

Once you have made your selections, the wizard may take up to 30 minutes to create
the database instance, depending on the size of your application.

Adding a User for Oracle

For configuration/application building and runtime operations, it is recommended
that you log in as a different user (not the installing user). See the procedure creating
users and groups in System 800xA Manual Installation (3BSE034678%).

To support Information Management applications such as historical database
maintenance, and other administrative procedures one or more Industrial IT users
must be added to the ora_dba and HistoryAdmin groups. For further information,
refer to the section on managing users in System 800xA Information Management
5.1 Configuration (3BUF001092%*).

SQL*Plus

Refer to the guidelines for using SQL*Plus in System 800xA Information
Management 5.1 Data Access and Reports (3BUF001094%*). Check ORACLE_SID.
Set to ADVA if not already done.

Testing Oracle Connections
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Oracle is accessed by different applications by different methods. Each method
should be tested:

e SQLPLUS - log into history ADVA database:
user name = history, password = history

*  ODBC - Test the ODBC connection using Control Panel > Administrative
Tools > ODBC Source. If you need further guidelines, refer to the procedure
for adding an ODBC data source in the post installation procedure for
Information Management in System S800xA Manual Installation
(3BSE034678%*).

*  Check the ADO data provider for Oracle. Go to Control Panel > ADSS Service
Configuration. Check that the ADO data provider has been started and is
running.

e Verify ORACLE_SID is set to ADVA.

Service Names

Under normal circumstances, Oracle software is installed after the Information
Management application server has been added to a domain. Oracle detects that the
workstation belongs to a domain, adds a line with the domain name to the sqlnet.ora
file, and appends the domain name to all service names defined in the tnsnames.ora
file.

If for some reason Oracle is installed before the node is added to a domain, the
domain name will not be entered into the sqlnet.ora file. The HSEH service name
(created during Information Management software installation), and the
LOCALHOST service name (created as a post installation step) will have the
domain name appended. This will create a mismatch between these service names
and sqlnet.ora file, and cause these service names to fail.

To rectify this condition, enter the domain name in the sqlnet.ora file and update any
names in the tnsnames.ora file that do not have the domain name extension. This
procedure is described in the section on post installation for Information
Management in System 800xA Post Installation (3BUAO00156%).

License Keys
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Table 18 describes the Information Management Licenses.

Table 18. Information Management Licenses

Application

License

Description

History

HIST_SRVR
(History Server)

Controls the number of History Servers in the
system. It also tracks the number of Oracle licenses
sold.

History (continued)

HIST_LOGS,
HIST_DUAL_LOGS,
HIST_CONS_LOGS

Control the total number of History, Dual and
Consolidation logs in the system (Information
Management logs only, not basic history).

Display Services

MDI_DISP_BLDR

Controls the number of clients in the system that
can use the Display builder.

HIST_DISP Controls the number of clients in the system that
can use the History Displays.
Desktop Trends HIST_TREND Controls the number of clients in the system that
can use the History Trend displays.
DataDirect EXCEL_DA Controls the number of DataDirect clients in the

Excel Data Access

system.

Open Data Access

HIST_ODBC_SRVR
(History ODBC Server)

Counts the use of the Open data Access server. A
configuration setting is used to select what nodes
will run the ODBC server. When an ODBC server
starts up if will check out one count of the license
from the CLS.

HIST_ODBC Controls the number of clients in the system that
(History ODBC) can use the Historian ODBC Server.
Calculations CALC_SRVR Controls the number of Calculation Servers in a

system.
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Revision History

Introduction

This section provides information on the revision history of this User Manual.

Revision History

The following table lists the revision history of this User Manual.

release

Revision Description Date
Index

- First version published for 800xA 5.1 June 2010
A Updated for 800xA 5.1 Rev A release May 2011
B Updated for 800xA 5.1 Rev B release June 2012
C Updated for 800xA 5.1 Feature Pack 4 release February 2013
D Updated for 800xA 5.1 Rev D release December 2013
E Updated for 800xA 5.1 Rev E and FP4 Rev E July 2015

The revision index of this User Manual is not related to the 800xA 5.1 System
Revision.
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Updates in Revision Index A

Updates in Revision Index A
The following table shows the updates made in this User Manual for 800xA 5.1

Rev A.
Updated Section/Subsection Description of Update
Section 5, Import/Export Updated the Engineering Repository section.
Section 6, Backup and Restore Updated the 800xA System Backup section.
Section 8, Information Management Updated the images in the Performance Counters
section for IM API Counters, IM Archive Counters,
IM Collection Counters, and IM Storage Counters.

Updates in Revision Index B
The following table shows the updates made in this User Manual for 800xA 5.1

Rev B.
Updated Section/Subsection Description of Update

Section 2. System Check Updated the System Check List section.

Section 6. Backup and Restore Changes done in the 800xA for Advant Master and
Safeguard subsection in the Page 84 and 111.

Section 7. Single Node Replacement Procedure changes done in the Information
Management Server subsection

Front Cover Maintenance name is now updated in Line 2.
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Updates in Revision Index C

Updates in Revision Index C
The following table shows the updates made in this User Manual for 800xA 5.1

Feature Pack 4.
Updated Section/Subsection Description of Update

Section 6, Backup and Restore Updated the changes in the Precautionary Issues >
800xA for IEC 61850 subsection.
Updated the changes in the 800xA System Restore >
800xA for IEC 61850 subsection.

About this User Manual Updated the changes in the section.

Section 5, Import/Export Updated the Application Change Management
subsection.

Updates in Revision Index D
The following table shows the updates made in this User Manual for 800xA 5.1

Rev D.
Updated Section/Subsection Description of Update
Section 6, Backup and Restore Updated the changes in the Precautionary Issues >

Asset Optimization subsection.

Updated the changes in the Recover Function-
Specific Information> Asset Optimization subsection.
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Updates in Revision Index E
The following table shows the updates made in this User Manual for 800xA 5.1

Rev E and FP4 Rev E.
Updated Section/Subsection Description of Update

Section 8, Information Management Changes updated in Services and Processes
Related to Information Management > Windows
Services

Section 6. Backup and Restore Changes updated in the 800xA Advant Master and
Safeguard both in Backup and Restore sections.

Section 7. Single Node Replacement Changes are updated in the 800xA Advant Master
and Safeguard subsection.
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